Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Mozilla Thunderbird 1.5.0.4 compile error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
robselina
Apprentice
Apprentice


Joined: 05 Feb 2006
Posts: 165
Location: Socorro, NM, USA

PostPosted: Mon Jun 26, 2006 10:32 pm    Post subject: Mozilla Thunderbird 1.5.0.4 compile error Reply with quote

I'm stuck. Any help getting thunderbird to compile would be most appreciated!

Here's the error sequence:

Quote:

s -O2 -DMOZILLA_CLIENT -include ../../../mozilla-config.h -Wp,-MD,.deps/ns
le.pp nsModule.cpp
nsModule.cpp:45:27: nsCharsetMenu.h: No such file or directory
nsModule.cpp:46:34: nsFontPackageHandler.h: No such file or directory
nsModule.cpp: In function `nsresult nsFontPackageHandlerConstructor(nsISuppo
, const nsIID&, void**)':
nsModule.cpp:68: error: `nsFontPackageHandler' was not declared in this scop
nsModule.cpp:68: error: `inst' was not declared in this scope
nsModule.cpp:68: error: `nsFontPackageHandler' is not a type
nsModule.cpp: At global scope:
nsModule.cpp:112: error: `NS_CHARSETMENU_CID' was not declared in this scope
nsModule.cpp:113: error: expected `}' before "NS_CHARSETMENU_PID"
nsModule.cpp:113: error: expected `}' before "NS_CHARSETMENU_PID"
nsModule.cpp:113: error: invalid conversion from `const char*' to `PRUint16'
nsModule.cpp:113: error: expected `,' or `;' before "NS_CHARSETMENU_PID"
nsModule.cpp:114: error: expected declaration before '}' token
gmake[4]: *** [nsModule.o] Error 1
gmake[4]: Leaving directory `/var/tmp/portage/mozilla-thunderbird-1.5.0.4/wo
ozilla/xpfe/components/build2'
gmake[3]: *** [libs] Error 2
gmake[3]: Leaving directory `/var/tmp/portage/mozilla-thunderbird-1.5.0.4/wo
ozilla/xpfe/components'
gmake[2]: *** [libs] Error 2
gmake[2]: Leaving directory `/var/tmp/portage/mozilla-thunderbird-1.5.0.4/wo
ozilla/xpfe'
gmake[1]: *** [tier_50] Error 2
gmake[1]: Leaving directory `/var/tmp/portage/mozilla-thunderbird-1.5.0.4/wo
ozilla'
make: *** [default] Error 2

!!! ERROR: mail-client/mozilla-thunderbird-1.5.0.4 failed.
Call stack:
ebuild.sh, line 1539: Called dyn_compile
ebuild.sh, line 939: Called src_compile
mozilla-thunderbird-1.5.0.4.ebuild, line 117: Called die

!!! (no error message)
!!! If you need support, post the topmost build error, and the call stack if
evant.


Thanks,

Rob
Back to top
View user's profile Send private message
artic
Veteran
Veteran


Joined: 22 Nov 2003
Posts: 1208

PostPosted: Tue Jun 27, 2006 12:44 am    Post subject: Reply with quote

You can use the bin version of thunderbird avaliable in portage ..................
_________________
Pwd by Gentoo | 2.6.28-gentoo-x64 | kde4.2| ext4 | xorg 7.4 |
Back to top
View user's profile Send private message
robselina
Apprentice
Apprentice


Joined: 05 Feb 2006
Posts: 165
Location: Socorro, NM, USA

PostPosted: Tue Jun 27, 2006 2:09 pm    Post subject: Reply with quote

yea, really don't like using binaries, would rather compile it locally if I can.....I have a working version 1.0.7, it's failing during an update....
Back to top
View user's profile Send private message
Minot
Tux's lil' helper
Tux's lil' helper


Joined: 01 Apr 2004
Posts: 86
Location: Colorado

PostPosted: Mon Jul 17, 2006 10:59 am    Post subject: Same Thunderbird compile error Reply with quote

I got the exact same error. Has there been a solution to this e-build compile error? The original post is almost a month old. Here is my emerge -V output:
Code:
Portage 2.1-r1 (default-linux/x86/2006.0, gcc-20050130, glibc-2.3.4.20041102-r1, 2.6.16-gentoo-r13 i686)

This is a version of GENTOO from one of the 2005 CDs. I'm trying to update it. Could my GCC or GLIBC be the problem? I also had a failure on Openoffice2, but I'll search for a solution to that one next. Thanks!

-MINOT-
Back to top
View user's profile Send private message
smlki
n00b
n00b


Joined: 30 Jun 2005
Posts: 12

PostPosted: Tue Jul 18, 2006 8:13 pm    Post subject: Reply with quote

artic wrote:
You can use the bin version of thunderbird avaliable in portage ..................

Unfortunately the binary version does not run with a gcc-3.4.6 or higher system (no binary does, so bye bye acroread).
Code:
~ $ thunderbird
No running windows found
Removing /home/smlki/.thunderbird/ou0cmnni.default/compreg.dat leftover from older thunderbird
Removing /home/smlki/.thunderbird/ou0cmnni.default/XUL.mfasl leftover from older thunderbird
/opt/thunderbird/thunderbird-bin: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory
thunderbird-bin exited with non-zero status (127)

Please do not answer "downgrade to gcc 3.3". This is no solution.
Back to top
View user's profile Send private message
dhris
Tux's lil' helper
Tux's lil' helper


Joined: 28 Nov 2004
Posts: 90

PostPosted: Wed Aug 09, 2006 1:33 am    Post subject: Reply with quote

The following fix worked for me, which was the solution to this same problem when it arose a few months ago:
Code:
MAKEOPTS="-j1" emerge mozilla-thunderbird   

I'm somewhat surprised that more people aren't complaining about this.
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4830
Location: Gothenburg, Sweden

PostPosted: Sat Aug 19, 2006 3:24 pm    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads in favour of topic 468699.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum