Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
revdep-rebuild problem after update ... [became irrelevant]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
equaeghe
Apprentice
Apprentice


Joined: 22 Feb 2005
Posts: 273

PostPosted: Mon Jun 26, 2006 9:30 pm    Post subject: revdep-rebuild problem after update ... [became irrelevant] Reply with quote

EDIT: this post has become irrelevant due to a gentoo reinstall

Hi,

after updating kde from 3.4.3 to 3.5.2 (and possibly also due to an update of gcc to 3.4.5 and now 3.4.6-r1), revdep-rebuild wants to re-emerge gcc again and again and complains about a lot of kde (and koffice) libraries and some gcj libraries (I have the gcj use flag set). (BTW: I unmerged kde 3.4.3.)

Letting gcc re-emerge does not solve anything. Re-emerging koffice, kdevelop, and friends did resolve part of the kde-complaints, but most complaints remain (all concerning lib's pointing to the now non-existing kde 3.4 lib dir).

Anybody knows how to get rid of this? If you need more info to help: just say what.

Erik

P.S.: revdep-rebuild -p output follows

Code:

Configuring search environment for revdep-rebuild

Checking reverse dependencies...

Packages containing binaries and libraries broken by a package update
will be emerged.

Collecting system binaries and libraries... done.
  (/root/.revdep-rebuild.1_files)

Collecting complete LD_LIBRARY_PATH... done.
  (/root/.revdep-rebuild.2_ldpath)

Checking dynamic linking consistency...
  broken /usr/lib64/gcc-lib/x86_64-pc-linux-gnu/3.4.6/lib-org-w3c-dom.la (requires /usr/lib/../lib64/libgcj.la)
  broken /usr/lib64/gcc-lib/x86_64-pc-linux-gnu/3.4.6/lib-org-xml-sax.la (requires /usr/lib/../lib64/libgcj.la)
  broken /usr/lib64/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libktexteditor.la)
  broken /usr/lib64/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libkabc.la)
  broken /usr/lib64/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libvcard.la)
  broken /usr/lib64/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libkresources.la)
  broken /usr/lib64/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libkparts.la)
  broken /usr/lib64/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libkscript.la)
  broken /usr/lib64/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libkio.la)
  broken /usr/lib64/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libkdeui.la)
  broken /usr/lib64/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libkdesu.la)
  broken /usr/lib64/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libkwalletclient.la)
  broken /usr/lib64/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libcvsservice.la)
  broken /usr/lib64/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libkdecore.la)
  broken /usr/lib64/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libDCOP.la)
  broken /usr/lib64/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libkdefx.la)
  broken /usr/lib64/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libktexteditor.la)
  broken /usr/lib64/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkabc.la)
  broken /usr/lib64/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libvcard.la)
  broken /usr/lib64/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkresources.la)
  broken /usr/lib64/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkscript.la)
  broken /usr/lib64/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkhtml.la)
  broken /usr/lib64/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkjs.la)
  broken /usr/lib64/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkdeprint.la)
  broken /usr/lib64/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkparts.la)
  broken /usr/lib64/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkutils.la)
  broken /usr/lib64/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkio.la)
  broken /usr/lib64/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkdeui.la)
  broken /usr/lib64/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkdesu.la)
  broken /usr/lib64/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkwalletclient.la)
  broken /usr/lib64/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libcvsservice.la)
  broken /usr/lib64/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkdecore.la)
  broken /usr/lib64/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libDCOP.la)
  broken /usr/lib64/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkdefx.la)
  broken /usr/lib64/kde3/libkspelltool.la (requires /usr/kde/3.4/lib64/libkdeprint.la)
  broken /usr/lib64/kde3/libkspelltool.la (requires /usr/kde/3.4/lib64/libkparts.la)
  broken /usr/lib64/kde3/libkspelltool.la (requires /usr/kde/3.4/lib64/libkabc.la)
  broken /usr/lib64/kde3/libkspelltool.la (requires /usr/kde/3.4/lib64/libvcard.la)
  broken /usr/lib64/kde3/libkspelltool.la (requires /usr/kde/3.4/lib64/libkresources.la)
  broken /usr/lib64/kde3/libkspelltool.la (requires /usr/kde/3.4/lib64/libkio.la)
  broken /usr/lib64/kde3/libkspelltool.la (requires /usr/kde/3.4/lib64/libkdesu.la)
  broken /usr/lib64/kde3/libkspelltool.la (requires /usr/kde/3.4/lib64/libkwalletclient.la)
  broken /usr/lib64/kde3/libkspelltool.la (requires /usr/kde/3.4/lib64/libkdeui.la)
  broken /usr/lib64/kde3/libkspelltool.la (requires /usr/kde/3.4/lib64/libkdecore.la)
  broken /usr/lib64/kde3/libkspelltool.la (requires /usr/kde/3.4/lib64/libDCOP.la)
  broken /usr/lib64/kde3/libkspelltool.la (requires /usr/kde/3.4/lib64/libkdefx.la)
  broken /usr/lib64/kde3/libwpimport.la (requires /usr/kde/3.4/lib64/libkdeprint.la)
  broken /usr/lib64/kde3/libwpimport.la (requires /usr/kde/3.4/lib64/libkparts.la)
  broken /usr/lib64/kde3/libwpimport.la (requires /usr/kde/3.4/lib64/libkabc.la)
  broken /usr/lib64/kde3/libwpimport.la (requires /usr/kde/3.4/lib64/libvcard.la)
  broken /usr/lib64/kde3/libwpimport.la (requires /usr/kde/3.4/lib64/libkresources.la)
  broken /usr/lib64/kde3/libwpimport.la (requires /usr/kde/3.4/lib64/libkio.la)
  broken /usr/lib64/kde3/libwpimport.la (requires /usr/kde/3.4/lib64/libkdeui.la)
  broken /usr/lib64/kde3/libwpimport.la (requires /usr/kde/3.4/lib64/libkdesu.la)
  broken /usr/lib64/kde3/libwpimport.la (requires /usr/kde/3.4/lib64/libkwalletclient.la)
  broken /usr/lib64/kde3/libwpimport.la (requires /usr/kde/3.4/lib64/libkdecore.la)
  broken /usr/lib64/kde3/libwpimport.la (requires /usr/kde/3.4/lib64/libDCOP.la)
  broken /usr/lib64/kde3/libwpimport.la (requires /usr/kde/3.4/lib64/libkdefx.la)
  broken /usr/lib64/kword.la (requires /usr/kde/3.4/lib64/libkdeprint.la)
  broken /usr/lib64/kword.la (requires /usr/kde/3.4/lib64/libkparts.la)
  broken /usr/lib64/kword.la (requires /usr/kde/3.4/lib64/libkabc.la)
  broken /usr/lib64/kword.la (requires /usr/kde/3.4/lib64/libvcard.la)
  broken /usr/lib64/kword.la (requires /usr/kde/3.4/lib64/libkresources.la)
  broken /usr/lib64/kword.la (requires /usr/kde/3.4/lib64/libkio.la)
  broken /usr/lib64/kword.la (requires /usr/kde/3.4/lib64/libkdeui.la)
  broken /usr/lib64/kword.la (requires /usr/kde/3.4/lib64/libkdesu.la)
  broken /usr/lib64/kword.la (requires /usr/kde/3.4/lib64/libkwalletclient.la)
  broken /usr/lib64/kword.la (requires /usr/kde/3.4/lib64/libkdecore.la)
  broken /usr/lib64/kword.la (requires /usr/kde/3.4/lib64/libDCOP.la)
  broken /usr/lib64/kword.la (requires /usr/kde/3.4/lib64/libkdefx.la)
  broken /usr/lib64/libkformula.la (requires /usr/kde/3.4/lib64/libkdeprint.la)
  broken /usr/lib64/libkformula.la (requires /usr/kde/3.4/lib64/libkparts.la)
  broken /usr/lib64/libkformula.la (requires /usr/kde/3.4/lib64/libkabc.la)
  broken /usr/lib64/libkformula.la (requires /usr/kde/3.4/lib64/libvcard.la)
  broken /usr/lib64/libkformula.la (requires /usr/kde/3.4/lib64/libkresources.la)
  broken /usr/lib64/libkformula.la (requires /usr/kde/3.4/lib64/libkspell.la)
  broken /usr/lib64/libkformula.la (requires /usr/kde/3.4/lib64/libkutils.la)
  broken /usr/lib64/libkformula.la (requires /usr/kde/3.4/lib64/libkio.la)
  broken /usr/lib64/libkformula.la (requires /usr/kde/3.4/lib64/libkdeui.la)
  broken /usr/lib64/libkformula.la (requires /usr/kde/3.4/lib64/libkdesu.la)
  broken /usr/lib64/libkformula.la (requires /usr/kde/3.4/lib64/libkwalletclient.la)
  broken /usr/lib64/libkformula.la (requires /usr/kde/3.4/lib64/libkdecore.la)
  broken /usr/lib64/libkformula.la (requires /usr/kde/3.4/lib64/libDCOP.la)
  broken /usr/lib64/libkformula.la (requires /usr/kde/3.4/lib64/libkdefx.la)
  broken /usr/lib64/libkospell.la (requires /usr/kde/3.4/lib64/libkdeui.la)
  broken /usr/lib64/libkospell.la (requires /usr/kde/3.4/lib64/libkdecore.la)
  broken /usr/lib64/libkospell.la (requires /usr/kde/3.4/lib64/libDCOP.la)
  broken /usr/lib64/libkospell.la (requires /usr/kde/3.4/lib64/libkdefx.la)
  broken /usr/lib/gcc-lib/x86_64-pc-linux-gnu/3.4.6/lib-org-w3c-dom.la (requires /usr/lib/../lib64/libgcj.la)
  broken /usr/lib/gcc-lib/x86_64-pc-linux-gnu/3.4.6/lib-org-xml-sax.la (requires /usr/lib/../lib64/libgcj.la)
  broken /usr/lib/gcc/x86_64-pc-linux-gnu/3.4.6/lib-org-w3c-dom.la (requires /usr/lib/../lib64/libgcj.la)
  broken /usr/lib/gcc/x86_64-pc-linux-gnu/3.4.6/lib-org-xml-sax.la (requires /usr/lib/../lib64/libgcj.la)
  broken /usr/lib/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libktexteditor.la)
  broken /usr/lib/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libkabc.la)
  broken /usr/lib/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libvcard.la)
  broken /usr/lib/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libkresources.la)
  broken /usr/lib/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libkparts.la)
  broken /usr/lib/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libkscript.la)
  broken /usr/lib/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libkio.la)
  broken /usr/lib/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libkdeui.la)
  broken /usr/lib/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libkdesu.la)
  broken /usr/lib/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libkwalletclient.la)
  broken /usr/lib/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libcvsservice.la)
  broken /usr/lib/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libkdecore.la)
  broken /usr/lib/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libDCOP.la)
  broken /usr/lib/kde3/libcvsserviceintegrator.la (requires /usr/kde/3.4/lib64/libkdefx.la)
  broken /usr/lib/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libktexteditor.la)
  broken /usr/lib/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkabc.la)
  broken /usr/lib/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libvcard.la)
  broken /usr/lib/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkresources.la)
  broken /usr/lib/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkscript.la)
  broken /usr/lib/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkhtml.la)
  broken /usr/lib/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkjs.la)
  broken /usr/lib/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkdeprint.la)
  broken /usr/lib/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkparts.la)
  broken /usr/lib/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkutils.la)
  broken /usr/lib/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkio.la)
  broken /usr/lib/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkdeui.la)
  broken /usr/lib/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkdesu.la)
  broken /usr/lib/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkwalletclient.la)
  broken /usr/lib/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libcvsservice.la)
  broken /usr/lib/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkdecore.la)
  broken /usr/lib/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libDCOP.la)
  broken /usr/lib/kde3/libkdevcvsservice.la (requires /usr/kde/3.4/lib64/libkdefx.la)
  broken /usr/lib/kde3/libkspelltool.la (requires /usr/kde/3.4/lib64/libkdeprint.la)
  broken /usr/lib/kde3/libkspelltool.la (requires /usr/kde/3.4/lib64/libkparts.la)
  broken /usr/lib/kde3/libkspelltool.la (requires /usr/kde/3.4/lib64/libkabc.la)
  broken /usr/lib/kde3/libkspelltool.la (requires /usr/kde/3.4/lib64/libvcard.la)
  broken /usr/lib/kde3/libkspelltool.la (requires /usr/kde/3.4/lib64/libkresources.la)
  broken /usr/lib/kde3/libkspelltool.la (requires /usr/kde/3.4/lib64/libkio.la)
  broken /usr/lib/kde3/libkspelltool.la (requires /usr/kde/3.4/lib64/libkdesu.la)
  broken /usr/lib/kde3/libkspelltool.la (requires /usr/kde/3.4/lib64/libkwalletclient.la)
  broken /usr/lib/kde3/libkspelltool.la (requires /usr/kde/3.4/lib64/libkdeui.la)
  broken /usr/lib/kde3/libkspelltool.la (requires /usr/kde/3.4/lib64/libkdecore.la)
  broken /usr/lib/kde3/libkspelltool.la (requires /usr/kde/3.4/lib64/libDCOP.la)
  broken /usr/lib/kde3/libkspelltool.la (requires /usr/kde/3.4/lib64/libkdefx.la)
  broken /usr/lib/kde3/libwpimport.la (requires /usr/kde/3.4/lib64/libkdeprint.la)
  broken /usr/lib/kde3/libwpimport.la (requires /usr/kde/3.4/lib64/libkparts.la)
  broken /usr/lib/kde3/libwpimport.la (requires /usr/kde/3.4/lib64/libkabc.la)
  broken /usr/lib/kde3/libwpimport.la (requires /usr/kde/3.4/lib64/libvcard.la)
  broken /usr/lib/kde3/libwpimport.la (requires /usr/kde/3.4/lib64/libkresources.la)
  broken /usr/lib/kde3/libwpimport.la (requires /usr/kde/3.4/lib64/libkio.la)
  broken /usr/lib/kde3/libwpimport.la (requires /usr/kde/3.4/lib64/libkdeui.la)
  broken /usr/lib/kde3/libwpimport.la (requires /usr/kde/3.4/lib64/libkdesu.la)
  broken /usr/lib/kde3/libwpimport.la (requires /usr/kde/3.4/lib64/libkwalletclient.la)
  broken /usr/lib/kde3/libwpimport.la (requires /usr/kde/3.4/lib64/libkdecore.la)
  broken /usr/lib/kde3/libwpimport.la (requires /usr/kde/3.4/lib64/libDCOP.la)
  broken /usr/lib/kde3/libwpimport.la (requires /usr/kde/3.4/lib64/libkdefx.la)
  broken /usr/lib/kword.la (requires /usr/kde/3.4/lib64/libkdeprint.la)
  broken /usr/lib/kword.la (requires /usr/kde/3.4/lib64/libkparts.la)
  broken /usr/lib/kword.la (requires /usr/kde/3.4/lib64/libkabc.la)
  broken /usr/lib/kword.la (requires /usr/kde/3.4/lib64/libvcard.la)
  broken /usr/lib/kword.la (requires /usr/kde/3.4/lib64/libkresources.la)
  broken /usr/lib/kword.la (requires /usr/kde/3.4/lib64/libkio.la)
  broken /usr/lib/kword.la (requires /usr/kde/3.4/lib64/libkdeui.la)
  broken /usr/lib/kword.la (requires /usr/kde/3.4/lib64/libkdesu.la)
  broken /usr/lib/kword.la (requires /usr/kde/3.4/lib64/libkwalletclient.la)
  broken /usr/lib/kword.la (requires /usr/kde/3.4/lib64/libkdecore.la)
  broken /usr/lib/kword.la (requires /usr/kde/3.4/lib64/libDCOP.la)
  broken /usr/lib/kword.la (requires /usr/kde/3.4/lib64/libkdefx.la)
  broken /usr/lib/libkformula.la (requires /usr/kde/3.4/lib64/libkdeprint.la)
  broken /usr/lib/libkformula.la (requires /usr/kde/3.4/lib64/libkparts.la)
  broken /usr/lib/libkformula.la (requires /usr/kde/3.4/lib64/libkabc.la)
  broken /usr/lib/libkformula.la (requires /usr/kde/3.4/lib64/libvcard.la)
  broken /usr/lib/libkformula.la (requires /usr/kde/3.4/lib64/libkresources.la)
  broken /usr/lib/libkformula.la (requires /usr/kde/3.4/lib64/libkspell.la)
  broken /usr/lib/libkformula.la (requires /usr/kde/3.4/lib64/libkutils.la)
  broken /usr/lib/libkformula.la (requires /usr/kde/3.4/lib64/libkio.la)
  broken /usr/lib/libkformula.la (requires /usr/kde/3.4/lib64/libkdeui.la)
  broken /usr/lib/libkformula.la (requires /usr/kde/3.4/lib64/libkdesu.la)
  broken /usr/lib/libkformula.la (requires /usr/kde/3.4/lib64/libkwalletclient.la)
  broken /usr/lib/libkformula.la (requires /usr/kde/3.4/lib64/libkdecore.la)
  broken /usr/lib/libkformula.la (requires /usr/kde/3.4/lib64/libDCOP.la)
  broken /usr/lib/libkformula.la (requires /usr/kde/3.4/lib64/libkdefx.la)
  broken /usr/lib/libkospell.la (requires /usr/kde/3.4/lib64/libkdeui.la)
  broken /usr/lib/libkospell.la (requires /usr/kde/3.4/lib64/libkdecore.la)
  broken /usr/lib/libkospell.la (requires /usr/kde/3.4/lib64/libDCOP.la)
  broken /usr/lib/libkospell.la (requires /usr/kde/3.4/lib64/libkdefx.la)
 done.
  (/root/.revdep-rebuild.3_rebuild)

Assigning files to ebuilds... done.
  (/root/.revdep-rebuild.4_ebuilds)

Evaluating package order... done.
  (/root/.revdep-rebuild.5_order)

All prepared. Starting rebuild...
emerge --oneshot -p =sys-devel/gcc-3.4.6-r1

These are the packages that would be merged, in order:

Calculating dependencies   ... done!
[ebuild   R   ] sys-devel/gcc-3.4.6-r1 
Now you can remove -p (or --pretend) from arguments and re-run revdep-rebuild.


Last edited by equaeghe on Mon Aug 07, 2006 8:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
marbraun
n00b
n00b


Joined: 27 Jun 2006
Posts: 4

PostPosted: Tue Jun 27, 2006 7:29 am    Post subject: Same problem Reply with quote

Hi!

I almost have the same problem. I updated from KDE 3.4.x to 3.5.x and revdep-rebuild wants to rebuild gcc all the time. I solved the problem with the KDE libraries by just uninstalling all the KDE 3.4.x packages, because they were not needed anymore, but portage still keeps them. Maybe figure out, if you still need them.

Martin
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7820

PostPosted: Sun Feb 18, 2007 10:37 am    Post subject: Reply with quote

This has been discussed in topic: "Persistent revdep-rebuild issues: gcc and libgcj.la".

Moved from Portage & Programming to Duplicate Threads.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum