Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dev-python/pyopengl-2.0.1.09 emerge failuare
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
nastasa_andrey
n00b
n00b


Joined: 24 Mar 2004
Posts: 64

PostPosted: Thu Jun 22, 2006 2:57 pm    Post subject: dev-python/pyopengl-2.0.1.09 emerge failuare Reply with quote

Hello. I want to compile gnome and i get this error:
Code:

gcc-config error: Could not run/locate "i386-pc-linux-gnu-gcc"
error: command 'i386-pc-linux-gnu-gcc' failed with exit status 1

!!! ERROR: dev-python/pyopengl-2.0.0.44 failed.
Call stack:
  ebuild.sh, line 1539:   Called dyn_compile
  ebuild.sh, line 939:   Called src_compile
  ebuild.sh, line 1248:   Called distutils_src_compile
  distutils.eclass, line 38:   Called die

!!! compilation failed
!!! If you need support, post the topmost build error, and the call stack if relevant.


emerge --info returns this:
Code:

Portage 2.1 (default-linux/x86/no-nptl, gcc-4.1.1, glibc-2.3.6-r4, 2.6.16-gentoo-r9 i686)
=================================================================
System uname: 2.6.16-gentoo-r9 i686 Intel(R) Pentium(R) 4 CPU 2.80GHz
Gentoo Base System version 1.6.14
dev-lang/python:     2.4.2
dev-python/pycrypto: [Not Present]
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r2
sys-devel/gcc-config: 1.3.13-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -fforce-addr -fomit-frame-pointer -ftracer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /var/opt/axigen/run /var/qmail/alias /var/qmail/control /var/vpopmail/domains /var/vpopmail/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/terminfo"
CXXFLAGS="-O2 -march=pentium4 -fforce-addr -fomit-frame-pointer -ftracer -pipe -fvisibility-inlines-hidden"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.lug.ro/gentoo http://ftp.lug.ro/gentoo/ http://ftp.roedu.net/pub/mirrors/gentoo.org/ ftp://ftp.roedu.net/pub/mirrors/gentoo.org/ ftp://ftp.romnet.org/gentoo/ http://ftp.romnet.org/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/opt/axigen/portage-axigen"
SYNC="rsync://rsync.ro.gentoo.org/gentoo-portage"
USE="x86 X alsa apache2 apm arts authdaemond avi berkdb bitmap-fonts cdr cli crypt cups dri dvd eds emboss encode foomaticdb fortran gdbm gif gpm gstreamer gtk2 imap imlib ipv6 isdnlog jpeg kde libg++ libwww mad maildir mikmod motif mp3 mpeg ncurses nls ogg opengl oss pam pcre pdflib perl png pppd python qt quicktime readline reflection sdl session spell spl ssl tcpd truetype truetype-fonts type1-fonts valias vhosts vorbis xml xmms xorg xv zlib elibc_glibc kernel_linux userland_GNU"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS


So i am using gcc-4.1.1 and CBUILD="i686-pc-linux-gnu". It seems that the package is looking for i386-pc-linux-gnu-gcc and fails.
gcc-config -l returns:
Code:

 [1] i686-pc-linux-gnu-3.4.6
 [2] i686-pc-linux-gnu-3.4.6-hardened
 [3] i686-pc-linux-gnu-3.4.6-hardenednopie
 [4] i686-pc-linux-gnu-3.4.6-hardenednopiessp
 [5] i686-pc-linux-gnu-3.4.6-hardenednossp
 [6] i686-pc-linux-gnu-4.1.1 *


So ... does anybody have any ideea what i can do?
Back to top
View user's profile Send private message
nastasa_andrey
n00b
n00b


Joined: 24 Mar 2004
Posts: 64

PostPosted: Fri Jun 23, 2006 6:46 am    Post subject: Reply with quote

Does anybody have any ideea? I have more and more packages that look for i386-pc-linux-gnu-gcc and i do not know what to do, for i have i686-pc-linux-gnu-gcc
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Fri Jun 23, 2006 6:58 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads.

See https://forums.gentoo.org/viewtopic-t-321340.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum