Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ATI DRIVERS] libgl error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Goumize
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2006
Posts: 127
Location: Marrakech

PostPosted: Wed Oct 25, 2006 9:49 am    Post subject: [ATI DRIVERS] libgl error Reply with quote

Les problemes avec les drivers de chez ATI sont toujours un sujet de debat vu le mauvais fonctionnement de ces derniers et surtout pour les laptops,

Ma configuration: HP compaq AMDTurion64 NX 6125 ATI XPRESS 200M.

J'ai tester les drivers stable dans portage (8.27) pour faire tourner Xgl mais sans succés, j'ai demasquer par la suite les DRIVERS 8.29.6; mais hélas en activant l'extension Composite dans Xorg le direct rendering passait en inactif DISABLED, meme en ajoutant l'option AllowGLXWithComposite cela ne changeait rien.

J'ai decider de downgrader les drivers en faveur de la version 8.28, et en passant au crible le log Xorg il semble que le Pilote est bien en marche aucune erreur dans le log, tout semble etre operationnel encore mieux que la version 8.29.

Mais hélas un fglrxinfo me renvoi cette erreur:

Code:
ERROR: DDX driver fingerprint mismatch: got 0x84220BA7, but expected 0x781B6E97
libGL error: InitDriver failed
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)


J'ai fait un petit tour sur le net pour voir l'origine du probleme, il semble que c'est un bug, et il est resolu sur le forum de Ubuntu en remplacant le fichier Libgl.so.1.2 par une version qqu'un internaute propose, j'ai pas tenter cette experience car elle me semble assez hors normes.

J'ai retrouver mon erreur dans l'un des liens du How to ATI de El goretto sur ce meme forum, pour resoudre l'erreur le how to proposait de passer en mode console et unloader le module fglrx avant de le recompiler, mais hélas cela n'a pas resolu mon probleme.

si quelqu'un à une solution à ce probléme, je suis preneur.

Merci d'avance
_________________
"If you make something simple enough for an idiot to use, only an idiot will want to use it." Thomas Cort
Back to top
View user's profile Send private message
nykos
Guru
Guru


Joined: 08 Jun 2005
Posts: 488
Location: Strasbourg

PostPosted: Wed Oct 25, 2006 5:52 pm    Post subject: Re: [ATI DRIVERS] libgl error Reply with quote

Quote:
Les problemes avec les drivers de chez ATI sont toujours un sujet de debat vu le mauvais fonctionnement de ces derniers et surtout pour les laptops.


Drôle de façon d'introduire son problème ! Ca fait plusieurs jours qu'il n'y a pas eu de nouveau post au sujet des drivers ATI donc je pense que ça marche de mieux en mieux (ou que de moins en moins de personnes les utilises mais bon ça je pense pas).

Par contre j'utilise pas XGL donc je peux pas trop t'aider, désolé. Si j'ai le temps j'essairai une fois mais pas dans les prochains jours...
_________________
-=Nykos=-
TARGA Traveller 826T - AMD Turion 64 MT 32 1,8GHz - ATI Radeon X700 Mobility (ati-drivers)
Back to top
View user's profile Send private message
Goumize
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2006
Posts: 127
Location: Marrakech

PostPosted: Wed Oct 25, 2006 6:15 pm    Post subject: Re: [ATI DRIVERS] libgl error Reply with quote

nykos wrote:
Quote:
Les problemes avec les drivers de chez ATI sont toujours un sujet de debat vu le mauvais fonctionnement de ces derniers et surtout pour les laptops.


Drôle de façon d'introduire son problème ! Ca fait plusieurs jours qu'il n'y a pas eu de nouveau post au sujet des drivers ATI donc je pense que ça marche de mieux en mieux (ou que de moins en moins de personnes les utilises mais bon ça je pense pas).


Je pense que c'est la realité, Vu le nombre de post sur ces drivers, et surtout l'efficacité (en les comparant a nVidia car j'ai deux autres UC sous nVidia), les problémes de fonctionnement de ces drivers sont loin d'etre maitrisés par la communauté du libre, et surtout par moi meme :(

Je precise que j'ai un chip 200M en bus XPRESS, je suis pas le seul à etre confronter a des problemes de fonctionnement du drivers, d'ailleurs j'ai deja poster pour autres problemes sur ce meme chip.

Pour Xgl c'est pas ma priorité, du moment que ma carte fonctionne correctement avec la 3d operationnelle le reste vient naturellement.

Enfin je prie que ATI suit le meme chemin que nVidia, ca arrangera bien du monde. (les derniers drivers datent de plus de 4mois).
_________________
"If you make something simple enough for an idiot to use, only an idiot will want to use it." Thomas Cort
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3098
Location: Paris

PostPosted: Thu Oct 26, 2006 5:36 am    Post subject: Re: [ATI DRIVERS] libgl error Reply with quote

Goumize wrote:
les derniers drivers datent de plus de 4mois).

Non.

Rationalise un peu tes propos. Le support des chip mobiles est pas top. Pour le reste, pas grand chose à redire en règle générale.
+1 Nykos, on pourrait faire des stats, mais sur les 12 derniers mois, c'est devenu bien tranquille, côté SAVAGE. Enfin, si on esxcepte tous ceux qui veulent du XGL&co, sans passer par la case départ "çà marche sous X?".
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
Goumize
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2006
Posts: 127
Location: Marrakech

PostPosted: Thu Oct 26, 2006 6:10 am    Post subject: Reply with quote

El_Goretto wrote:
Rationalise un peu tes propos. Le support des chip mobiles est pas top. Pour le reste, pas grand chose à redire en règle générale.


Pour la version 8.29.6 elle date du 20/09/2006

Code:
Notes:

   1. The drivers below support English only.
   2. The display driver requires POSIX shared memory to be enabled on the system.
   3. Kernel Source package is no longer required if Kernel Header package is installed.
   4. 32-Bit packages must be installed for 64-Bit Linux drivers to install or work.

Installer
   Download Link    File Size (MB)    Date Posted    Additional Info
ATI Driver Installer
   Download    55.0    09/20/06    Version: 8.29.6


c'est justement la versions qui n'est toujours pas stable dans l"arbre portage la 8.28 aussi et en instable.
Donc ya que la version 8.27 qui pour portage est stable, c'est de celle ci dont je parlais.
El_Goretto wrote:

mais sur les 12 derniers mois, c'est devenu bien tranquille, côté SAVAGE. Enfin, si on esxcepte tous ceux qui veulent du XGL&co, sans passer par la case départ "çà marche sous X?".


Ben justement, je cherche juste a faire tourner normalement les drivers sous X avec l'extensions "composite" (ya pas que Xgl qui a besoin de cette option, la transparence requiert cette extension par exemple).

Il reste certain que nVidia a de l'avance sur ATI (BEAUCOUP), mais quand tu dis le support pour les chip mobile n'est pas top, alors là je t'approuve, c'est certain aussi.

PS: faut faire avec si il n'y a pas d'autre soluces

Merci
_________________
"If you make something simple enough for an idiot to use, only an idiot will want to use it." Thomas Cort
Back to top
View user's profile Send private message
nykos
Guru
Guru


Joined: 08 Jun 2005
Posts: 488
Location: Strasbourg

PostPosted: Thu Oct 26, 2006 12:46 pm    Post subject: Reply with quote

ah ben j'avais mal compris le problème alors, je croyais que ça concernait xgl
c'est censé servir à quoi ton truc composite que tu veux rajouter ?
_________________
-=Nykos=-
TARGA Traveller 826T - AMD Turion 64 MT 32 1,8GHz - ATI Radeon X700 Mobility (ati-drivers)
Back to top
View user's profile Send private message
Goumize
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2006
Posts: 127
Location: Marrakech

PostPosted: Thu Oct 26, 2006 6:11 pm    Post subject: Reply with quote

nykos wrote:
ah ben j'avais mal compris le problème alors, je croyais que ça concernait xgl
c'est censé servir à quoi ton truc composite que tu veux rajouter ?



support pour la transparence et du coup je pourrai faire tourner AIGLX ou XGL, mais pour le moment je n'ai ni le direct rendering ni la transparence, je parcours un peu les how to des differentes distrib pour essayer de resoudre ce probleme.
Car apparement personne n'a de solution pour moi et sur le forum et sur le net, a part ce copier coller du fichier libgl.so.1.2 dont je me mefie.

Je recompile un nouveau noyau et retente un emerge, car j'ai besoin de rajouter qlq options pour l'ACPI, mon dmesg me rapporte une erreur:
Code:
APIC error on CPU0: 40(40)


et il se peut que mon support "Memory Type Range Register" soit aussi lier a cette erreur.
je te tiens au courant dans qlq instants. :wink:
_________________
"If you make something simple enough for an idiot to use, only an idiot will want to use it." Thomas Cort
Back to top
View user's profile Send private message
nykos
Guru
Guru


Joined: 08 Jun 2005
Posts: 488
Location: Strasbourg

PostPosted: Thu Oct 26, 2006 9:34 pm    Post subject: Reply with quote

APIC error on CPU0: 40(40)

j'en ai aussi plein des commes ça
mon dmesg est rempli avec ça
dans le temps j'utilisais le paramètres noapic pour le kernel
mais bon cette erreur je sais pas ce que c'est mais depuis quelques temps je la laisse et j'ai viré le paramètre au kernel vu que je ressent aucun changement au niveau du comportement de l'ordinateur !

EDIT : je pense que c'est spécifique au Turion et que ça n'a rien à voir avec la carte graphique

pour ton composite, tu configures ton xorg à la main ou tu utilises aticonfig ?
_________________
-=Nykos=-
TARGA Traveller 826T - AMD Turion 64 MT 32 1,8GHz - ATI Radeon X700 Mobility (ati-drivers)
Back to top
View user's profile Send private message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Thu Oct 26, 2006 10:43 pm    Post subject: Reply with quote

Goumize wrote:
Je recompile un nouveau noyau et retente un emerge, car j'ai besoin de rajouter qlq options pour l'ACPI, mon dmesg me rapporte une erreur:
Code:
APIC error on CPU0: 40(40)



J'avais ce truc aussi sur mon portable HP zv6000 proc sempron 64bit mais apparement ce n'est pas grave :
http://gentoo-wiki.com/HARDWARE_Gentoo_Linux_64bit_on_HP_Pavilion_zv6000_series_notebook#APIC_CPU_ERROR

Sinon, je n'ai tjrs pas reçu mon portable mais je peux t'affirmer que Xgl fonctionnait dessus sans problème donc avec les drivers d'il y a 3 mois et avec une XPRESS 200 ( j'avais vu que tu avais relevé différentes serie de la 200 ...) ! Franchement, je n'ai eu aucun soucis avec les drivers ATI et j'étais plutôt agréablement surpris ...


@ +
_________________
Get Up and Go !
Back to top
View user's profile Send private message
Goumize
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2006
Posts: 127
Location: Marrakech

PostPosted: Sat Oct 28, 2006 1:00 pm    Post subject: Reply with quote

Merci pour le lien "man in the hill", j'ai reessayer en downgradant et upgrade par la suite, le probleme de libgl revient en installant la version 8.28, les autres versions n'arrivent pas a faire marcher le composite et le DRI.
Yen a marre de galérer avec ces drivers, j'ai tout virer pour les drivers libres.

Mais hélas voila le resultat de RADEON drivers:

Code:
WW) RADEON(0): Unknown DDCType 5 found
(WW) RADEON(0): LCD DDC Info Table found!
(WW) RADEON(0): Failed to detect secondary monitor, MergedFB/Clone mode disabled
(WW) RADEON(0): Direct rendering disabled


Bon la ca me rassure, ce n'est pas les meme erreurs que fglrx, je continue a chercher la resolution a ce probleme.
_________________
"If you make something simple enough for an idiot to use, only an idiot will want to use it." Thomas Cort
Back to top
View user's profile Send private message
nykos
Guru
Guru


Joined: 08 Jun 2005
Posts: 488
Location: Strasbourg

PostPosted: Sat Oct 28, 2006 5:48 pm    Post subject: Reply with quote

t'as essayé de l'activer comment ?
en tout cas j'ai pas vu cette option dans aticonfig alors c'est peut-être pour ça que ça te l'active pas :-S
_________________
-=Nykos=-
TARGA Traveller 826T - AMD Turion 64 MT 32 1,8GHz - ATI Radeon X700 Mobility (ati-drivers)
Back to top
View user's profile Send private message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Sat Oct 28, 2006 6:21 pm    Post subject: Reply with quote

nykos wrote:
t'as essayé de l'activer comment ?
en tout cas j'ai pas vu cette option dans aticonfig alors c'est peut-être pour ça que ça te l'active pas :-S


Ci-dessus, c'est une erreur des drivers libre ...

Tu suis un Howto en particulier ?


@ +
_________________
Get Up and Go !
Back to top
View user's profile Send private message
nykos
Guru
Guru


Joined: 08 Jun 2005
Posts: 488
Location: Strasbourg

PostPosted: Sun Oct 29, 2006 12:35 am    Post subject: Reply with quote

man in the hill wrote:

Ci-dessus, c'est une erreur des drivers libre ...


oui oui j'ai bien vu, mais encore au-dessus il disait ne pas arriver à faire marcher le composite avec le drivers proprio aussi ;)
_________________
-=Nykos=-
TARGA Traveller 826T - AMD Turion 64 MT 32 1,8GHz - ATI Radeon X700 Mobility (ati-drivers)
Back to top
View user's profile Send private message
Goumize
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2006
Posts: 127
Location: Marrakech

PostPosted: Sun Oct 29, 2006 3:00 am    Post subject: Reply with quote

Exact "man in the hill", dans l'impossiblité de faire tourner le composite ainsi que DRI sur le lien que tu m'avais filer un peu plus en haut, il etait conseillé d'opter pour les drivers libre au cas ou ca marcherai pas, alors j'ai reussi a reparer l'erreur que j'ai citer dans mon premier post mais en activant l'extension composite je perdais systematiquement le direct rendering, donc j'ai essayer avec les drivers libres et ca donne l'erreur trois post plus en haut.

En fait j'ai pas reporter les lignes du log precedent celle ci, direct rendering broken in ATI XPRESS 200M, voila tt est dit, je vois pas peux venir ce probleme, mais apparement ma carte assez compliquée a faire marcher avec les differents drivers, je pense pas que c'est la meme ref que la tienne "man in the hill", mais elle cause beaucoup de probleme pour activer le composite et le DRI, j'ai fais le tour des forums pour trouver une solution, sans succés.

Mon arbre se trouve à l'instant cassé pour cause d'un emerge --sync, je ne peux plus emerger ou unmerger, je vois pas aussi la cause, rien fait de particulier, a part virer tout les paquets dont j'ai plus besoin que j'avais mis dans mon package.keywords c'est tout.

Donc mon portage cassé et moi meme par le suite, je suis vraiment dégouter au point que je pense que je dois m'arreter là, en attendant une sortie stable des drivers ati avec la prise en charge du GL desktop, et reprendre l'install depuis le debut sur mon laptop, car il se trouve qu'il fonctionne plus, dommage.

Et merci encore a toi "man in the hill"
_________________
"If you make something simple enough for an idiot to use, only an idiot will want to use it." Thomas Cort
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum