Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[nvidia drivers] Problème à l'install des 96.26 (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
GutsBlack
n00b
n00b


Joined: 27 Oct 2006
Posts: 6

PostPosted: Fri Oct 27, 2006 8:08 am    Post subject: [nvidia drivers] Problème à l'install des 96.26 (résolu) Reply with quote

Bonjour,
Voilà ça fait quelques jours que je teste une Gentoo 2006.1, j'en suis à l'installation des drivers nVidia 1.0.9626 mais je n'y arrives pas.
Je suis en X.org 7.1 correctement installé j'ai suivis quelques tutos pour le drivers nVidia mais un emerge -pv nvidia-drivers ne me propose que le nVidia 8774 et rien d'autres.

j'ai essayé de mettre dans package.unmask et keywords x11-drivers/nvidia-drivers-1.0.9626* mais ça ne fonctionne pas.

Quelqu'un aurais-t-il une idée ?

Merci d'avance :)


Last edited by GutsBlack on Fri Oct 27, 2006 11:35 pm; edited 2 times in total
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Fri Oct 27, 2006 8:13 am    Post subject: Reply with quote

Dans le package.unmask > x11-drivers/nvidia-drivers
Dans le package.keywords > x11-drivers/nvidia-drivers ~x86
(ou ~amd64, adapte à ta machine)
Back to top
View user's profile Send private message
GutsBlack
n00b
n00b


Joined: 27 Oct 2006
Posts: 6

PostPosted: Fri Oct 27, 2006 8:20 am    Post subject: Reply with quote

Ca ne marche pas non plus... je désespère un peu, j'ai l'impression que quelque chose manque mais je ne vois pas quoi.
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Fri Oct 27, 2006 8:46 am    Post subject: Reply with quote

C'est parce que tu n'as pas synchro portage depuis quelques temps!
Le driver stable n'est pas le 8774 mais le 8776.

Et puis va lire les conventions du forum concernant ton titre, il n'est pas aux normes.
Back to top
View user's profile Send private message
GutsBlack
n00b
n00b


Joined: 27 Oct 2006
Posts: 6

PostPosted: Fri Oct 27, 2006 8:56 am    Post subject: Reply with quote

Temet wrote:
C'est parce que tu n'as pas synchro portage depuis quelques temps!
Le driver stable n'est pas le 8774 mais le 8776.

Effectivement après avoir fait un emerge--sync, je vois bien un 8776 mais impossible d'avoir le beta 9626. je continus mes recherches... mais c'est bizarre la semaine dernière ça ne m'avais pas poser de problème.

Temet wrote:
Et puis va lire les conventions du forum concernant ton titre, il n'est pas aux normes.

Heu oui désolé je viens de modifier :roll:
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Fri Oct 27, 2006 9:50 am    Post subject: Reply with quote

cat /etc/portage/package.keywords
cat /etc/portage/package.unmask

que donnent ces deux commandes?
Back to top
View user's profile Send private message
GutsBlack
n00b
n00b


Joined: 27 Oct 2006
Posts: 6

PostPosted: Fri Oct 27, 2006 10:42 am    Post subject: Reply with quote

cat /etc/portage/package.keywords me donne

Code:
=x11-apps/mesa-progs-6.5
=media-libs/mesa-6.5-r3
=x11-base/xorg-server-1.1.1
=x11-drivers/xf86-video-nv-1.1.2
=x11-drivers/xf86-input-mouse-1.1.1
=x11-drivers/xf86-input-keyboard-1.1.0
x11-drivers/xf86-input-evdev
x11-drivers/nvidia-drivers ~x86


et cat /etc/portage/package.unmask me donne
Code:
x11-drivers/nvidia-drivers
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Fri Oct 27, 2006 10:47 am    Post subject: Reply with quote

Bonjours je ne fais que passer :

Juste au cas ou tu serais passé à coté :
[Nvidia] Changement dans la gestion du driver binaire
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Fri Oct 27, 2006 11:57 am    Post subject: Reply with quote

Code:
=x11-apps/mesa-progs-6.5
=media-libs/mesa-6.5-r3
=x11-base/xorg-server-1.1.1
=x11-drivers/xf86-video-nv-1.1.2
=x11-drivers/xf86-input-mouse-1.1.1
=x11-drivers/xf86-input-keyboard-1.1.0
x11-drivers/xf86-input-evdev


Tout ça ne sert à rien (xorg 7.1 est déjà en stable), et est même faux ... manque le keywords.

Vire moi ça et regarde à nouveau ;)
Back to top
View user's profile Send private message
GutsBlack
n00b
n00b


Joined: 27 Oct 2006
Posts: 6

PostPosted: Fri Oct 27, 2006 12:03 pm    Post subject: Reply with quote

Temet wrote:
Tout ça ne sert à rien (xorg 7.1 est déjà en stable), et est même faux ... manque le keywords.
Vire moi ça et regarde à nouveau ;)

Ok je vais chercher un peu avec vos deux réponses merci beaucoup.

Sinon je n'ai fait que suivre les indications du wiki francais sur gentoo :)
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Fri Oct 27, 2006 12:08 pm    Post subject: Reply with quote

Ouep, il y a écrit de démasquer ... d'un coté t'es censé savoir que t'as xorg 7.1.
Et s'il n'a pas écrit le keyword (~x86 ou ~amd64), c'est justement (enfin je pense) car il dépend de l'architecture ;)
Back to top
View user's profile Send private message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Fri Oct 27, 2006 12:08 pm    Post subject: Reply with quote

Temet wrote:
Code:
=x11-apps/mesa-progs-6.5
=media-libs/mesa-6.5-r3
=x11-base/xorg-server-1.1.1
=x11-drivers/xf86-video-nv-1.1.2
=x11-drivers/xf86-input-mouse-1.1.1
=x11-drivers/xf86-input-keyboard-1.1.0
x11-drivers/xf86-input-evdev


Tout ça ne sert à rien (xorg 7.1 est déjà en stable), et est même faux ... manque le keywords.

exact et pas besoin non plus de spécifier une version ...
_________________
Get Up and Go !
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1426
Location: Bamako - Mali - Afrique

PostPosted: Fri Oct 27, 2006 2:10 pm    Post subject: Reply with quote

man in the hill wrote:
Temet wrote:
Code:
=x11-apps/mesa-progs-6.5
=media-libs/mesa-6.5-r3
=x11-base/xorg-server-1.1.1
=x11-drivers/xf86-video-nv-1.1.2
=x11-drivers/xf86-input-mouse-1.1.1
=x11-drivers/xf86-input-keyboard-1.1.0
x11-drivers/xf86-input-evdev


Tout ça ne sert à rien (xorg 7.1 est déjà en stable), et est même faux ... manque le keywords.

exact et pas besoin non plus de spécifier une version ...


Ben moi je specifie la version si je veux ~archer une version specifique... je suis passé à Xorg7.1 avant le passage en satble (je suis en amd64) et j'ai bloqué les versions pour ne pas passer plus loin :) maintenant je peux nettoyé mon .keywords .unmask ^_^
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
ultrabug
Developer
Developer


Joined: 24 Jan 2005
Posts: 698
Location: Paris

PostPosted: Fri Oct 27, 2006 2:44 pm    Post subject: Reply with quote

Salut,

En supposant que tu fasses tout ca pour beryl, dans le howto suivant, ils expliquent comment avoir les drivers nvidia que tu cherches :
http://fr.gentoo-wiki.com/HOWTO_Beryl#Nvidia

Bon courage
Back to top
View user's profile Send private message
GutsBlack
n00b
n00b


Joined: 27 Oct 2006
Posts: 6

PostPosted: Fri Oct 27, 2006 11:34 pm    Post subject: Reply with quote

ultrabug wrote:
Salut,

En supposant que tu fasses tout ca pour beryl, dans le howto suivant, ils expliquent comment avoir les drivers nvidia que tu cherches :
http://fr.gentoo-wiki.com/HOWTO_Beryl#Nvidia

Bon courage

Oui c'est mon but mais avec le tuto ça ne marche pas, mais il date un peu !

Bon sinon merci beaucoup pour l'aide j'ai finalement réussi, j'ai repris de zéro, j'ai viré les deux fichiers dans /etc/portage et je les ai recréé avec la première solution de Temet et bingo !!

Allez hop prochaine étape pour moi e17 et beryl :D
Back to top
View user's profile Send private message
PabOu
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1088
Location: Hélécine - Belgium

PostPosted: Sat Oct 28, 2006 12:00 am    Post subject: Re: [nvidia drivers] Problème à l'install des 96.26 (réso Reply with quote

GutsBlack wrote:
Voilà ça fait quelques jours que je teste une Gentoo 2006.1


Salut !

Juste pour clarifier un point (je ne sais pas si tu avais compris ou pas donc je vais faire comme si tu n'avais pas compris), il n'y a pas (vraiment) de différence entre les différentes "versions" de Gentoo (comme tu dis ici "2006.1"). En fait il n'y a pas de "versions" de Gentoo, il y a simplement des médias (livecd/dvd et installcd/dvd) différents.
À part les modifications impliquées par mon fichier make.conf (ce qui rend le système complètement customisée selon nos besoins à chacun et qui fait une bonne partie de la puissance de Gentoo), et un lien symbolique près (qui ne change rien de notable en théorie et encore moins en pratique), ta Gentoo fraichement installée est identique à la mienne qui a été installée il y a 3 ans et mise à jour régulièrement depuis, et pareille que celle de toutes les autres Gentoo quoi :P.

Je tenais à le préciser parceque dans 6 mois quand un nouveau média sortira (2007.0), tu aurais pu mal comprendre et réinstaller tout ton système (comme il faut le faire avec d'autres distributions et ca provoque la confusion à plein de gens et peut-être à toi, d'où ma remarque) alors que cela aurait été inutile car si tu mets ta Gentoo à jour, tu aurais exactement le même résultat mais sans devoir télécharger le nouveau média et réinstaller.
_________________
Mangez du poulet !
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Sat Oct 28, 2006 6:39 pm    Post subject: Reply with quote

GutsBlack wrote:
Allez hop prochaine étape pour moi e17 et beryl :D


Ne perds pas le temps la dessus, E17 est et ne sera pas compatible Beryl (choix des devs ;))
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Sat Oct 28, 2006 7:11 pm    Post subject: Reply with quote

@Pabou : ah non je suis pas d'accord, toutes les Gentoo ne sont pas pareil, bien au contraire ! Il n'y a pas de versions comme on l'entend habituellement, ce que tu soulignes bien, mais cela fait justement qu'elles sont toutes différentes !
Back to top
View user's profile Send private message
PabOu
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1088
Location: Hélécine - Belgium

PostPosted: Sat Oct 28, 2006 7:45 pm    Post subject: Reply with quote

kopp wrote:
@Pabou : ah non je suis pas d'accord, toutes les Gentoo ne sont pas pareil, bien au contraire ! Il n'y a pas de versions comme on l'entend habituellement, ce que tu soulignes bien, mais cela fait justement qu'elles sont toutes différentes !


Oui je suis d'accord et c'est pour ça que j'ai mis
PabOu wrote:
À part les modifications impliquées par mon fichier make.conf (ce qui rend le système complètement customisée selon nos besoins à chacun et qui fait une bonne partie de la puissance de Gentoo)


J'ai ignoré cette idée dans le reste du texte pour ne pas embrouiller mes explications qui étaient avant tout sur les nouveaux profils qui n'impliquent pas une réinstallation complète du système, comme on l'a déjà vu.
_________________
Mangez du poulet !
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Sun Oct 29, 2006 4:29 am    Post subject: Reply with quote

Temet wrote:
Code:
=x11-apps/mesa-progs-6.5
=media-libs/mesa-6.5-r3
=x11-base/xorg-server-1.1.1
=x11-drivers/xf86-video-nv-1.1.2
=x11-drivers/xf86-input-mouse-1.1.1
=x11-drivers/xf86-input-keyboard-1.1.0
x11-drivers/xf86-input-evdev


Tout ça ne sert à rien (xorg 7.1 est déjà en stable), et est même faux ... manque le keywords.

Vire moi ça et regarde à nouveau ;)


Le keyword n'est pas du tout obligatoire, il est implicite.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum