Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200606-18 ] PAM-MySQL: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1703

PostPosted: Thu Jun 15, 2006 5:26 pm    Post subject: [ GLSA 200606-18 ] PAM-MySQL: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: PAM-MySQL: Multiple vulnerabilities (GLSA 200606-18)
Severity: normal
Exploitable: local
Date: June 15, 2006
Updated: July 29, 2006
Bug(s): #120842
ID: 200606-18

Synopsis


Vulnerabilities in PAM-MySQL can lead to a Denial of Service, making it
impossible to log into a machine.


Background


PAM-MySQL is a PAM module used to authenticate users against a MySQL
backend.


Affected Packages

Package: sys-auth/pam_mysql
Vulnerable: < 0.7_rc1
Unaffected: >= 0.7_rc1
Architectures: All supported architectures


Description


A flaw in handling the result of pam_get_item() as well as further
unspecified flaws were discovered in PAM-MySQL.


Impact


By exploiting the mentioned flaws an attacker can cause a Denial of
Service and thus prevent users that authenticate against PAM-MySQL from
logging into a machine. There is also a possible additional attack
vector with more malicious impact that has not been confirmed yet.


Workaround


There is no known workaround at this time.


Resolution


All PAM-MySQL users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=sys-auth/pam_mysql-0.7_rc1"


References

Official release information
CVE-2005-4713
CVE-2006-0056


Last edited by GLSA on Mon Jan 20, 2014 5:28 am; edited 5 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum