Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Little-Endian Gentoo Slug (Linksys NLSU2)
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message

Joined: 11 Oct 2003
Posts: 4

PostPosted: Wed Jun 14, 2006 3:39 pm    Post subject: Little-Endian Gentoo Slug (Linksys NLSU2) Reply with quote

Hi All,

Just a note for those who are trying something similiar out there ...

I've managed to get my little TurboSlug (Linksys NSLU2 @ 266Mhz) to run Gentoo in Little-Endian mode based on the recent "DebianSlug 3.10" flash image (LittleEndian Openslug intended for Debian installs) which I got from


1) Flashing the debian image to the slug with upslug2 as normal. Rebooting Slug. (See for details).
2) Login (root pwd was opeNSLUg) and prepared my USB external disk (e.g. fdisk) (no boot partition, just swap and / partition running reiserfs).
3) Started "normal" Gentoo install process following instructions from (as primary reference) and (background reference, German)


1) I used the arm (not armeb) little-endian stage 3 tarball (stage3-arm-uclibc-softfloat-20050811.tar.bz2) and Portage snapshot (which I lifted from
2) Managed to get distcc running (for faster compilations), offloading the compilation to my AMD64 laptop, but eventually stopped doing this as I had too many little compile errors. If you do want to try this, remember to setup your crossdev for arm-softfloat-linux-uclibc --- and NOT armeb --- but for the time being, I'm sticking to native compiles on the SLUG, but your mileage might vary.
4) Biggest problem ... coreutils upgrade didn't wanna compile so I package.masked it, and now running coreutils-5.2.1-r7

Outcome: so far so good. I've run into a few minor glitches here and there ... but nothing that an eager "Gentoo-er" can't deal with. ;-)


gap ~ # emerge --info
Portage 2203-svn (uclibc/arm, gcc-3.4.6, uclibc-0.9.28-r0, 2.6.16 armv5tel)
System uname: 2.6.16 armv5tel XScale-IXP42x Family rev 1 (v5l)
Gentoo Base System version 1.6.14
distcc 2.18.3 arm-softfloat-linux-uclibc (protocols 1 and 2) (default port 3632) [disabled]
dev-lang/python:     2.3.5, 2.4.2
dev-python/pycrypto: [Not Present]
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r2
sys-devel/gcc-config: 1.3.13-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
CFLAGS="-march=armv5te -mtune=xscale -Os"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=armv5te -mtune=xscale -Os"
FEATURES="autoconfig distlocks nodoc noinfo noman sandbox sfperms strict"
GENTOO_MIRRORS="<put your gentoo mirrors here>"
USE="arm apache2 bitmap-fonts bzip2 cli dri expat ncurses pcre perl python readline reflection session spl ssl truetype-fonts type1-fonts uclibc udev xorg zlib userland_GNU kernel_linux elibc_uclibc"


1) Roll my own kernel... <efg>
2) Get raid1 working on two large external USB drives.
3) Fatten the SLUG (the 32Mb of RAM just not enough).

.... and lots more. :)
-- espresso yourself --
Back to top
View user's profile Send private message

Joined: 02 Aug 2005
Posts: 8
Location: mpls,mn

PostPosted: Mon Jun 19, 2006 7:30 pm    Post subject: thanks! Reply with quote

thanks... been wanting to do something along these lines for a while... now i must get off my lazy ass.

Back to top
View user's profile Send private message

Joined: 27 Jul 2006
Posts: 4
Location: Düsseldorf, Germany

PostPosted: Thu Sep 14, 2006 11:49 am    Post subject: Reply with quote

I've tried it, but uclibc refuses to update. I've tried it with a fresh installation according to the wiki and I've tried updating portage and gcc before, but it still fails:
>>> Emerging (1 of 1) sys-libs/uclibc-0.9.28 to /
 * uClibc-0.9.28.tar.bz2 MD5 ;-) ...                                                                                          [ ok ]
 * uClibc-0.9.28.tar.bz2 RMD160 ;-) ...                                                                                       [ ok ]
 * uClibc-0.9.28.tar.bz2 SHA1 ;-) ...                                                                                         [ ok ]
 * uClibc-0.9.28.tar.bz2 SHA256 ;-) ...                                                                                       [ ok ]
 * uClibc-0.9.28.tar.bz2 size ;-) ...                                                                                         [ ok ]
 * uClibc-0.9.28-patches-1.3.tar.bz2 MD5 ;-) ...                                                                              [ ok ]
 * uClibc-0.9.28-patches-1.3.tar.bz2 RMD160 ;-) ...                                                                           [ ok ]
 * uClibc-0.9.28-patches-1.3.tar.bz2 SHA1 ;-) ...                                                                             [ ok ]
 * uClibc-0.9.28-patches-1.3.tar.bz2 SHA256 ;-) ...                                                                           [ ok ]
 * uClibc-0.9.28-patches-1.3.tar.bz2 size ;-) ...                                                                             [ ok ]
 * checking ebuild checksums ;-) ...                                                                                          [ ok ]
 * checking auxfile checksums ;-) ...                                                                                         [ ok ]
 * checking miscfile checksums ;-) ...                                                                                        [ ok ]
 * checking uClibc-0.9.28.tar.bz2 ;-) ...                                                                                     [ ok ]
 * checking uClibc-0.9.28-patches-1.3.tar.bz2 ;-) ...                                                                         [ ok ]
QA Notice: USE Flag 'crosscompile_opts_headers-only' not in IUSE for sys-libs/uclibc-0.9.28

!!! ERROR: sys-libs/uclibc-0.9.28 failed.
Call stack:, line 1562:   Called dyn_setup, line 665:   Called pkg_setup
  uclibc-0.9.28.ebuild, line 73:   Called built_with_use 'sys-libs/uclibc' 'nls'
  eutils.eclass, line 1619:   Called die

!!! sys-libs/uclibc-0.9.27 does not actually support the nls USE flag!
!!! If you need support, post the topmost build error, and the call stack if relevant.

Note: I've never ever done anything with the nls useflag or something related to it.

Anyway, I'm giving up now and will return to big-endian.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum