Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
XGL (Part 5)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 35, 36, 37  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
CoffeeBuzz
Apprentice
Apprentice


Joined: 15 Jun 2005
Posts: 269
Location: Canada Eh.

PostPosted: Tue Aug 15, 2006 10:56 pm    Post subject: Reply with quote

lysergicacid wrote:
Gusar wrote:
lysergicacid wrote:
xgl any better with kde now ? (natively i mean) instead of having to install all that gnome crap ?

gnome-window-decorator has been replaced by 'cgwd', which has much less gnome dependencies. You still need some gnome stuff (like gconf), but switching to cgwd allowed me to remove about 30 gnome-related packages.


great stuff think i'll finally give it another go then :), sorry for slow reply was off doing other things ;) thanx :)


Just to clarify, cgwd is required for compiz-quinnstorm. gnome-window-decorator is still required for vanilla compiz.

its either, compiz + gwd or compiz-quinnstorm + cgwd
_________________
HP Pavilion zd7260us
Xgl Overlay: http://svn.xgl-coffee.org/xgl-coffee/trunk
Xgl Forums: http://forums.xgl-coffee.org
Back to top
View user's profile Send private message
lysergicacid
Guru
Guru


Joined: 25 Nov 2003
Posts: 352
Location: The Universe,Virgo Super Cluster,Milky Way,Earth

PostPosted: Wed Aug 16, 2006 3:42 am    Post subject: Reply with quote

i was running compiz-quinnstorm before and ive gone for it again this time round, i cant stand gnome so i went for the cgwd anyway, but thank you for taking the time to clarify that :)
_________________
[img]http://valid.canardpc.com/cache/banner/2040927.png[/img]
Desktop:
[img]http://valid.canardpc.com/cache/banner/2703952.png[/img]


Last edited by lysergicacid on Wed Aug 16, 2006 5:01 am; edited 1 time in total
Back to top
View user's profile Send private message
grimz
n00b
n00b


Joined: 29 Jun 2006
Posts: 53

PostPosted: Wed Aug 16, 2006 4:09 am    Post subject: Reply with quote

Thought I'd post my findings here as well in case others had similar issues, in reply to my original post.

I think I've found the solution for the keybinding bug!
I've combed thru the gconf-editor, and under Compiz -> General -> All Screens -> Options, it's seems the entries in there that are being used for the key binds are *_key. Such as, my "run_key" and "show_desktop_key" were "Disabled". As soon as I changed them to <Super>r and <Super>d respectively, the functions came back. But what is strange is, there are still the other entries in there that used to work such as "run" (which has the description of "Show Run Application Dialog"), and "run_button". I never had "run_button" bound, but just the "run" entry was bound to <Super>r, so it seems this entry has been deprecated? I'm not sure what the "*_button" entry ever did as it still has the same description as all the others?

Same thing with "show_desktop", and "show_desktop_button" entries. I'm now using the "show_desktop_key" entry, and it seems to be working fine.

Are the "*_button" entires gone with for good now and we're moving across to the "*_key" entires?

Now the only issue I have is the wobbly bug :D

EDIT: Does anybody know how to turn off the "Zoom out slightly, then rotate, then zoom back in" feature of the cube? I think I prefer the nice and quick rotation :)
Back to top
View user's profile Send private message
loemmel
Apprentice
Apprentice


Joined: 19 Aug 2003
Posts: 227
Location: switzerland

PostPosted: Wed Aug 16, 2006 6:25 am    Post subject: Reply with quote

I have problems compiling the newest cgwd version:

Quote:
r/lib64/libpng12.so -lz /usr/lib64/libXrender.so /usr/lib64/libSM.so /usr/lib64/libICE.so /usr/lib64/libX11.so /usr/lib64/libXau.so /usr/lib64/libXdmcp.so -lm /usr/lib64/libgobject-2.0.so /usr/lib64/libgmodule-2.0.so -ldl /usr/lib64/libglib-2.0.so
main.o: In function `draw_window_decoration_real':
main.c:(.text+0x3b4e): undefined reference to `gdk_cairo_set_source_pixmap'
collect2: ld returned 1 exit status
make[2]: *** [cgwd] Error 1
make[2]: Leaving directory `/var/tmp/portage/cgwd-0.49/work/cgwd/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/cgwd-0.49/work/cgwd'
make: *** [all] Error 2

!!! ERROR: x11-wm/cgwd-0.49 failed.
Call stack:
ebuild.sh, line 1543: Called dyn_compile
ebuild.sh, line 938: Called src_compile
cgwd-0.49.ebuild, line 31: Called gnome2_src_compile '--disable-mime-update'
gnome2.eclass, line 64: Called die

!!! compile failure


I've never had any problems with it before... any Ideas?


[edit]
The cvs compiles fine. so I'll use that version.
[/edit]
Back to top
View user's profile Send private message
Jupiter1TX
Guru
Guru


Joined: 24 Feb 2006
Posts: 546
Location: 3rd Rock

PostPosted: Wed Aug 16, 2006 2:27 pm    Post subject: Reply with quote

loemmel wrote:
I have problems compiling the newest cgwd version:

Quote:
r/lib64/libpng12.so -lz /usr/lib64/libXrender.so /usr/lib64/libSM.so /usr/lib64/libICE.so /usr/lib64/libX11.so /usr/lib64/libXau.so /usr/lib64/libXdmcp.so -lm /usr/lib64/libgobject-2.0.so /usr/lib64/libgmodule-2.0.so -ldl /usr/lib64/libglib-2.0.so
main.o: In function `draw_window_decoration_real':
main.c:(.text+0x3b4e): undefined reference to `gdk_cairo_set_source_pixmap'
collect2: ld returned 1 exit status
make[2]: *** [cgwd] Error 1
make[2]: Leaving directory `/var/tmp/portage/cgwd-0.49/work/cgwd/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/cgwd-0.49/work/cgwd'
make: *** [all] Error 2

!!! ERROR: x11-wm/cgwd-0.49 failed.
Call stack:
ebuild.sh, line 1543: Called dyn_compile
ebuild.sh, line 938: Called src_compile
cgwd-0.49.ebuild, line 31: Called gnome2_src_compile '--disable-mime-update'
gnome2.eclass, line 64: Called die

!!! compile failure


I've never had any problems with it before... any Ideas?


[edit]
The cvs compiles fine. so I'll use that version.
[/edit]


There was a dependancy mistake with that rev
probably easier to roll back to 0.45
http://forums.xgl-coffee.org/viewtopic.php?t=99&postdays=0&postorder=asc&start=0
_________________
Core i7 920 D0 | Asus P6T DLX | Patriot Viper 1600 6GB | Antec Quattro 850W
Geforce 8800GTX OC2 768MB | Dell 22" LCD | Koolance Exos2/Swiftech GTZ
GCC 4.6.1 | 3.7.x-geek | Xorg-7.4-x | KDE-4.7.x | Compiz
Back to top
View user's profile Send private message
KaiNeR
Tux's lil' helper
Tux's lil' helper


Joined: 19 Mar 2004
Posts: 100

PostPosted: Wed Aug 16, 2006 6:51 pm    Post subject: Reply with quote

Hi on my recent attempts of reinstalling xlg+compiz i recieve this error

i386-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../src -I../../src -O2 -mtune=pentium4 -pipe -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -MT glitz_glx_extension.lo -MD -MP -MF .deps/glitz_glx_extension.Tpo -c glitz_glx_extension.c -o glitz_glx_extension.o >/dev/null 2>&1
if /bin/sh ../../libtool --tag=CC --mode=compile i386-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../src -I../../src -O2 -mtune=pentium4 -pipe -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -MT glitz_glx_context.lo -MD -MP -MF ".deps/glitz_glx_context.Tpo" -c -o glitz_glx_context.lo glitz_glx_context.c; \
then mv -f ".deps/glitz_glx_context.Tpo" ".deps/glitz_glx_context.Plo"; else rm -f ".deps/glitz_glx_context.Tpo"; exit 1; fi
if /bin/sh ../../libtool --tag=CC --mode=compile i386-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../src -I../../src -O2 -mtune=pentium4 -pipe -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -MT glitz_glx_pbuffer.lo -MD -MP -MF ".deps/glitz_glx_pbuffer.Tpo" -c -o glitz_glx_pbuffer.lo glitz_glx_pbuffer.c; \
then mv -f ".deps/glitz_glx_pbuffer.Tpo" ".deps/glitz_glx_pbuffer.Plo"; else rm -f ".deps/glitz_glx_pbuffer.Tpo"; exit 1; fi
i386-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../src -I../../src -O2 -mtune=pentium4 -pipe -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -MT glitz_glx_context.lo -MD -MP -MF .deps/glitz_glx_context.Tpo -c glitz_glx_context.c -fPIC -DPIC -o .libs/glitz_glx_context.o
i386-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../src -I../../src -O2 -mtune=pentium4 -pipe -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -MT glitz_glx_pbuffer.lo -MD -MP -MF .deps/glitz_glx_pbuffer.Tpo -c glitz_glx_pbuffer.c -fPIC -DPIC -o .libs/glitz_glx_pbuffer.o
In file included from glitz_glxint.h:37,
from glitz_glx_context.c:30:
glitz_glxext.h:119:1: warning: "GLX_SAMPLE_BUFFERS_ARB" redefined
In file included from /usr/include/GL/glx.h:27,
from glitz_glxint.h:35,
from glitz_glx_context.c:30:
/usr/include/GL/glxtokens.h:61:1: warning: this is the location of the previous definition
In file included from glitz_glxint.h:37,
from glitz_glx_context.c:30:
glitz_glxext.h:120:1: warning: "GLX_SAMPLES_ARB" redefined
In file included from /usr/include/GL/glx.h:27,
from glitz_glxint.h:35,
from glitz_glx_context.c:30:
/usr/include/GL/glxtokens.h:62:1: warning: this is the location of the previous definition
In file included from glitz_glxint.h:37,
from glitz_glx_pbuffer.c:30:
glitz_glxext.h:119:1: warning: "GLX_SAMPLE_BUFFERS_ARB" redefined
In file included from /usr/include/GL/glx.h:27,
from glitz_glxint.h:35,
from glitz_glx_pbuffer.c:30:
/usr/include/GL/glxtokens.h:61:1: warning: this is the location of the previous definition
In file included from glitz_glxint.h:37,
from glitz_glx_pbuffer.c:30:
glitz_glxext.h:120:1: warning: "GLX_SAMPLES_ARB" redefined
In file included from /usr/include/GL/glx.h:27,
from glitz_glxint.h:35,
from glitz_glx_pbuffer.c:30:
/usr/include/GL/glxtokens.h:62:1: warning: this is the location of the previous definition
i386-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../src -I../../src -O2 -mtune=pentium4 -pipe -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -MT glitz_glx_context.lo -MD -MP -MF .deps/glitz_glx_context.Tpo -c glitz_glx_context.c -o glitz_glx_context.o >/dev/null 2>&1
i386-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../src -I../../src -O2 -mtune=pentium4 -pipe -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -MT glitz_glx_pbuffer.lo -MD -MP -MF .deps/glitz_glx_pbuffer.Tpo -c glitz_glx_pbuffer.c -o glitz_glx_pbuffer.o >/dev/null 2>&1
/bin/sh ../../libtool --tag=CC --mode=link i386-pc-linux-gnu-gcc -O2 -mtune=pentium4 -pipe -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -o libglitz-glx.la -rpath /usr/lib -version-info 1:0:0 -no-undefined glitz_glx_drawable.lo glitz_glx_format.lo glitz_glx_info.lo glitz_glx_extension.lo glitz_glx_context.lo glitz_glx_pbuffer.lo -L../../src -lglitz -lX11 -lGL -lpthread
i386-pc-linux-gnu-gcc -shared .libs/glitz_glx_drawable.o .libs/glitz_glx_format.o .libs/glitz_glx_info.o .libs/glitz_glx_extension.o .libs/glitz_glx_context.o .libs/glitz_glx_pbuffer.o -Wl,--rpath -Wl,/var/tmp/portage/glitz-0.5.6/work/glitz-0.5.6/src/.libs /var/tmp/portage/glitz-0.5.6/work/glitz-0.5.6/src/.libs/libglitz.so /usr/lib/libX11.so -L/usr/lib /usr/lib/libGL.so -L/usr/X11R6/lib -lpthread -mtune=pentium4 -Wl,-soname -Wl,libglitz-glx.so.1 -o .libs/libglitz-glx.so.1.0.0
i386-pc-linux-gnu-gcc: /usr/lib/libGL.so: No such file or directory
make[3]: *** [libglitz-glx.la] Error 1
make[3]: Leaving directory `/var/tmp/portage/glitz-0.5.6/work/glitz-0.5.6/src/glx'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/glitz-0.5.6/work/glitz-0.5.6/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/glitz-0.5.6/work/glitz-0.5.6'
make: *** [all] Error 2

!!! ERROR: media-libs/glitz-0.5.6 failed.
Call stack:
ebuild.sh, line 1539: Called dyn_compile
ebuild.sh, line 939: Called src_compile
ebuild.sh, line 609: Called die

!!! emake failed
!!! If you need support, post the topmost build error, and the call stack if relevant.

I have tried to install Glitz seperatly but recieved the same error, does anyone know how to get past this problem

thanks
Back to top
View user's profile Send private message
lysergicacid
Guru
Guru


Joined: 25 Nov 2003
Posts: 352
Location: The Universe,Virgo Super Cluster,Milky Way,Earth

PostPosted: Wed Aug 16, 2006 7:28 pm    Post subject: Reply with quote

Code:
i386-pc-linux-gnu-gcc: /usr/lib/libGL.so: No such file or directory
^^ thats your problem u have no opengl, did u install nvidia-kernel and nvidia-glx or ati-drivers and mesa ? if not try install them then try again :), if im wrong please correct me, hope it helps either way.
_________________
[img]http://valid.canardpc.com/cache/banner/2040927.png[/img]
Desktop:
[img]http://valid.canardpc.com/cache/banner/2703952.png[/img]
Back to top
View user's profile Send private message
KaiNeR
Tux's lil' helper
Tux's lil' helper


Joined: 19 Mar 2004
Posts: 100

PostPosted: Wed Aug 16, 2006 7:40 pm    Post subject: Reply with quote

cheers, i managed to get past that error but now i'm recieving this

i386-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../../include -I../../include -I../../include -I../../include -I../../include -I../../include -I../../include -I../../include -I../../hw/xfree86/os-support -I../../hw/xfree86/os-support/bus -I../../hw/xfree86/common -I../../hw/xfree86/dri -I../../mi -I/var/tmp/portage/xgl-0.0.1_pre20060714-r1/work/Mesa/include -DHAVE_DIX_CONFIG_H -I/usr/include/drm -I/usr/include/X11/dri -I/var/tmp/portage/xgl-0.0.1_pre20060714-r1/work/Mesa/src/mesa/glapi -I/var/tmp/portage/xgl-0.0.1_pre20060714-r1/work/Mesa/src/mesa/main -DXGLServer -DNO_LIBCWRAPPER -DUSE_MGL_NAMESPACE -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -I../../include -I../../include -I../../Xext -I../../composite -I../../damageext -I../../xfixes -I../../Xi -I../../mi -I../../miext/shadow -I../../miext/damage -I../../render -I../../randr -I../../fb -O2 -mtune=pentium4 -pipe -MT glthread.lo -MD -MP -MF .deps/glthread.Tpo -c glthread.c -fPIC -DPIC -o .libs/glthread.o
if /bin/sh ../../libtool --tag=CC --mode=compile i386-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../../include -I../../include -I../../include -I../../include -I../../include -I../../include -I../../include -I../../include -I../../hw/xfree86/os-support -I../../hw/xfree86/os-support/bus -I../../hw/xfree86/common -I../../hw/xfree86/dri -I../../mi -I/var/tmp/portage/xgl-0.0.1_pre20060714-r1/work/Mesa/include -DHAVE_DIX_CONFIG_H -I/usr/include/drm -I/usr/include/X11/dri -I/var/tmp/portage/xgl-0.0.1_pre20060714-r1/work/Mesa/src/mesa/glapi -I/var/tmp/portage/xgl-0.0.1_pre20060714-r1/work/Mesa/src/mesa/main -DXGLServer -DNO_LIBCWRAPPER -DUSE_MGL_NAMESPACE -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -I../../include -I../../include -I../../Xext -I../../composite -I../../damageext -I../../xfixes -I../../Xi -I../../mi -I../../miext/shadow -I../../miext/damage -I../../render -I../../randr -I../../fb -O2 -mtune=pentium4 -pipe -MT glxcmds.lo -MD -MP -MF ".deps/glxcmds.Tpo" -c -o glxcmds.lo glxcmds.c; \
then mv -f ".deps/glxcmds.Tpo" ".deps/glxcmds.Plo"; else rm -f ".deps/glxcmds.Tpo"; exit 1; fi
if /bin/sh ../../libtool --tag=CC --mode=compile i386-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../../include -I../../include -I../../include -I../../include -I../../include -I../../include -I../../include -I../../include -I../../hw/xfree86/os-support -I../../hw/xfree86/os-support/bus -I../../hw/xfree86/common -I../../hw/xfree86/dri -I../../mi -I/var/tmp/portage/xgl-0.0.1_pre20060714-r1/work/Mesa/include -DHAVE_DIX_CONFIG_H -I/usr/include/drm -I/usr/include/X11/dri -I/var/tmp/portage/xgl-0.0.1_pre20060714-r1/work/Mesa/src/mesa/glapi -I/var/tmp/portage/xgl-0.0.1_pre20060714-r1/work/Mesa/src/mesa/main -DXGLServer -DNO_LIBCWRAPPER -DUSE_MGL_NAMESPACE -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -I../../include -I../../include -I../../Xext -I../../composite -I../../damageext -I../../xfixes -I../../Xi -I../../mi -I../../miext/shadow -I../../miext/damage -I../../render -I../../randr -I../../fb -O2 -mtune=pentium4 -pipe -MT glxcmdsswap.lo -MD -MP -MF ".deps/glxcmdsswap.Tpo" -c -o glxcmdsswap.lo glxcmdsswap.c; \
then mv -f ".deps/glxcmdsswap.Tpo" ".deps/glxcmdsswap.Plo"; else rm -f ".deps/glxcmdsswap.Tpo"; exit 1; fi
i386-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../../include -I../../include -I../../include -I../../include -I../../include -I../../include -I../../include -I../../include -I../../hw/xfree86/os-support -I../../hw/xfree86/os-support/bus -I../../hw/xfree86/common -I../../hw/xfree86/dri -I../../mi -I/var/tmp/portage/xgl-0.0.1_pre20060714-r1/work/Mesa/include -DHAVE_DIX_CONFIG_H -I/usr/include/drm -I/usr/include/X11/dri -I/var/tmp/portage/xgl-0.0.1_pre20060714-r1/work/Mesa/src/mesa/glapi -I/var/tmp/portage/xgl-0.0.1_pre20060714-r1/work/Mesa/src/mesa/main -DXGLServer -DNO_LIBCWRAPPER -DUSE_MGL_NAMESPACE -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -I../../include -I../../include -I../../Xext -I../../composite -I../../damageext -I../../xfixes -I../../Xi -I../../mi -I../../miext/shadow -I../../miext/damage -I../../render -I../../randr -I../../fb -O2 -mtune=pentium4 -pipe -MT glxcmds.lo -MD -MP -MF .deps/glxcmds.Tpo -c glxcmds.c -fPIC -DPIC -o .libs/glxcmds.o
glxcmds.c: In function `DoGetFBConfigs':
glxcmds.c:1175: error: `GLX_SWAP_METHOD_OML' undeclared (first use in this function)
glxcmds.c:1175: error: (Each undeclared identifier is reported only once
glxcmds.c:1175: error: for each function it appears in.)
glxcmds.c: In function `__glXBindTexImageEXT':
glxcmds.c:1604: error: `GLX_FRONT_LEFT_EXT' undeclared (first use in this function)
glxcmds.c: In function `DoGetDrawableAttributes':
glxcmds.c:1683: error: `GLX_TEXTURE_TARGET_EXT' undeclared (first use in this function)
glxcmds.c:1684: error: `GLX_TEXTURE_RECTANGLE_EXT' undeclared (first use in this function)
i386-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../../include -I../../include -I../../include -I../../include -I../../include -I../../include -I../../include -I../../include -I../../hw/xfree86/os-support -I../../hw/xfree86/os-support/bus -I../../hw/xfree86/common -I../../hw/xfree86/dri -I../../mi -I/var/tmp/portage/xgl-0.0.1_pre20060714-r1/work/Mesa/include -DHAVE_DIX_CONFIG_H -I/usr/include/drm -I/usr/include/X11/dri -I/var/tmp/portage/xgl-0.0.1_pre20060714-r1/work/Mesa/src/mesa/glapi -I/var/tmp/portage/xgl-0.0.1_pre20060714-r1/work/Mesa/src/mesa/main -DXGLServer -DNO_LIBCWRAPPER -DUSE_MGL_NAMESPACE -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -I../../include -I../../include -I../../Xext -I../../composite -I../../damageext -I../../xfixes -I../../Xi -I../../mi -I../../miext/shadow -I../../miext/damage -I../../render -I../../randr -I../../fb -O2 -mtune=pentium4 -pipe -MT glxcmdsswap.lo -MD -MP -MF .deps/glxcmdsswap.Tpo -c glxcmdsswap.c -fPIC -DPIC -o .libs/glxcmdsswap.o
make[2]: *** [glxcmds.lo] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/var/tmp/portage/xgl-0.0.1_pre20060714-r1/work/xgl/GL/glx'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/xgl-0.0.1_pre20060714-r1/work/xgl/GL'
make: *** [all-recursive] Error 1

!!! ERROR: x11-base/xgl-0.0.1_pre20060714-r1 failed.


any help greatly appreciated :oops:
Back to top
View user's profile Send private message
Xamindar
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1155
Location: California

PostPosted: Wed Aug 16, 2006 9:36 pm    Post subject: Reply with quote

I have a problem with emerging and I thik it is related to xgl. Should I just unmask this package or is there a serious problem I should wait for?

Code:
 emerge -uDav world

These are the packages that would be merged, in order:

Calculating world dependencies |
!!! All ebuilds that could satisfy ">=x11-libs/gtk+-2.10" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-libs/gtk+-2.10.0 (masked by: package.mask)
# Stefan Schweizer <genstef@gentoo.org> (5 Jul 2006)
# Masked to allow proper testing of the old to-be-stable versions
# Please unmask when that version is stable and cairo-1.20 unmasked

- x11-libs/gtk+-2.10.1 (masked by: package.mask)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "x11-wm/metacity-2.15.21" [ebuild])



!!! Problem resolving dependencies for gnome-base/gnome
!!! Depgraph creation failed.
Back to top
View user's profile Send private message
sternklang
Veteran
Veteran


Joined: 10 Sep 2005
Posts: 1641
Location: Somewhere in time and space

PostPosted: Wed Aug 16, 2006 9:45 pm    Post subject: Reply with quote

If I'm not mistaken, that version of metacity is in the overlay to support AIGLX rather than Xgl. Metacity is the standard Gnome window manager. It doesn't run under Xgl, it's replaced by compiz instead. So you can mask that particular metacity version and you won't need the masked gtk+ as a dependency.
Back to top
View user's profile Send private message
Jupiter1TX
Guru
Guru


Joined: 24 Feb 2006
Posts: 546
Location: 3rd Rock

PostPosted: Wed Aug 16, 2006 9:48 pm    Post subject: Reply with quote

Xamindar wrote:
I have a problem with emerging and I thik it is related to xgl. Should I just unmask this package or is there a serious problem I should wait for?

Code:
 emerge -uDav world

These are the packages that would be merged, in order:

Calculating world dependencies |
!!! All ebuilds that could satisfy ">=x11-libs/gtk+-2.10" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-libs/gtk+-2.10.0 (masked by: package.mask)
# Stefan Schweizer <genstef@gentoo.org> (5 Jul 2006)
# Masked to allow proper testing of the old to-be-stable versions
# Please unmask when that version is stable and cairo-1.20 unmasked

- x11-libs/gtk+-2.10.1 (masked by: package.mask)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "x11-wm/metacity-2.15.21" [ebuild])



!!! Problem resolving dependencies for gnome-base/gnome
!!! Depgraph creation failed.


heya Xamindar
cgwd-0.49 has a dependancy error which causes this
it has been fixed in newer cgwd revs

I had already did the upgrade when this was fixed and so
am now using the gtk+-2.10.1 and haven't had a noticeable problems

EDIT: sorry just saw the metacity at the end of the error
_________________
Core i7 920 D0 | Asus P6T DLX | Patriot Viper 1600 6GB | Antec Quattro 850W
Geforce 8800GTX OC2 768MB | Dell 22" LCD | Koolance Exos2/Swiftech GTZ
GCC 4.6.1 | 3.7.x-geek | Xorg-7.4-x | KDE-4.7.x | Compiz
Back to top
View user's profile Send private message
coolsnowmen
Veteran
Veteran


Joined: 30 Jun 2004
Posts: 1479
Location: No.VA

PostPosted: Thu Aug 17, 2006 3:27 pm    Post subject: Reply with quote

grimz wrote:

EDIT: Does anybody know how to turn off the "Zoom out slightly, then rotate, then zoom back in" feature of the cube? I think I prefer the nice and quick rotation :)


Have you looked at the options from the package: x11-misc/gset-compiz
I'm not at home now, but im pretty sure I saw them in there somewhere...note that you don't have to restart Xgl to see what the changes do...
_________________
emerge: there are no ebuilds to satisfy "moo"
Back to top
View user's profile Send private message
Jupiter1TX
Guru
Guru


Joined: 24 Feb 2006
Posts: 546
Location: 3rd Rock

PostPosted: Thu Aug 17, 2006 3:33 pm    Post subject: Reply with quote

coolsnowmen wrote:
grimz wrote:

EDIT: Does anybody know how to turn off the "Zoom out slightly, then rotate, then zoom back in" feature of the cube? I think I prefer the nice and quick rotation :)


Have you looked at the options from the package: x11-misc/gset-compiz
I'm not at home now, but im pretty sure I saw them in there somewhere...note that you don't have to restart Xgl to see what the changes do...


/apps/compiz/plugins/rotate/screen0/options/zoom
just set it to "0"
_________________
Core i7 920 D0 | Asus P6T DLX | Patriot Viper 1600 6GB | Antec Quattro 850W
Geforce 8800GTX OC2 768MB | Dell 22" LCD | Koolance Exos2/Swiftech GTZ
GCC 4.6.1 | 3.7.x-geek | Xorg-7.4-x | KDE-4.7.x | Compiz
Back to top
View user's profile Send private message
stupidkid
Apprentice
Apprentice


Joined: 17 Apr 2006
Posts: 247
Location: 127.0.0.1

PostPosted: Thu Aug 17, 2006 11:17 pm    Post subject: Reply with quote

I just updated to compiz-quinn-0.0.13.31 and cgwd-0.55 and rotate up/down with ctrl+alt+up/down doesn't work anymore. Although it is still defined in plugins/rotate/screen0.

Also maximize/restore seem a bit weird. The window just maximizes/restores very quickly with a very little (if any) animation. Anyone know the causes of these?
_________________
How many people can read hex if you and dead people can read hex?
Back to top
View user's profile Send private message
Jupiter1TX
Guru
Guru


Joined: 24 Feb 2006
Posts: 546
Location: 3rd Rock

PostPosted: Thu Aug 17, 2006 11:41 pm    Post subject: Reply with quote

stupidkid wrote:
I just updated to compiz-quinn-0.0.13.31 and cgwd-0.55 and rotate up/down with ctrl+alt+up/down doesn't work anymore. Although it is still defined in plugins/rotate/screen0.

Also maximize/restore seem a bit weird. The window just maximizes/restores very quickly with a very little (if any) animation. Anyone know the causes of these?


yea the maximize/minimize problem has been reported already
it's pretty ugly now and i hope it is fixed soon
as far as rotate up/down has also been reported a while back
_________________
Core i7 920 D0 | Asus P6T DLX | Patriot Viper 1600 6GB | Antec Quattro 850W
Geforce 8800GTX OC2 768MB | Dell 22" LCD | Koolance Exos2/Swiftech GTZ
GCC 4.6.1 | 3.7.x-geek | Xorg-7.4-x | KDE-4.7.x | Compiz
Back to top
View user's profile Send private message
younker
Apprentice
Apprentice


Joined: 18 Feb 2004
Posts: 267
Location: China

PostPosted: Fri Aug 18, 2006 1:39 am    Post subject: Reply with quote

when you move the window in the desktop, the speed is very slow now.

Hope this will soon be fixed.
Back to top
View user's profile Send private message
FatMom
n00b
n00b


Joined: 23 Feb 2006
Posts: 62

PostPosted: Fri Aug 18, 2006 1:48 am    Post subject: Reply with quote

I have a problem when trying to test xgl in a nested window, it gives me this error

Code:
FatBox fatmom # Xgl :1 -ac -accel glx:pbuffer -accel xv
X Error of failed request:  BadLength (poly request too large or internal Xlib length error)
  Major opcode of failed request:  143 (GLX)
  Minor opcode of failed request:  1 (X_GLXRender)
  Serial number of failed request:  91
  Current serial number in output stream:  92


why ? :'(
Back to top
View user's profile Send private message
Jupiter1TX
Guru
Guru


Joined: 24 Feb 2006
Posts: 546
Location: 3rd Rock

PostPosted: Fri Aug 18, 2006 2:12 am    Post subject: Reply with quote

FatMom wrote:
I have a problem when trying to test xgl in a nested window, it gives me this error

Code:
FatBox fatmom # Xgl :1 -ac -accel glx:pbuffer -accel xv
X Error of failed request:  BadLength (poly request too large or internal Xlib length error)
  Major opcode of failed request:  143 (GLX)
  Minor opcode of failed request:  1 (X_GLXRender)
  Serial number of failed request:  91
  Current serial number in output stream:  92


why ? :'(


I believe you can find a possible solution here
http://gentoo-wiki.com/HOWTO_XGL/Troubleshooting

It's halfway down that page there are 3 seperate solutions
depending on which graphics card you have

If it is your initial install i would bookmark that page as
most setup problems have been documented already

You might also be interested in the dedicated forum for
Gentoo XGL/Compiz at
http://forums.xgl-coffee.org/
_________________
Core i7 920 D0 | Asus P6T DLX | Patriot Viper 1600 6GB | Antec Quattro 850W
Geforce 8800GTX OC2 768MB | Dell 22" LCD | Koolance Exos2/Swiftech GTZ
GCC 4.6.1 | 3.7.x-geek | Xorg-7.4-x | KDE-4.7.x | Compiz
Back to top
View user's profile Send private message
FatMom
n00b
n00b


Joined: 23 Feb 2006
Posts: 62

PostPosted: Fri Aug 18, 2006 3:12 am    Post subject: Reply with quote

problem solved, never did eselect opengl set nvidia after emerge the driver and X was not able to load GLX, now its solved, and XGL works fine.

thx anyway !
Back to top
View user's profile Send private message
opqdan
Guru
Guru


Joined: 13 Dec 2004
Posts: 429
Location: Redmond, WA, USA

PostPosted: Fri Aug 18, 2006 2:24 pm    Post subject: Reply with quote

I just wanted to chime in here and say thank you to all the devs working on the packages (Xgl, compiz, cgwd), the overlay, and the gentoo wiki howto. I just upgraded to Xgl/compiz-quinnstorm/cgwd after using a Kororaa livecd and realizing that my ATI 9800 XT would indeed work (I seem to remember the wiki saying that it would not). All I had to do was follow the few simple commands in the wiki for setting it up. A few emerges, edit some config files, and voila, it works seeming-flawlessly.

This is as close to a simple, click-to-install, as it is possible to get in Linux. Thanks everyone.

Only problems I have are the kaffeine (xine) seems to skip a little bit sometimes, and that Google Earth is a little laggy (but suprisingly works, I assumed I would have to run it in a sepparate X server like a 3d game - but thhat hard locks my computer0). I assume that these problems have workarounds or fixes, so I'll have to read through the thread and find them.
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Fri Aug 18, 2006 2:34 pm    Post subject: Reply with quote

Please continue in XGL (Part 6).
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 35, 36, 37
Page 37 of 37

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum