Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Serious font problem with Nvidia driver.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
passive
Tux's lil' helper
Tux's lil' helper


Joined: 31 Dec 2004
Posts: 105

PostPosted: Fri Jun 09, 2006 12:40 pm    Post subject: Serious font problem with Nvidia driver. Reply with quote

Hi All,

I'm having a weird problem with my Nvidia driver. I've been using it successfully for a long time, but a recent world update caused KDE to stop displaying text (more or less). I thought it was a KDE problem, so a re-emerged that, then I thought it might be an Xorg problem so I re-emerged that. No luck in either case. Looking through X's startup log, I notice that the Nvidia driver seems to have a problem with the loaded GLX. It loads the xorg GLX first, then the Nvidia driver, then the Nvidia GLX. Once I noticed this, I switched to the "nv" driver, which worked fine. However, there are a couple of things that I depend on the Nvidia driver for, so if possible, I would prefer to use that.

Also, the other weird thing I noticed is that when I do a world update, I get a message about xorg-server >= 1.0.99 blocking nvidia-kernel. This is weird to me because I'm not trying to emerge either of these packages, they are both already installed. Any clues on that front?
Back to top
View user's profile Send private message
TheRAt
Veteran
Veteran


Joined: 03 Jun 2002
Posts: 1580
Location: Salt Spring Island, BC, Canada

PostPosted: Fri Jun 09, 2006 12:51 pm    Post subject: Reply with quote

the new xorg server does not work with the latest nvidia drivers ..
not sure if there is a version of the nvidia drivers that does as yet..
i believe there are two options available to you.. either switch to the opensources (nv) drivers or downgrade xorg to the previous version so it works with the nvidia drivers you have installed..
_________________
All reality is the construct of the observer.

Get Firefox and rediscover the web!

BOFH Excuse #295:
The Token fell out of the ring. Call us when you find it.
Back to top
View user's profile Send private message
passive
Tux's lil' helper
Tux's lil' helper


Joined: 31 Dec 2004
Posts: 105

PostPosted: Fri Jun 09, 2006 10:07 pm    Post subject: Reply with quote

I thought it might be something of that nature. I guess I'll stick with the nv driver until Nvidia's next release.
Back to top
View user's profile Send private message
drigz
n00b
n00b


Joined: 12 Sep 2004
Posts: 42

PostPosted: Fri Jun 09, 2006 10:28 pm    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-456172-highlight-disappearing+text.html

That fixed it for me, without having to use nv or anything like that.
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Sat Jun 10, 2006 9:24 pm    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads in favour of xorg-server-1.0.99.x ABI breaks nvidia/ati binary drivers.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum