Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[patch para xine-lib] como utilizarlo (CERRADO)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
dmery
Apprentice
Apprentice


Joined: 15 Sep 2004
Posts: 225
Location: Coral Gables, Florida, USA

PostPosted: Thu Jun 08, 2006 3:24 pm    Post subject: [patch para xine-lib] como utilizarlo (CERRADO) Reply with quote

Gentoonitas,

Necesito una auda en lo siguiente,

no puedo realizar una actualizacion del xine-lib por un bug que ya fue reportado y solucionado por @flambeyes. Pero no encuentro la manera de utilizar este patch:

Index: xine-lib-1.1.2cvs20060328/src/audio_out/audio_alsa_out.c
===================================================================
--- xine-lib-1.1.2cvs20060328.orig/src/audio_out/audio_alsa_out.c
+++ xine-lib-1.1.2cvs20060328/src/audio_out/audio_alsa_out.c
sigue.....


Si alguien me puede orientar estare muy agradecido ya que para mi es "latin antiguo"...por que seran tan "crypticos" en el mundo Linux ?

Un salu2
Daniel Mery
_________________
"El conocimiento es patrimonio de la humanidad, por lo tanto no tiene propietarios ni necesita de licencias"
Usuario linux registrado: 364487
Gentoo user
Arch user


Last edited by dmery on Thu Jun 08, 2006 9:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
pacho2
Developer
Developer


Joined: 04 Mar 2005
Posts: 2593
Location: Oviedo, Spain

PostPosted: Thu Jun 08, 2006 5:45 pm    Post subject: Reply with quote

En http://packages.gentoo.org/search/?sstring=xine-lib tienes las versiones de xine-lib, si quieres puedes intentar emerger o bien la estable o bien la de testing.
Back to top
View user's profile Send private message
dmery
Apprentice
Apprentice


Joined: 15 Sep 2004
Posts: 225
Location: Coral Gables, Florida, USA

PostPosted: Thu Jun 08, 2006 6:32 pm    Post subject: gracias por tu respuesta Reply with quote

Paco2 gracias por tu respuesta:

En http://packages.gentoo.org/search/?sstring=xine-lib tienes las versiones de xine-lib, si quieres puedes intentar emerger o bien la estable o bien la de testing.

pasa que parece que hay un bug y por lo que pude leer habria que actulaizar a GCC3.4, en mi caso utilizo 3.3. Pasa que Gentoo es mi sistema operativo de produccion y no quiero "'correr" riesgos con una actualizacion de GCC, hasta no estar bien seguro de lo que hago. En el pasado me ha jugado bien duro y me las he visto negras.
Estuve tratando de poder emerger el paquete:

media-libs/xine-lib-1.1.2_pre20060328-r11

pero no esta disponible por: (masked by: ~86 keyword).
por lo tanto en /etc/portage/package.keyword agregue la siguiente linea:
=media-libs/xine-lib-1.1.2_pre20060328-r11 ~86
pero nada sigue queriendo emerger el paquete del bug, o sea el: media-libs/xine-lib-1.1.2_pre20060328-r9
cambie en /etc/package.keywords a:
media-libs/xine-lib ~86
la misma cuestion.
Trate de inhibir en /etc/portage/package.mask
=media-libs/xine-lib-1.1.2_pre20060328-r9 (el paquete del bug)
entonce quiere realizar un "downgrade" al paquete 1.1.1( o sea mas antiguo que el instalado), el cual enmascare, pero absolutatamente nada, me comenta que estan todos enmascarados y bla bla bla.

Asi que supongo que no estare realizando algun paso en forma correcta, en fin no se...se me quemaron los papeles. :oops:
Si tienes alguna idea de donde estoy cometiendo la "burrada" :twisted: avisame por favor, he leido y re-leido los manuales, pero no me doy cuenta.
Gracias por tu ayuda
Salu2
Daniel Mery :D
_________________
"El conocimiento es patrimonio de la humanidad, por lo tanto no tiene propietarios ni necesita de licencias"
Usuario linux registrado: 364487
Gentoo user
Arch user
Back to top
View user's profile Send private message
pacho2
Developer
Developer


Joined: 04 Mar 2005
Posts: 2593
Location: Oviedo, Spain

PostPosted: Thu Jun 08, 2006 7:20 pm    Post subject: Reply with quote

Creo que es ~x86 , no ~86

Saludos :)
Back to top
View user's profile Send private message
dmery
Apprentice
Apprentice


Joined: 15 Sep 2004
Posts: 225
Location: Coral Gables, Florida, USA

PostPosted: Thu Jun 08, 2006 9:51 pm    Post subject: Gracias por tu respuesta Reply with quote

En realidad fue un error en el tipeo del post, en /etc/portage/package.keyword lo colocaba correctamente.
Pero afortunadamente encontre el como de mi "horror" (lease error), cuando lo hice me permitia emerger correctamente la version r11, pero yo la confundia con la 1.1.1:
en /etc/portage/package solo debo agregar:

media-libs/xine-lib ~x86

sin necesidad de emascarar la version r9
pero al compilar xine-lib me da otro error que creo esta vinculado al bug en cuestion.
Muchisimas gracias por tu ayuda
Salu2
Daniel Mery :D
_________________
"El conocimiento es patrimonio de la humanidad, por lo tanto no tiene propietarios ni necesita de licencias"
Usuario linux registrado: 364487
Gentoo user
Arch user
Back to top
View user's profile Send private message
pacho2
Developer
Developer


Joined: 04 Mar 2005
Posts: 2593
Location: Oviedo, Spain

PostPosted: Fri Jun 09, 2006 6:36 pm    Post subject: Reply with quote

Si pones el error mejor ;)

Saludos :)
Back to top
View user's profile Send private message
Pablo S. Barrera
l33t
l33t


Joined: 16 May 2006
Posts: 642
Location: Mataderos. Argentina. America del Sur

PostPosted: Mon Jun 12, 2006 1:34 am    Post subject: Reply with quote

Hola. Tengo este problema. Alguien me podria decir que es lo que debo hacer? Realmente intente inyectar el ebuild R11 y me tiro un error tambien. Perdon pero sinceramente no entiendo que es lo que debo hacer.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum