Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Samba 3.0 on Fedora Linux, unable to write to shares
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Joncamp
n00b
n00b


Joined: 06 Jun 2006
Posts: 11
Location: Florida

PostPosted: Tue Jun 06, 2006 5:10 pm    Post subject: Samba 3.0 on Fedora Linux, unable to write to shares Reply with quote

Has anyone had success with Samba 3.0 on Linux? I am having trouble getting write permission on Samba shares from Windows XP clients. Someone told me to make sure "writeable=yes" on the smb.conf share configuration. I've done that, I've given full permissions on the Linux chmod share permissions too.

Thanks. :lol:
Back to top
View user's profile Send private message
runningwithscissors
Guru
Guru


Joined: 21 Apr 2006
Posts: 454
Location: the third world

PostPosted: Tue Jun 06, 2006 5:11 pm    Post subject: Reply with quote

Post smb.conf
_________________
At some stage, the Hindus locked on to the nation destroying concepts like ahimsa (non-violence), shanti (peace), satya (truth) — the ‘ass’ syndrome.
Back to top
View user's profile Send private message
Joncamp
n00b
n00b


Joined: 06 Jun 2006
Posts: 11
Location: Florida

PostPosted: Tue Jun 06, 2006 5:41 pm    Post subject: Here is the smb.conf file, from Samba 3.0.22.... Reply with quote

#======================= Global Settings =====================================
[global]

# workgroup = NT-Domain-Name or Workgroup-Name
workgroup = MYGROUP

# server string is the equivalent of the NT Description field
server string = Samba Server2

; hosts allow = 192.168.1. 192.168.2. 127.

printcap name = /etc/printcap
load printers = yes

; printing = bsd

; guest account = pcguest

log file = /var/log/samba/log.smbd

max log size = 50

security = user
; password server = <NT-Server-Name>

; password level = 8
; username level = 8

; encrypt passwords = yes
; smb passwd file = /etc/samba/smbpasswd

; unix password sync = Yes
; passwd program = /usr/bin/passwd %u
; passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*

; username map = /etc/samba/smbusers

; include = /etc/samba/smb.conf.%m

socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

; interfaces = 192.168.12.2/24 192.168.13.2/24

; remote browse sync = 192.168.3.25 192.168.5.255
; remote announce = 192.168.1.255 192.168.2.44

; local master = no

; os level = 33

; domain master = yes

; preferred master = yes

; domain logons = yes

; logon script = %m.bat
; logon script = %U.bat

; logon path = \\%L\Profiles\%U

; name resolve order = wins lmhosts bcast

; wins support = yes

; wins server = w.x.y.z

; wins proxy = yes

dns proxy = no

; preserve case = no
; short preserve case = no

; default case = lower

; case sensitive = no

#============================ Share Definitions ==============================
[homes]
comment = Home Directories
browseable = no
writable = yes

[printers]
comment = All Printers
path = /var/spool/samba
browseable = no
guest ok = no
writable = no
printable = yes


[myshare]
comment = Root and Jon's stuff
path = /myshare
valid users = root jon
public = no
writable = yes
printable = no
create mask = 7777
Back to top
View user's profile Send private message
asommer
n00b
n00b


Joined: 15 Nov 2005
Posts: 36

PostPosted: Tue Jun 06, 2006 5:49 pm    Post subject: Reply with quote

I'm not sure, but isn't this line
Quote:
valid users = root jon


Supposed to be something like
Code:
valid users = root,jon

_________________
Party On!
Back to top
View user's profile Send private message
runningwithscissors
Guru
Guru


Joined: 21 Apr 2006
Posts: 454
Location: the third world

PostPosted: Tue Jun 06, 2006 6:11 pm    Post subject: Reply with quote

Uncomment the guest account=pcguest line
Substitute pcguest with some user on your local machine
After the guest account line add the following line
guest ok = yes
Add the guest ok = yes line to the options for the samba share as well.
Add another option valid users = <username you substituted in place of pcguest> to the options of the samba share

Also, try changing the security option to share instead of user.
_________________
At some stage, the Hindus locked on to the nation destroying concepts like ahimsa (non-violence), shanti (peace), satya (truth) — the ‘ass’ syndrome.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum