Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GeForce 5200 - Toimiiko XGL ? [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Finnish
View previous topic :: View next topic  
Author Message
linuxtuxhellsinki
l33t
l33t


Joined: 15 Nov 2004
Posts: 692
Location: Hellsinki

PostPosted: Sun Jun 04, 2006 7:18 pm    Post subject: GeForce 5200 - Toimiiko XGL ? [Solved] Reply with quote

Eli tuli tossa ostettua tommonen Xfx GeForce 5200 128mb näyttis (nykyinen on joku 7000Radeon) ja ajattelin näin etukäteen kysästä ennen kuin sen saa käsiin, että kannattaako lähteä yrittämään asentamaan XGL/AiGXL, eli jaksaako se pyörittää kuutiota ym. karkkeja :?:
Edit : Ihan hienosti pyörii Compiz, mutta jos on kääntöhommat kesken niin vähän jumittaa.

Ja mitkä ajurit siihen kannattaa asentaa, Kernel / Binary :?:
Tai siis onko kellään ollut mitään ongelmia binääri ajureiden kanssa ? On nääs jäännyt semmoinen bullin maku kaikenlaisista bin-ajureista, kun on leikkinyt joidenkin ADSL-modeemin ym. roska-ajureiden kanssa, jotka on ainoita kertoja kun on saannut Linukan nurin :evil:
Edit : Eipä ole kyllä mitään valittamista NVidian bin-ajureista (f**k ati, tai ainakin TeleHell) :P

Oon kyllä lueskellut tota http://www.gentoo.org/doc/en/nvidia-guide.xml, mutta olis kiva kuulla kokemuksista ja jotain xorg.conffi vinkkejä jos löytyy. Ja toi XGL juttu kyllä kiinnostais mutten viitsi lähteä sitä väkisin vääntämään, pääasia että saa ton translucencyn (onkse Suamex läpikuultavuus ?) toimimaan kun ei toi radeoni(32MB) sitä oikeen jaksa pyörittää :roll:
_________________
1st use 'Search' & lastly add [Solved] to
the subject of your first post in the thread.


Last edited by linuxtuxhellsinki on Mon Nov 06, 2006 1:44 pm; edited 3 times in total
Back to top
View user's profile Send private message
pussi
l33t
l33t


Joined: 08 May 2004
Posts: 727
Location: Finland

PostPosted: Sun Jun 04, 2006 10:11 pm    Post subject: Re: GeForce 5200 - Toimiiko XGL ? Mitkä ajurit ? ? ? Reply with quote

Ensinnäkään nvidialle ei löydy open source 3d-ajureita, eli jos haluat pyöritellä xgl:ää tai pelailla jotain 3d-ominaisuuksia vaativia pelejä niin binääriajurit on oltava. Toisaalta nvidian ajureita kehutaan paljon ati:n ajureita paremmaksi eikä itselläni ainakaan ole ollut suurempia ongelmia niiden kanssa.

Xgl:n pitäisi nvidian korteilla toimia ihan moitteetta ja ajuritukeakin ovat lupailleet tulevaisuudessa (joskus 1.0.9*** aikoihin aikaisintaan). Nykyisellään tuo että jaksaako ne karkit pyöriä ei kylläkään riipu yhtään näytönohjaimesta, koska tuota ajuritukea ei vielä taida olla (ellei sitten näille ati:n opensource ajureille, mene ja tiedä).

Jos käytät normaalia xorgia niin näytönohjaimella ei ole vaikutusta compositen nopeuteen. Tosin nvidiassa on joku renderaccel systeemi minkä saat xorg.conffista päälle mutta hyvällä tuurilla sekin kaataa konee minuutin välein.
Back to top
View user's profile Send private message
linuxtuxhellsinki
l33t
l33t


Joined: 15 Nov 2004
Posts: 692
Location: Hellsinki

PostPosted: Sun Jun 04, 2006 10:30 pm    Post subject: Re: GeForce 5200 - Toimiiko XGL ? Mitkä ajurit ? ? ? Reply with quote

pussi wrote:
Jos käytät normaalia xorgia niin näytönohjaimella ei ole vaikutusta compositen nopeuteen. Tosin nvidiassa on joku renderaccel systeemi minkä saat xorg.conffista päälle mutta hyvällä tuurilla sekin kaataa konee minuutin välein.

Juu ei mitään koneen kaato kikkoja (nimim. saannut aikoinaan tarpeeksi Redmondin OS:n siitä 'ominaisuudesta'), mutta olis kiva kuulla jotain kokemuksia eri optioista kyseisen kortin kanssa ?
_________________
1st use 'Search' & lastly add [Solved] to
the subject of your first post in the thread.
Back to top
View user's profile Send private message
pussi
l33t
l33t


Joined: 08 May 2004
Posts: 727
Location: Finland

PostPosted: Sun Jun 04, 2006 11:27 pm    Post subject: Reply with quote

No voisin kyllä mainita että nykyisin tuon renderaccelin pitäisi kai olla jo aika vakaa systeemi (olisiko jopa päällä defaulttina). Lähinnä kaatuilua tapahtui 1.0.7***-sarjan ajureilla jotka olivat itselläni aika epävakaat muutenkin.

Sinuna ainakin koittaisin tuota renderaccelia koska se kuitenkin nopeuttaa compositea aika mukavasti. Jos ei pelitä vakaasti niin senhän voi aina ottaa pois päältä.

Ja senhän saa päälle lisäämällä tämän xorg.conffiin tiedät kyllä mihin kohtaan:
Code:
Option   "RenderAccel" "True"


Ja jos haluat käyttää glx:ää compositen kanssa niin tämä helpottaa huomattavasti sitä hommaa:
Code:
Option   "AllowGLXWithComposite" "True"
Back to top
View user's profile Send private message
Toomuch
n00b
n00b


Joined: 16 Mar 2004
Posts: 45

PostPosted: Mon Jun 05, 2006 2:00 pm    Post subject: Re: GeForce 5200 - Toimiiko XGL ? Mitkä ajurit ? ? ? Reply with quote

linuxtuxhellsinki wrote:
Eli tuli tossa ostettua tommonen Xfx GeForce 5200 128mb näyttis (nykyinen on joku 7000Radeon) ja ajattelin näin etukäteen kysästä ennen kuin sen saa käsiin, että kannattaako lähteä yrittämään asentamaan XGL/AiGXL, eli jaksaako se pyörittää kuutiota ym. karkkeja :?:


Kokeile Kororaan XGL-livecdtä: http://kororaa.org/static.php?page=static060318-181203

Sillä ainakin näkee miten KDE ja Gnome -kuutiotyöpöydät pyörähtää karkkeineen Xgl:llä. Ite kokeilin Geforce2:lla ja P3:lla ja hyvin toimi.

t
Back to top
View user's profile Send private message
linuxtuxhellsinki
l33t
l33t


Joined: 15 Nov 2004
Posts: 692
Location: Hellsinki

PostPosted: Mon Jun 05, 2006 8:23 pm    Post subject: Reply with quote

Kiitos linkistä, nimittäin pitikin juuri etsiä se ja laittaa latautumaan 8)
Sain tuon kortin juuri käsiini ja pitää katsoa jos huomis iltana ehtisi sen asentamaan.

Pari selventävää kysymystä olisi ollut, eli meneekö homma niin että pitää vaan emergata nvidia-kernel ja nvidia-glx (kannattaako ottaa ~x86 ?) ja ehkä sitten lisätä nvidia USE-flagi make.confiin. Mutta menikö se siis niin että pitää aina emergata nvidia-kernel joka Kernelin päivityksen yhteydessä ja tuleeko se ns. modulina että voi kuitenkin käyttää eri Kerneleitä, vai onko sitä sidottuna siihen viimeiseen niiden ajurien kanssa :?:

Ja pitää se näköjään joka tapauksessa kääntää Kernel uusix, kun on toi CONFIG_DRM_RADEON=y :?
_________________
1st use 'Search' & lastly add [Solved] to
the subject of your first post in the thread.
Back to top
View user's profile Send private message
Obi-Lan
Apprentice
Apprentice


Joined: 21 Jan 2005
Posts: 230
Location: Riihimäki

PostPosted: Mon Jun 05, 2006 8:48 pm    Post subject: Reply with quote

Käytännössä se on mulla menny niin, että aina kun vaihtaa kerneliä niin joutuu emergee nvidia-kernelin. Siis kernelin käännön jälkeen. nvidia-glx tarvii päivittää jos on säätäny jotain X kans tai ajuriversio on päivittynyt. Itelläni on Geforce 6600GT ja nvidia-ajurit toimii vallan mainiosti. Pystyy pelaa Civ4 Cedegalla melkei täysil resoil ja detaileil. Ja käytössä ~amd64 ajurit :wink:
Back to top
View user's profile Send private message
linuxtuxhellsinki
l33t
l33t


Joined: 15 Nov 2004
Posts: 692
Location: Hellsinki

PostPosted: Wed Jun 07, 2006 11:17 am    Post subject: Reply with quote

No muuten asennus ja muut meni ihan Ok, mutta kun koittaa startata X:n niin tulee virheilmo
Code:
FATAL: Error inserting nvidia (/lib/modules/2.6.16-gentoo-r9/video/nvidia.ko): Invalid module format

Nvidia-kernel ja -glx ovat ~x86 versiot 1.0.8762 ja eivät herjanneet mitään asennuksen aikana, mutta nyt heittää tuommoista herjaa myös silloin jos koittaa modprobeta modulin käsin.

Just ennen tätä tuli päiviteltyä koko systeemi ja käännettyä toi uus Kerneli tätä varten ohjeiden mukaan. Asensin myös ensin uuden 4.1.1GCC:n, jonka myös vedin ohjeiden mukaan eli käänsin sillä sitten libtoolin, glibc:n, binutilsin ja vielä itsensä uudestaan, ja siihen perään revdep-rebuildin ja sitten vasta uuden Kernelin ja nvidiat.

Ok ! Homma poikki, se lähtikin toimimaan kun forcetti modprobe -f nvidia (Glxgears ~2600, onko Ok?)
Mutta nyt sitten jäi yksi kysymys, eli ei kai sitä nyt tarvitse joka kerta käsin forcetella ruuttina :?:
Edit : Tähän ongelmaan löytyi vastaus kun oli näköjään Kernel tullut käännettyä vanhalla GCC-3.4:lla ja Nvidia halusi että se on 4.1.1:llä :)
_________________
1st use 'Search' & lastly add [Solved] to
the subject of your first post in the thread.


Last edited by linuxtuxhellsinki on Sun Jun 18, 2006 8:18 pm; edited 1 time in total
Back to top
View user's profile Send private message
AnXa
Apprentice
Apprentice


Joined: 06 Apr 2004
Posts: 250
Location: Lahti, Finland

PostPosted: Fri Jun 16, 2006 5:38 pm    Post subject: Reply with quote

linuxtuxhellsinki wrote:
Ok ! Homma poikki, se l�htikin toimimaan kun forcetti modprobe -f nvidia (Glxgears ~2600, onko Ok?)
Mutta nyt sitten j�i yksi kysymys, eli ei kai sit� nyt tarvitse joka kerta k�sin forcetella ruuttina :?:


heh, mulla on FX5700 ja tulee ~3000-5000 riippuen onko XGL päällä vai ei. FX5200 ei ole mikään teho hirmu joten toi on ihan ok.

Moduulista sen verran, että laita se automaattisesti latautumaan tonne /etc/modules.autoload/kernel-2.6 tiedostoon. Silloin se lataa itsensä aina käynnistyksen yhteydessä. Toi moduulin lataamis ongelma voi olla seurausta siitä että olet kääntänyt ensin moduulin ja sitten kernelin. Kannattaa kokeilla kääntää nvidia-kernel pakettia uudestaan. Toinen voi olla, että sulla on kernelin moduulien versio numerointi päällä. Se ei kato hyvällä tuota nvidian-binaaria, sen kytkee pois ei pitäis olla mitään ongelmaa. Kolmas hyvin epätodennäköinen homma voi olla, että ATin joku kernelin sisäänrakennettu juttu estää moduulin lataamisen. Mutta en usko siihen koska se näköjään latautuu pakotettuna systeemiin. :)

Voin olla tumpelo kiintolevyjen kanssa, mutta tän jutun mä osaan. ;D
_________________
The idea isn't about how do you see or hear it, it's about how do you experience it...
--//--
Asus K8V Deluxe, Athlon64 3500+, nVidia 7600 GT, 3Gb 400MHz DDR, IDE HD 160Gb, IDE HD 850Mb and SATA HD 250Gb
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Finnish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum