Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg-server blocking nvidia-glx
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
rojanu
Guru
Guru


Joined: 02 Feb 2004
Posts: 361
Location: London

PostPosted: Sat Jun 03, 2006 1:51 pm    Post subject: Xorg-server blocking nvidia-glx Reply with quote

when I have tried to update the world I faced
Code:
[blocks B     ] >=x11-base/xorg-server-1.0.99 (is blocking media-video/nvidia-glx-1.0.8762)
[ebuild     U ] x11-base/xorg-server-1.1.0 [1.0.2-r4] USE="dri ipv6 nptl% sdl% xorg% -3dfx% -debug -dmx% -kdrive% -minimal -xprint" INPUT_DEVICES="keyboard% mouse% vmmouse% -acecad% -aiptek% -calcomp% -citron% -digitaledge% -dmc% -dynapro% -elo2300% -elographics% -evdev% -fpit% -hyperpen% -jamstudio% -joystick% -magellan% -magictouch% -microtouch% -mutouch% -palmax% -penmount% -spaceorb% -summa% -synaptics% -tek4957% -ur98% -void% -wacom%" VIDEO_CARDS="nvidia% vga% vmware% -apm% -ark% -chips% -cirrus% -cyrix% -dummy% -epson% -fbdev% -fglrx% -glint% -i128% -i740% -i810% -imstt% -mach64% -mga% -neomagic% -nsc% -nv% -r128% -radeon% -rendition% -s3% -s3virge% -savage% -siliconmotion% -sis% -sisusb% -tdfx% -tga% -trident% -tseng% -v4l% -vesa% -via% -voodoo%" 6,174 kB
[ebuild     U ] x11-drivers/xf86-input-mouse-1.1.1 [1.0.4] USE="-debug" 261 kB
[ebuild     U ] x11-drivers/xf86-video-vga-4.1.0 [4.0.0.5] USE="-debug" 228 kB
[ebuild     U ] x11-drivers/xf86-input-vmmouse-12.4.0 [12.3.2.0] USE="-debug" 235 kB
[ebuild  N    ] media-video/nvidia-glx-1.0.8762  USE="-dlloader" 0 kB
[ebuild     U ] x11-drivers/xf86-video-vmware-10.13.0 [10.12.0.0] USE="-debug" 253 kB
[ebuild     U ] x11-drivers/xf86-input-keyboard-1.1.0 [1.0.1.3] USE="-debug" 226 kB

however I haven't got xorg-server-1.0.99 as it can be seen portage is trying to update version 1.0.2-r4 I thought may be installed nvidia-glx was causing the problem unmerging it did not solved anything,

Any ideas?
_________________
"Any fool can write code that a computer can understand. Good programmers write code that humans can understand." --- Martin Fowler,
Linux User: #416714
Back to top
View user's profile Send private message
skunk
Guru
Guru


Joined: 28 May 2003
Posts: 574
Location: granada, spain

PostPosted: Sat Jun 03, 2006 2:09 pm    Post subject: Reply with quote

afaik, nvidia drivers are still not compatible with xorg 7.1 which xorg-server-1.1.0 is part of
if you want xorg 7.1 you should uninstall the nvidia driver and use the nv open source driver
Back to top
View user's profile Send private message
rojanu
Guru
Guru


Joined: 02 Feb 2004
Posts: 361
Location: London

PostPosted: Sat Jun 03, 2006 2:29 pm    Post subject: Reply with quote

Thank you that was it, I think I have been searching with wrong terms, What is the difference between using nv and nvidia. also I should mantion I am no gamer so I am do not heavy graphics.
_________________
"Any fool can write code that a computer can understand. Good programmers write code that humans can understand." --- Martin Fowler,
Linux User: #416714
Back to top
View user's profile Send private message
skunk
Guru
Guru


Joined: 28 May 2003
Posts: 574
Location: granada, spain

PostPosted: Sat Jun 03, 2006 2:34 pm    Post subject: Reply with quote

nvidia has hw accelerated 3d support but is propietary while nv has not 3d and is open source...
if you don't need 3d nv will work fine
Back to top
View user's profile Send private message
Matteo Azzali
Retired Dev
Retired Dev


Joined: 23 Sep 2004
Posts: 1133

PostPosted: Sat Jun 03, 2006 3:42 pm    Post subject: Reply with quote

Care that not only games use 3d, also blender , opengl screensavers, wings3D , K3D , etc.etc.
_________________
Every day a new distro comes to birth. Every day a distro "eats" another.
If you're born distro, no matter what, start to run.
---- http://www.linuxprinting.org/ ---- http://tuxmobil.org/
Back to top
View user's profile Send private message
Roguelazer
Veteran
Veteran


Joined: 10 Feb 2003
Posts: 1233
Location: Harvey Mudd College

PostPosted: Sat Jun 03, 2006 5:36 pm    Post subject: Reply with quote

Not to mention that 2D is also much faster with binary drivers, and don't even think about using XCOMPOSITE or XGL on the open-source driver...
_________________
Registered Linux User #263260
Back to top
View user's profile Send private message
agent_jdh
Veteran
Veteran


Joined: 08 Aug 2002
Posts: 1776
Location: Scotland

PostPosted: Sat Jun 03, 2006 5:50 pm    Post subject: Reply with quote

This is a bit strange - even though I've uninstalled nvidia-glx and nvidia-kernel, removed nvidia from my USE flags, and changed VIDEO_CARDS to nv instead of nvidia in make.conf, an emerge -upDv world is still showing the xorg-server blocker and says it wants to reinstall the nvidia kernel and glx ebuilds. What gives with this?

EDIT - DOH, just worked it out, xorg-server-1.1.0 was emerge'd before I changed my VIDEO_CARDS variable. Hopefully a re-emerge of that will solve the problem.

EDIT #2 - nvidia-settings needed to be unmerged to prevent emerge wanting to re-install the nvidia binary drivers.
_________________
Jingle Jangle Jewellery
Back to top
View user's profile Send private message
ash
n00b
n00b


Joined: 19 Mar 2003
Posts: 27

PostPosted: Sat Jun 03, 2006 8:51 pm    Post subject: Reply with quote

skunk wrote:
afaik, nvidia drivers are still not compatible with xorg 7.1 which xorg-server-1.1.0 is part of
if you want xorg 7.1 you should uninstall the nvidia driver and use the nv open source driver


okay, so the nvidia drivers aren't compatible with xorg 7.1 (or so I just found out). so adding to my /etc/portage/package.mask, I now have something like this:

Code:
>media-video/nvidia-glx-1.0.7174-r5
>media-video/nvidia-kernel-1.0.7174-r2
>media-video/nvidia-settings-1.0.7167
>=x11-base/xorg-x11-7.1
>=x11-base/xorg-server-1.0.99
>=x11-drivers/xf86-input-keyboard-1.1.0
>=x11-drivers/xf86-input-mouse-1.1.0
>=x11-drivers/xf86-input-joystick-1.1.0


(The older nvidia-{kernel,driver} because I have to use the old unified driver.) Gentoo has been good about keeping the older nvidia-drivers available in portage, but what about xorg 7.0? do they plan on continued support of that? Surely they don't want to alienate everyone that uses the 3D drivers - or is there a planned (compatibility) fix?
Back to top
View user's profile Send private message
punkmikey
n00b
n00b


Joined: 23 Apr 2005
Posts: 43
Location: Sheffield, UK

PostPosted: Sat Jun 03, 2006 9:16 pm    Post subject: Reply with quote

I had the same problem this morning. I just went back to xorg 7.0 and added xorg 7.1 to package.mask for now.

Aparently nvidia will support xorg 7.1 in the 9xxx series drivers.
_________________
Intel Core Quad Q6600 @ 3GHz
4gig DDR2 RAM
GeForce 8800 GTS 640MB
Abit IP35
Soundblaster Audigy2
Back to top
View user's profile Send private message
ApeFan
n00b
n00b


Joined: 19 Oct 2003
Posts: 1
Location: Germany

PostPosted: Sun Jun 04, 2006 10:56 am    Post subject: Reply with quote

In case anyone's interested, the current NVidia drivers DO in fact somewhat work with X.Org 7.1 (even GL), but font rendering is b0rked.
Back to top
View user's profile Send private message
bushwakko
Guru
Guru


Joined: 25 Mar 2003
Posts: 495

PostPosted: Sun Jun 04, 2006 12:19 pm    Post subject: Reply with quote

I had to mask all this stuff, it took me a while, so I'll just paste it here, if someone might need it too:

>=x11-base/xorg-x11-7.1
>=x11-base/xorg-server-1.0.99
>=x11-drivers/xf86-input-keyboard-1.1.0
>=x11-drivers/xf86-input-mouse-1.1.0
>=x11-drivers/xf86-input-joystick-1.1.0
>=x11-drivers/xf86-input-spaceorb-1.1.0
>=x11-drivers/xf86-input-summa-1.1.0
>=x11-drivers/xf86-input-elo2300-1.1.0
>=x11-drivers/xf86-input-elographics-1.1.0
>=x11-drivers/xf86-input-jamstudio-1.1.0
>=x11-drivers/xf86-input-palmax-1.1.0
>=x11-drivers/xf86-input-dynapro-1.1.0
>=x11-drivers/xf86-input-ur98-1.1.0
>=x11-drivers/xf86-input-evdev-1.1.2-r1
>=x11-drivers/xf86-input-citron-2.2.0
>=x11-drivers/xf86-input-hyperpen-1.1.0
>=x11-drivers/xf86-input-aiptek-1.0.1
>=x11-drivers/xf86-input-calcomp-1.1.0
>=x11-drivers/xf86-input-void-1.1.0
>=x11-drivers/xf86-input-digitaledge-1.1.0
>=x11-drivers/xf86-input-microtouch-1.1.0
>=x11-drivers/xf86-input-dmc-1.1.0
>=x11-drivers/xf86-input-fpit-1.1.0
>=x11-drivers/xf86-input-penmount-1.2.0
>=x11-drivers/xf86-input-penmount-1.1.0
>=x11-drivers/xf86-input-mutouch-1.1.0
>=x11-drivers/xf86-input-tek4957-1.1.0
>=x11-drivers/xf86-input-acecad-1.1.0
>=x11-drivers/xf86-input-magellan-1.1.0
_________________
Macbook Pro 15"
Core 2 Duo 2,33ghz
2gb Ram
ATI Mobility x1600 256mb
Back to top
View user's profile Send private message
MatzeOne
Guru
Guru


Joined: 07 Sep 2003
Posts: 579
Location: Hamburg, Germany

PostPosted: Sun Jun 04, 2006 2:59 pm    Post subject: Reply with quote

Thanks bushwakko. I'll use it for my package.mask.
_________________
Mit null lässt sich eine ganze Menge machen.
Sportschule Hamburg
Back to top
View user's profile Send private message
crotty
n00b
n00b


Joined: 25 Apr 2002
Posts: 70

PostPosted: Tue Jun 06, 2006 1:58 am    Post subject: Reply with quote

hey,
can you guys drop a little knowledge on me, and let me know how to fully move back to xorg 7.0 ? I'm kinda stuck in the middle of the upgrade (a kde emerge failed), and now it won't get started again because nvidia-glx is blocking.
i put the stuff from bushwakko in my /etc/portage/package.mask file, but it's still not gonna fly...

thanks very much in advance

Code:
Calculating world dependencies... done!
[blocks B     ] >=x11-base/xorg-server-1.0.99 (is blocking media-video/nvidia-glx-1.0.8762)
[ebuild     U ] app-portage/gentoolkit-0.2.2 [0.2.2_rc1]
[ebuild     U ] www-client/mozilla-firefox-1.5.0.4 [1.5.0.3]
[nomerge      ] media-sound/amarok-1.4.0a
[ebuild     U ]  dev-lang/ruby-1.8.4.20060529 [1.8.4.20060226]
[ebuild     U ] app-editors/vim-7.0.17 [7.0-r2]
[ebuild     U ]  app-editors/vim-core-7.0.17 [7.0-r2]
[ebuild     U ] kde-base/kde-3.5.3 [3.5.2]
[ebuild     U ]  kde-base/kdetoys-3.5.3 [3.5.2] USE="-kdehiddenvisibility%"
[ebuild     U ]  kde-base/kdeutils-3.5.3 [3.5.2] USE="-kdehiddenvisibility%"
[ebuild     U ]  kde-base/kdeedu-3.5.3 [3.5.2] USE="-kdehiddenvisibility%"
[ebuild     U ]  kde-base/kdegraphics-3.5.3 [3.5.2] USE="-kdehiddenvisibility%"
[ebuild     U ]   app-text/poppler-bindings-0.5.3 [0.5.2]
[ebuild     U ]  kde-base/kdewebdev-3.5.3 [3.5.2] USE="-kdehiddenvisibility%"
[ebuild     U ]  kde-base/kdeadmin-3.5.3 [3.5.2] USE="-kdehiddenvisibility%"
[ebuild     U ]  kde-base/kdenetwork-3.5.3 [3.5.2] USE="-kdehiddenvisibility%"
[ebuild     U ]  kde-base/kdeaddons-3.5.3 [3.5.2-r1] USE="-kdehiddenvisibility%"
[ebuild     U ]   kde-base/kdemultimedia-3.5.3 [3.5.2-r2] USE="musicbrainz* -akode% -kdehiddenvisibility%"
[nomerge      ] media-plugins/xmms-mpg123-1.2.10-r1
[ebuild     U ]  media-libs/xine-lib-1.1.2_pre20060328-r11 [1.1.2_pre20060328-r10] VIDEO_CARDS="-nvidia*"
[nomerge      ] net-fs/samba-3.0.22-r2
[nomerge      ]  x11-libs/qt-3.3.6-r1
[nomerge      ]   net-print/cups-1.1.23-r7
[ebuild     U ]    app-text/poppler-0.5.3 [0.5.1-r1]
[nomerge      ] media-video/nvidia-glx-1.0.8762
[ebuild     UD]  x11-base/xorg-server-1.0.2-r4 [1.1.0]
[nomerge      ] virtual/libstdc++-3.3
[nomerge      ] media-sound/alsa-utils-1.0.11
[nomerge      ]  media-libs/alsa-lib-1.0.11-r1
[nomerge      ]   sys-kernel/gentoo-sources-2.6.16-r9
[nomerge      ]    sys-fs/udev-090
[ebuild     U ]     sys-apps/baselayout-1.12.1 [1.12.0-r1]
[ebuild     U ] sys-apps/portage-2.1_rc4-r2 [2.1_rc4-r1]
Back to top
View user's profile Send private message
mrpete
Apprentice
Apprentice


Joined: 01 Sep 2003
Posts: 184

PostPosted: Tue Jun 06, 2006 8:05 am    Post subject: Reply with quote

Do an emerge -C nvidia-glx and then you should be ok. So long as you have got
Code:
VIDEO_CARDS="nvidia"

in your /etc/make.conf file it should pull it back in on the downgrade
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Tue Jun 06, 2006 8:26 am    Post subject: Reply with quote

Please follow up to xorg-server-1.0.99.x ABI breaks nvidia/ati binary drivers.

Moved from Desktop Environments to Duplicate Threads.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum