Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xbox, bootstrapping, glibc complains kernel too low version
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
Proctologist
n00b
n00b


Joined: 11 Mar 2006
Posts: 9

PostPosted: Sat Jun 03, 2006 2:08 am    Post subject: xbox, bootstrapping, glibc complains kernel too low version Reply with quote

For some reason whenever I try to bootstrap and my XBOX goes to compile glibc, it gripes that the kernel is too old. I'm using the normal XBOX install disc and I haven't seen anyone else with this issue. Is there something I forgot to do or I need to do that I must've overlooked in the installation instructions? This is aggrivating considering I've followed this to the T basically, I've installed gentoo on other architechtures before and this is the only issue I'm having with it, and it does not make any sense. I'm feeling I may have to continue this installation on another computer I have with gentoo through a chroot just so this dumb thing will actually compile.

If I don't need to do my second idea, please tell me how. If my second idea won't work, please tell me why. If I didn't have to have NPTL support I might be able to just re-emerge glibc later with support so I can just install this base system. I believe I'm just going to go forward and repeat my installation and see if I run into the same problem in a few days.

Thanks in advance,
Doug
Back to top
View user's profile Send private message
Proctologist
n00b
n00b


Joined: 11 Mar 2006
Posts: 9

PostPosted: Sun Jun 04, 2006 7:16 am    Post subject: Reply with quote

well, I think I figured out what happened. before, whenever I first tried to bootstrap, it was complaining that nptl would not be built for i386, and needed i486+. So, after it had compiled half of the things already, it failed and I had to go edit my make.conf to make it i686. well, when I resumed the bootstraping with my xbox hard drive in my computer (with a 2.6 kernel ;)) it compiled everything, but started acting just really funky... So... I just trashed it all (saved my CORRECT make.conf) and restarted the install so now I'm emerging my system and it seems to be working perfectly. So yeah... I know this is a duh kinda thing, but don't mess up your make.conf y'all. haha
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum