Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pam-login and shadow: unemerging of pam-login doesn't work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
therisen
n00b
n00b


Joined: 27 May 2006
Posts: 36
Location: Germany

PostPosted: Wed May 31, 2006 8:25 pm    Post subject: pam-login and shadow: unemerging of pam-login doesn't work Reply with quote

Hi there,

after upgrading my gcc i tried to update my world. The following message appeared:

Quote:
[blocks B ] sys-apps/pam-login (is blocking sys-apps/shadow-4.0.15-r2)


So I had a look on the internet and found the actual solution:

Code:
emerge -c pam-login && emerge -u shadow


emerge answers:
Quote:
>>> clean: No packages selected for removal.


So what? I also tried "emerge -c sys-apps/pam-login" without any success.

Finally I did a search for the two packages on my system:

Quote:
Searching... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..
[ Results for search key : pam-login ]
[ Applications found : 1 ]

* sys-apps/pam-login
Latest version available: 4.0.14
Latest version installed: 3.17
Size of downloaded files: 3,653 kB
Homepage: http://shadow.pld.org.pl/
Description: Login, lastlog and faillog for PAM based systems
License: GPL-2

Searching... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..... ..
[ Results for search key : shadow ]
[ Applications found : 2 ]

* dev-perl/ShadowHash
Latest version available: 0.07
Latest version installed: [ Not Installed ]
Size of downloaded files: 9 kB
Homepage: http://www.cpan.org/modules/by-authors/id/R/RR/RRA/ShadowHash-0.07.readme
Description: Merge multiple data sources into a hash
License: || ( Artistic GPL-2 )

* sys-apps/shadow
Latest version available: 4.0.15-r2
Latest version installed: 4.0.7-r4
Size of downloaded files: 3,793 kB
Homepage: http://shadow.pld.org.pl/
Description: Utilities to deal with user accounts
License: BSD


What am I supposed to do? I feel ashamed :oops:


Thanks.
_________________
"Pure mathematics is on the whole distinctly more useful than applied.
For what is useful above all is technique, and mathematical technique
is taught mainly through pure mathematics.


Godfrey H. Hardy
Back to top
View user's profile Send private message
usurpah
n00b
n00b


Joined: 10 Dec 2003
Posts: 5

PostPosted: Wed May 31, 2006 8:34 pm    Post subject: Reply with quote

I thought to unmerge it was "emerge -C", not "emerge -c". Lowercase c is "clean", I believe.
Back to top
View user's profile Send private message
1clue
Veteran
Veteran


Joined: 05 Feb 2006
Posts: 1503

PostPosted: Wed May 31, 2006 8:38 pm    Post subject: Reply with quote

I ran into this too, but I'm a bit confused as to the best approach. I thought pam-login was preferable to shadow. The changelog documentation is a bit unclear. Anyone give an opinion on that, or a place to get a human-based description of which is supposed to take over?
Back to top
View user's profile Send private message
Proteus
Guru
Guru


Joined: 14 Jul 2002
Posts: 346
Location: Hamburg, Germany

PostPosted: Wed May 31, 2006 8:51 pm    Post subject: Reply with quote

Try to use
Code:
emerge unmerge pam-login

Then just emerge world and just to be in the safe side run revdep-rebuild.
Hope this helps.
_________________
Greetings,
Proteus
Back to top
View user's profile Send private message
The Ennead
Apprentice
Apprentice


Joined: 31 Jan 2003
Posts: 157
Location: Red Half Of Manchester, UK

PostPosted: Wed May 31, 2006 9:18 pm    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-443022.html


Scroll down to the first post by ecatmur.

That worked for me a couple of months ago and so I see no reason it shouldn't do this time as well but I won't be rebooting until tomorrow morning.



emerge --buildpkgonly --nodeps shadow && emerge -C pam-login && emerge --usepkgonly shadow


for anyone that can't click :P
Back to top
View user's profile Send private message
1clue
Veteran
Veteran


Joined: 05 Feb 2006
Posts: 1503

PostPosted: Wed May 31, 2006 9:44 pm    Post subject: Reply with quote

Ennead,

The critical text was in there, that I missed in the changelog: PAM is merging with shadow.

Thanks.
Back to top
View user's profile Send private message
dave-gallagher
n00b
n00b


Joined: 01 Mar 2006
Posts: 38

PostPosted: Thu Jun 01, 2006 1:22 am    Post subject: Reply with quote

Proteus wrote:
Try to use
Code:
emerge unmerge pam-login

Then just emerge world and just to be in the safe side run revdep-rebuild.
Hope this helps.


I did this on a spare machine and it killed my ability to su - root or sudo. I rebooted and authentication fails when I attempt to login with any account, so I'm completely locked out of my system. No, it's not your fault Proteus. I did it before reading your post, so unfortunately I can't blame you. ;)

I guess my next option will be to boot off of the Gentoo Live! CD, chown into my system, and re-emerge pam-login or convert to shadow.
Back to top
View user's profile Send private message
turtles
Veteran
Veteran


Joined: 31 Dec 2004
Posts: 1269

PostPosted: Thu Jun 01, 2006 2:18 am    Post subject: Reply with quote

I am contemplating updating world again (whch I do as little as possible because of issues like this) and have the same
Code:
 Calculating world dependencies ...done!
[blocks B     ] sys-apps/pam-login (is blocking sys-apps/shadow-4.0.15-r2)
as my only blocker for now, which is better than the 25 or so I had last time.
I need very specific tested clarification as to the correct non system breaking aproach here since the last post is a broken (spare) system.
cheers to all
_________________
Donate to Gentoo
Back to top
View user's profile Send private message
RazielFMX
l33t
l33t


Joined: 23 Apr 2005
Posts: 833
Location: NY, USA

PostPosted: Thu Jun 01, 2006 2:24 am    Post subject: Reply with quote

I have the same issue, which did not exist until I ran a emerge-websync --sync...

Code:

smbox ~ # emerge --newuse --update --deep --pretend world

These are the packages that I would merge, in order:

Calculating world dependencies ...done!
[blocks B     ] sys-apps/pam-login (is blocking sys-apps/shadow-4.0.15-r2)
[ebuild     U ] media-libs/tiff-3.8.2 [3.7.4]
[ebuild     U ] sys-apps/shadow-4.0.15-r2 [4.0.14-r1]
[ebuild     UD] app-text/poppler-0.5.1-r1 [0.5.2]
[ebuild   R   ] app-editors/gvim-6.4 
[ebuild   R   ] app-editors/xemacs-21.4.15-r3 
[ebuild   R   ] x11-misc/xlockmore-5.17-r1 
[ebuild     UD] app-text/poppler-bindings-0.5.1-r1 [0.5.2]

_________________
I am not anti-systemd; I am pro-choice. If being the latter makes you feel that I am the former, then so be it.
Back to top
View user's profile Send private message
mbeher
n00b
n00b


Joined: 01 Jun 2006
Posts: 1

PostPosted: Thu Jun 01, 2006 2:32 am    Post subject: Reply with quote

I'm getting the same error. I just synced portage, and tried to update world. Is portage broken?
Back to top
View user's profile Send private message
RazielFMX
l33t
l33t


Joined: 23 Apr 2005
Posts: 833
Location: NY, USA

PostPosted: Thu Jun 01, 2006 2:47 am    Post subject: Reply with quote

I just resynched to the most recent snapshot (websynch, behind a firewall and cant runt he usual synch) 20050531, and I still get the error...
_________________
I am not anti-systemd; I am pro-choice. If being the latter makes you feel that I am the former, then so be it.
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Thu Jun 01, 2006 4:18 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads.

See https://forums.gentoo.org/viewtopic-t-443022.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum