Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
XGL+Gnome upgrade problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
EvilAl
n00b
n00b


Joined: 25 May 2006
Posts: 3

PostPosted: Thu May 25, 2006 11:34 pm    Post subject: XGL+Gnome upgrade problem Reply with quote

ok, so iv just upgraded gnome and all, but the XGL plugin "decoration" seems to have broken as all of my window borders are now not being shown.
granted, with all the other fun plugins in compiz i dont actually NEED the borders/titlebars, but it would definatly be nice to get them back. so are any of you having the same problem as me or know how to fix this? -thanks


oh, and very sorry if theres another post about this already, did try searching for one
Back to top
View user's profile Send private message
darcon
n00b
n00b


Joined: 26 Jun 2004
Posts: 46

PostPosted: Mon May 29, 2006 1:26 am    Post subject: Reply with quote

If it dies just start it again by running gnome-window-decorator in a terminal or in gnome's run dialog by using alt-F2
Back to top
View user's profile Send private message
EvilAl
n00b
n00b


Joined: 25 May 2006
Posts: 3

PostPosted: Mon May 29, 2006 11:51 am    Post subject: Reply with quote

i tried that, but get an error stating (currently logged into windows but its something like this)

Error loading shared libraries: libexpat.so.0

apparently it couldnt find this -is there somethingwrong with my config -because this is the only app that generates this error
Back to top
View user's profile Send private message
neonknight
Guru
Guru


Joined: 19 Jul 2003
Posts: 357
Location: Zurich, Switzerland

PostPosted: Mon May 29, 2006 11:56 am    Post subject: Reply with quote

That file should be in
/usr/lib64/libexpat.so.0
and belongs to dev-libs/expat
Maybe you should run revdep-rebuild.
Back to top
View user's profile Send private message
sternklang
Veteran
Veteran


Joined: 10 Sep 2005
Posts: 1641
Location: Somewhere in time and space

PostPosted: Mon May 29, 2006 2:28 pm    Post subject: Reply with quote

If you updated to dev-libs/expat-2.0.0, there are a large number of packages that are now broken on your system. You have two choices, run revdep-rebuild as neonknight said or mask expat-2.0.0 and downgrade. There's a sticky thread on problems with the newer expat.

Personally, I've downgraded until I have a chance to rebuild the large number of packages involved.
Back to top
View user's profile Send private message
nixnut
Administrator
Administrator


Joined: 09 Apr 2004
Posts: 10973
Location: the dutch mountains

PostPosted: Mon May 29, 2006 5:31 pm    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads.
See above link
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum