Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ALSA] Pas de son dans les headphones :/
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
C3DScredi
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2006
Posts: 106

PostPosted: Sat May 13, 2006 7:54 am    Post subject: [ALSA] Pas de son dans les headphones :/ Reply with quote

Bonjour à tous !
Voila j'ai terminé d'installer ma carte son mais à présent le son fonctionne bien mise à part la sortie jack pour les écouteurs ... En effet je n'entends aucun son dans les ecouteurs. J'ai cherché mais je ne vois pas pourquoi j'ai emergé alsa-jack en me disant que peut etre ca arrangerait le probleme mais non :?
Aussi comment avoir le daemon du mixeur alsa ?
Quelqu'un à une tite idée ?
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8106
Location: ~Brussels - Belgique

PostPosted: Sat May 13, 2006 7:59 am    Post subject: Reply with quote

Salut,

as-tu suivi le Guide ALSA pour Gentoo Linux ? c'est dans la section "vérifier le volume": lance alsamixer et vérifie que le volume "master" et "PCM" sont "unmuted" et à un volume décent ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
C3DScredi
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2006
Posts: 106

PostPosted: Sat May 13, 2006 8:21 am    Post subject: Reply with quote

Oui oui j'ai fais tout ca mais le son fonctiona par les speakers mais quand je branche les ecouteurs y a pas de son
Mais j'ai trouver la solution sur le forum english, je ne pense jamais a chercher par la mais maintenant je le ferai tout le temps :)
Seul petit probleme, quelques soucis de comprehension ...
Code:
Sound works with with module snd_hda_intel. But to get the headphone-jack working you have to hand over a module parameter for example using 'modconf'. I use two parameters:

model=z71v position_fix=1


Source : https://forums.gentoo.org/viewtopic-t-420937-highlight-headphones.html

C'est ou que je dois rejouter cette ligne ?

Edit : ah oui pour le mixer j'ai emergé kmixer c'est OK :)
Back to top
View user's profile Send private message
Jellyffs
Apprentice
Apprentice


Joined: 24 Mar 2006
Posts: 190
Location: France

PostPosted: Sat May 13, 2006 11:50 am    Post subject: Reply with quote

Salut,

Tu rajoutes ceci:

Quote:
options snd-hda-intel model=z71v position_fix=1


Ici (a créer s'il n'existe pas):

Quote:
/etc/modprobe.d/snd-hda-intel



J'ai rien capté au soucis mais c'est ce qu'ils disent :)

Bon courage.

Alex
Back to top
View user's profile Send private message
kaworu
Guru
Guru


Joined: 07 Dec 2005
Posts: 450

PostPosted: Sat May 13, 2006 1:18 pm    Post subject: Reply with quote

Salut !
peux tu donner la version de ton kernel et ta carte son stp?
Code:

# uname -r
# lspci | grep "Audio"

_________________
Macbook
Core2Duo @ 2.0GHz - 1Go RAM - HD 80Go - Intel GMA 945

Gentoo GNU/Linux
~amd64 - 2.6.24-gentoo-r2 - Fluxbox || (KDE && Compiz-Fusion)
Back to top
View user's profile Send private message
C3DScredi
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2006
Posts: 106

PostPosted: Sat May 13, 2006 1:42 pm    Post subject: Reply with quote

kernel : 2.6.16-gentoo-r6
Carte son : 00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)

Mais j'ai pas de dossier /etc/modprobe.d/ ... Je le créé aussi ?
Back to top
View user's profile Send private message
C3DScredi
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2006
Posts: 106

PostPosted: Sun May 14, 2006 8:41 am    Post subject: Reply with quote

Up :oops:
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Sun May 14, 2006 10:03 am    Post subject: Reply with quote

bon, arrête les UPs comme ça s'il-te-plait !

sinon c'etait une erreur le modprobe.d, c'est modules.d !
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
C3DScredi
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2006
Posts: 106

PostPosted: Sun May 21, 2006 9:23 am    Post subject: Reply with quote

Oui j'arrette :)

Mais non le fichier n'y etais pas je l'ai créé mais toujours pas de son dans les ecouteurs :(
Back to top
View user's profile Send private message
kaworu
Guru
Guru


Joined: 07 Dec 2005
Posts: 450

PostPosted: Sun May 21, 2006 11:28 am    Post subject: Reply with quote

Salut !
Code:

# lspci
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
# uname -r
2.6.15-gentoo-r7


Avec ce kernel j'ai du patcher mon kernel, car le problème était que lorsque je plug les headphones, le son des speackers ne s'éteignait pas ! ( voir ici pour le patch )
pour les kernels 2.6.16 j'ai plus eu de son du tout ( même si le soft le croyais et me disait que tout va bien ) jusqu'aux kernels >=2.6.16-r6 ou le son marche , et pas besoin de patcher pour les headphones (mais maintenant, j'ai un problème pour hiberner :/ ).
Voila je sais pas si ça t'a aidé, dis nous le modèle de ton laptop et regarde par exemple sur "linux on laptop" y'a surement qqn qui a le même problème que toi ^____^
_________________
Macbook
Core2Duo @ 2.0GHz - 1Go RAM - HD 80Go - Intel GMA 945

Gentoo GNU/Linux
~amd64 - 2.6.24-gentoo-r2 - Fluxbox || (KDE && Compiz-Fusion)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum