Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with php4 blocking php5 and php5 blocking php4
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
flipper203
n00b
n00b


Joined: 07 Aug 2005
Posts: 32
Location: Paris

PostPosted: Wed May 17, 2006 10:04 am    Post subject: Problem with php4 blocking php5 and php5 blocking php4 Reply with quote

Hello, I m stuck in a weird situation, I have apache, php and sql installed. When I want to install snort and some other progams, I get this :

emerge -p net-libs/libnet net-analyzer/snort net-analyzer/acid net-analyzer/oinkmaster

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B ] dev-php/mod_php (is blocking dev-lang/php-5.1.4)
[blocks B ] dev-php/php (is blocking dev-lang/php-5.1.4)
[blocks B ] dev-php/mod_php (is blocking dev-lang/php-4.4.2-r2)
[blocks B ] dev-php/php (is blocking dev-lang/php-4.4.2-r2)
[ebuild N ] net-libs/libnet-1.1.2.1-r1
[ebuild N ] net-libs/libpcap-0.9.4
[ebuild N ] dev-libs/libpcre-6.3
[ebuild N ] net-analyzer/snort-2.4.3-r1
[ebuild N ] media-libs/gd-2.0.33
[ebuild N ] dev-lang/php-5.1.4
[ebuild N ] dev-php/adodb-4.72
[ebuild N ] app-arch/cabextract-1.1
[ebuild N ] media-fonts/corefonts-1-r2
[ebuild N ] dev-lang/php-4.4.2-r2
[ebuild N ] dev-php4/jpgraph-1.20.2
[ebuild N ] net-analyzer/acid-0.9.6_beta23-r1
[ebuild N ] net-analyzer/oinkmaster-1.2

How can I fix this (The version of ph installed on my computer is 4.4.0-pl1-gentoo)
Back to top
View user's profile Send private message
bkunlimited
l33t
l33t


Joined: 18 Jun 2004
Posts: 672

PostPosted: Wed May 17, 2006 10:09 am    Post subject: Reply with quote

i had the same problem, reading this http://www.gentoo.org/proj/en/php/php-upgrading.xml helped me out.
Back to top
View user's profile Send private message
flipper203
n00b
n00b


Joined: 07 Aug 2005
Posts: 32
Location: Paris

PostPosted: Wed May 17, 2006 11:54 am    Post subject: Reply with quote

yes but I already have php installed an working, is there a way to avoid gentoo from installing php-5, i only need php4, as it is now on my server.
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Wed May 17, 2006 12:08 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, please see this topic: Upgrading PHP on Gentoo.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum