Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Acentuação e Cedilha] Vamos achar um solução final!
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
viniciusferrao
Tux's lil' helper
Tux's lil' helper


Joined: 28 Aug 2005
Posts: 83

PostPosted: Mon May 15, 2006 6:33 am    Post subject: [Acentuação e Cedilha] Vamos achar um solução final! Reply with quote

Seguinte pessoal, acho q isso não é apenas um problema meu, mas de todos... infelizmente o Linux eh chato pra caral** com acetuação e cedilha... até hoje nao consegui configurar essa porcaria direito!

Enfim, aqui o caso é estranho, aqui no Firefox ta tudo bonitinho né? Cedilha aparecendo e os acentos, nao sei como isso ta assim, mas fazer oq né?

Agora no KDE em geral, eh impossivel o Ç só sai o ridiculo do C com acento: ć (copiei e colei de um konsole), fora q sai varios caracteres lixos como śŕýń e etc.

No console sem X server nem nada, nem acentos saem nem nada...

Enfim, alguem saberia explicar como configurar isso?
[]'s
Back to top
View user's profile Send private message
xef
Guru
Guru


Joined: 20 Jun 2003
Posts: 460
Location: Porto - Portugal

PostPosted: Mon May 15, 2006 9:08 am    Post subject: Reply with quote

Configurar o teclado correcto no X e no kontrol center do kde? (ou la como se chama a ferramenta)
Back to top
View user's profile Send private message
viniciusferrao
Tux's lil' helper
Tux's lil' helper


Joined: 28 Aug 2005
Posts: 83

PostPosted: Mon May 15, 2006 10:13 pm    Post subject: Reply with quote

xef wrote:
Configurar o teclado correcto no X e no kontrol center do kde? (ou la como se chama a ferramenta)


Não funciona.

E mesmo que funcionasse ainda tem o problema do console... alguma outra idéia?
Back to top
View user's profile Send private message
viniciusferrao
Tux's lil' helper
Tux's lil' helper


Joined: 28 Aug 2005
Posts: 83

PostPosted: Tue May 16, 2006 5:27 am    Post subject: Reply with quote

Pessoal ta sinistro isso aqui!

Meu /etc/env.d/02locale

Code:
phobos viniciusferrao # cat /etc/env.d/02locale
LANG=pt_BR.utf8
LC_CTYPE="pt_BR.utf8"
LC_NUMERIC="pt_BR.utf8"
LC_TIME="pt_BR.utf8"
LC_COLLATE="pt_BR.utf8"
LC_MONETARY="pt_BR.utf8"
LC_MESSAGES="en_US.utf8"
LC_PAPER="pt_BR.utf8"
LC_NAME="pt_BR.utf8"
LC_ADDRESS="pt_BR.utf8"
LC_TELEPHONE="pt_BR.utf8"
LC_MEASUREMENT="pt_BR.utf8"
LC_IDENTIFICATION="pt_BR.utf8"


Desta forma as aplicações GTK (como o Firefox e o OpenOffice), funcionam quase perfeitamente com todos os acentos e o cedilha... (quase perfeito pois ainda existem caracteres garbage como ñ ý, q nao sao usados)
Ja as aplicações do QT (o KDE todo), fica com a porcaria dos C com acentos e afins!

Agora mudando a flag LC_CTYPE para:
Code:
LC_CTYPE="POSIX"


Acontece exatamente o oposto, o KDE inteiro fica ok, mas o FF e OO morrem, dando C com acentos, e coisas loucas!

Alguma idéia?

[]'s
Back to top
View user's profile Send private message
RoadRunner
Bodhisattva
Bodhisattva


Joined: 12 Jun 2002
Posts: 490
Location: Coimbra, Portugal

PostPosted: Tue May 16, 2006 10:04 am    Post subject: Reply with quote

Já tentaste isto: https://forums.gentoo.org/viewtopic-t-3116-highlight-.html ?
Back to top
View user's profile Send private message
tuxuserBR
n00b
n00b


Joined: 16 May 2006
Posts: 23

PostPosted: Tue May 16, 2006 8:54 pm    Post subject: Reply with quote

Fiz o que o colega sugeriu e não funcionou. Meu problema é quanto ao open office ele salva documentos com cedilha e acentos colocando %[alguma coisa] no nome, veja um exemplo:
Teste %E7 %E9 = Teste ç é

Não estou entendendo 8O
Back to top
View user's profile Send private message
viniciusferrao
Tux's lil' helper
Tux's lil' helper


Joined: 28 Aug 2005
Posts: 83

PostPosted: Wed May 17, 2006 3:14 am    Post subject: Reply with quote

RoadRunner wrote:
Já tentaste isto: https://forums.gentoo.org/viewtopic-t-3116-highlight-.html ?


Nada adiantou...

Mas tive uma ideia aki, recompilei o GLIBC com ISO 8859-1 em vez de só UTF-8, e milagrosamente funciona tudo direito agora... ainda tem caracteres bizarros como ý e ñ mas que se dane.

Agora o q nao da pra entender, eh problema com o Unicode isso? Pq disso?

E o console tb nao funciona, ele tá em UTF-8, vo tentar botar em ISO 8859-1 pra ver c consigo cedilha e acentos lá!
Back to top
View user's profile Send private message
oandarilho01
Tux's lil' helper
Tux's lil' helper


Joined: 17 Nov 2005
Posts: 132
Location: Rio de Janeiro/RJ - Brasil

PostPosted: Tue May 23, 2006 7:13 pm    Post subject: Reply with quote

viniciusferrao wrote:
...

Mas tive uma ideia aki, recompilei o GLIBC com ISO 8859-1 em vez de só UTF-8, e milagrosamente funciona tudo direito agora... ainda tem caracteres bizarros como ý e ñ mas que se dane.

E o console tb nao funciona, ele tá em UTF-8, vo tentar botar em ISO 8859-1 pra ver c consigo cedilha e acentos lá!


Pergunta de iniciante: como eu faria esses passos que você descreveu acima?
Back to top
View user's profile Send private message
leosgb
Apprentice
Apprentice


Joined: 07 Mar 2006
Posts: 272
Location: Rio de Janeiro, Brazil

PostPosted: Wed May 09, 2007 5:03 am    Post subject: Reply with quote

Pois é, esse pulo do gato que tá faltando. Eu também tou tentando descobrir.

Olha o meu cedilha:

ć

valeu!
Back to top
View user's profile Send private message
Fellype
n00b
n00b


Joined: 08 Nov 2006
Posts: 9
Location: Campinas-SP/Brasil

PostPosted: Sun May 13, 2007 3:04 am    Post subject: Reply with quote

Eu tive este problema em um pc com Slackware e resolvi, definitivamente, com a dica dada no link:

http://www.vivaolinux.com.br/dicas/verDica.php?codigo=2595

Reproduzindo (para o caso de o link acima sair da rede...):

1. Abra o seu /etc/gtk-2.0/gtk.immodules;
2. Procure pela linha que contenha "im-cedilla.so";
3. Na linha seguinte, adicione "en" onde você vê os "locales az:fr:co", etc;
4. Salve e feche;
5. Reinicie seu X;
6. Pronto!

É provável que isto funcione também no Gentoo.

Um abraço.
_________________
Beleza é fundamental... Mas não é tudo.

Tem que ser gostosa também...
Back to top
View user's profile Send private message
leosgb
Apprentice
Apprentice


Joined: 07 Mar 2006
Posts: 272
Location: Rio de Janeiro, Brazil

PostPosted: Sun May 13, 2007 5:56 am    Post subject: Reply with quote

Aí muito obrigado! Funcionou no firefox agora! Vou ter que anotar isso porque como o:

/etc/gtk-2.0/x86_64-pc-linux-gnu/gtk.immodules

é gerado automaticamente:

Code:

# GTK+ Input Method Modules file
# Automatically generated file, do not edit
# Created by gtk-query-immodules-2.0 from gtk+-2.10.9


Então eu possivelmente vou ter que ajeitar isso todas as vezes que eu atualizar o meu sistema. Ou então pelo menos prestar atenção nos milhões de arquivos que são atualizados para garantir que nada foi modificado.

Mais uma vez muitíssimo obrigado. E lá vão alguns ç para você:

ççççççççççççççççççççççç

Fui!
Back to top
View user's profile Send private message
gotaserena
Apprentice
Apprentice


Joined: 23 Feb 2005
Posts: 153
Location: fourth worst city in the world

PostPosted: Sat May 19, 2007 8:44 am    Post subject: Reply with quote

Curioso, comigo o guia de localização funcionou sem problemas, inclusive para o console, e em 4 máquinas. Só tive de adicionar 'Option "XkbVariant" "intl"' no xorg.conf nos teclados us que eu tenho.

Nesses teclados o padrão de '+c=ć, realmente. Para digitar o c com cedilha, tenho que usar RightAlt+, ou RightAlt+,+c. Questão de costume.
Back to top
View user's profile Send private message
Fellype
n00b
n00b


Joined: 08 Nov 2006
Posts: 9
Location: Campinas-SP/Brasil

PostPosted: Sat May 19, 2007 10:04 pm    Post subject: Reply with quote

gotaserena wrote:
Só tive de adicionar 'Option "XkbVariant" "intl"' no xorg.conf nos teclados us que eu tenho...


Geralmente isso é suficiente para resolver o problema de acentuação e cedilha em Linux. Porém, nem sempre as coisas saem tão bem quanto a gente gostaria. Ex: funciona corretamente em aplicativos baseados em Qt mas não nos baseados em Gtk, ou vice-versa (de quem será a culpa????). Aí é que entram as diversas soluções mostradas nas respostas anteriores, que podem ou não resolver definitivamente o problema. Sem falar que a configuração do teclado no terminal nem sempre é a mesma do X, pois são arquivos de configuração diferentes (aliás, isso não ocorre apenas no Linux).
Eu acredito que exista uma solução única e definitiva que abranja a grande maioria dos casos, pois muitas vezes, e em muitas distribuições, essas coisas não acontecem. Se, por acaso, alguém conhece, ou vier a conhecer, tal solução, por favor divulgue-a exaustivamente para que o acesso à mesma seja facilitado.

Até mais.
_________________
Beleza é fundamental... Mas não é tudo.

Tem que ser gostosa também...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum