Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Thunderbird 1.5.0.2-r1 ebuild fail
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
dbeer
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2004
Posts: 82

PostPosted: Sun May 14, 2006 10:56 pm    Post subject: Thunderbird 1.5.0.2-r1 ebuild fail Reply with quote

Hi All,

Sorry if this has been answered somewhere elese, but I was unable to find a solution.

The error message is a follows
Code:
nsModule.cpp:45:27: nsCharsetMenu.h: No such file or directory
nsModule.cpp:46:34: nsFontPackageHandler.h: No such file or directory
nsModule.cpp: In function `nsresult nsFontPackageHandlerConstructor(nsISupports*, const nsIID&, void**)':
nsModule.cpp:68: error: `nsFontPackageHandler' was not declared in this scope
nsModule.cpp:68: error: `inst' was not declared in this scope
nsModule.cpp:68: error: `nsFontPackageHandler' is not a type
nsModule.cpp: At global scope:
nsModule.cpp:112: error: `NS_CHARSETMENU_CID' was not declared in this scope
nsModule.cpp:113: error: expected `}' before "NS_CHARSETMENU_PID"
nsModule.cpp:113: error: expected `}' before "NS_CHARSETMENU_PID"
nsModule.cpp:113: error: invalid conversion from `const char*' to `PRUint16'
nsModule.cpp:113: error: expected `,' or `;' before "NS_CHARSETMENU_PID"
nsModule.cpp:114: error: expected declaration before '}' token
gmake[4]: *** [nsModule.o] Error 1
gmake[4]: Leaving directory `/tmp/portage/mozilla-thunderbird-1.5.0.2-r1/work/mozilla/xpfe/components/build2'
gmake[3]: *** [libs] Error 2
gmake[3]: Leaving directory `/tmp/portage/mozilla-thunderbird-1.5.0.2-r1/work/mozilla/xpfe/components'
gmake[2]: *** [libs] Error 2
gmake[2]: Leaving directory `/tmp/portage/mozilla-thunderbird-1.5.0.2-r1/work/mozilla/xpfe'
gmake[1]: *** [tier_50] Error 2
gmake[1]: Leaving directory `/tmp/portage/mozilla-thunderbird-1.5.0.2-r1/work/mozilla'
make: *** [default] Error 2

!!! ERROR: mail-client/mozilla-thunderbird-1.5.0.2-r1 failed.
!!! Function src_compile, Line 117, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.


Any advice would be great. I am running a AMD 64.

David
Back to top
View user's profile Send private message
didymos
Advocate
Advocate


Joined: 10 Oct 2005
Posts: 4798
Location: California

PostPosted: Mon May 15, 2006 12:09 am    Post subject: Reply with quote

Someone's filed a bug on this, but it doesn't look like there's a solution yet:
Bugzilla Bug 131727

I'd suggest having Bugzilla send you mail when the bug is updated, but that's kind of a catch-22. I'd just install the 32-bit binary. You can always build 64-bit later when a bugfix is in.
_________________
Thomas S. Howard
Back to top
View user's profile Send private message
dbeer
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2004
Posts: 82

PostPosted: Mon May 15, 2006 10:39 am    Post subject: Reply with quote

Hi

Thanks for the reply will keep people posted on any outcome.

Thanks
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4830
Location: Gothenburg, Sweden

PostPosted: Sat Aug 19, 2006 3:24 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of topic 468699.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum