Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ksplash-engine-moodin-0.4.2 not respecting -arts
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
lenk
Apprentice
Apprentice


Joined: 08 Mar 2004
Posts: 211

PostPosted: Mon Feb 20, 2006 1:38 am    Post subject: ksplash-engine-moodin-0.4.2 not respecting -arts Reply with quote

[ebuild N ] kde-misc/ksplash-engine-moodin-0.4.2 USE="-arts -debug -xinerama" 0 kB [1]

Code:

checking for mcopidl... not found
configure: error: The important program mcopidl was not found!
Please check whether you installed aRts correctly or use
--without-arts to compile without aRts support (this will remove functionality).

!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/ksplash-engine-moodin-0.4.2/work/moodin/config.log

!!! ERROR: kde-misc/ksplash-engine-moodin-0.4.2 failed.
Call stack:
  ebuild.sh, line 1894:   Called dyn_compile
  ebuild.sh, line 941:   Called src_compile
  ksplash-engine-moodin-0.4.2.ebuild, line 26:   Called econf 'compile'

!!! econf failed
!!! If you need support, post the topmost build error, and the call stack if relevant.



Does anyone know how to tweak this ebuild to make it respect -arts? Thanks


Code:

# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

inherit kde

#MY_P=ksplash-engine-moodin${P/moodinKDE-/_}
MY_P=${P/moodin-0/moodin_0}
S=${WORKDIR}/moodin

DESCRIPTION="Splash Screen Engine for KDE - Heavily customizable engine for various types of themes"
HOMEPAGE="http://www.kde-look.org/content/show.php?content=25705"
SRC_URI="http://moodwrod.com/files/${MY_P}.tar.gz"

SLOT="0"
LICENSE="GPL-2"
#KEYWORDS="~amd64 ~x86"
KEYWORDS="amd64 x86"
IUSE=""

RESTRICT="nomirror $RESTRICT"

need-kde 3.4

src_compile() {
        econf --prefix=${KDEDIR} || die
        emake || die
}

_________________
E6300 Gigabyte GA-965P-DS3 2GB Corsair 320GB Seagate 7200.10 XFX 7600GT Gentoo
Dell M1330 T7500 2GB 160GB 13.3" WXGA Gentoo
Sharp Zaurus SL-C760 Cacko ROM 1.21b / pdaXrom 1.10rc5 512MB CF + 512MB SD
Sun Ultra5 Gentoo
Back to top
View user's profile Send private message
l'otis
n00b
n00b


Joined: 24 Aug 2004
Posts: 13

PostPosted: Thu May 18, 2006 10:33 am    Post subject: Reply with quote

Hi,

although this post is a rather old one I'll still reply. I had the same problem so I thought I just give this a shot:
Change
Code:
econf --prefix=${KDEDIR} || die

to
Code:
econf --prefix=${KDEDIR} --without-arts || die

and it worked. Now I have no idea if this is the correct way of doing it but hey it works ;)

Cheers
Otis
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum