Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Trick: How-to Flash Sound KDE 3.4 and Firefox-1.5
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
FastTurtle
Guru
Guru


Joined: 03 Sep 2002
Posts: 386
Location: Shake & Bake

PostPosted: Sat May 06, 2006 5:56 pm    Post subject: Trick: How-to Flash Sound KDE 3.4 and Firefox-1.5 Reply with quote

This is a very easy fix for sound in flash with KDE 3.4 and firefox 1.5 and may also work for 1.0.8 . 8)

Simple edit the icon and add -artsd to the command line. Start firefox and visit a flash site/game/what ever where you want sound. Should work immediately although you may also have to restart kde to get it fully operational.

Note that once sound works in flash once again, simply remove the extra command from the startup link and it will continue working correctly. :lol:
_________________
AMD 640 - 16GB - Radeon 5670
Back to top
View user's profile Send private message
seatec
n00b
n00b


Joined: 05 Jul 2003
Posts: 50
Location: Munich.de

PostPosted: Sun May 07, 2006 4:57 pm    Post subject: Reply with quote

Err, what icon? My firefox is 1.0.8, Kde is 3.4.3. I don't see any sort of icon that links to flash, neither in Firefox nor Kde. The video part works fine for me, but sound obviously doesn't.
Maybe you can provide the command string associated with this icon so I can maybe manually run flash with that option? Thx in advance!
Back to top
View user's profile Send private message
Phenax
l33t
l33t


Joined: 10 Mar 2006
Posts: 972

PostPosted: Sun May 07, 2006 5:35 pm    Post subject: Reply with quote

firefox -artsd
^ In terminal.
Anyways, this is only for people who are using artsd (KDE) or whatnot and don't have hardware mixing in their sound card.
Back to top
View user's profile Send private message
sasq
Apprentice
Apprentice


Joined: 09 Sep 2005
Posts: 181
Location: Poland

PostPosted: Sun May 07, 2006 6:12 pm    Post subject: Reply with quote

And what if somenone hasn't Arts? I have only ALSA kernel driver and software audio mixing works for other apps. Only in several flash movies there isn't any sound :/
_________________
SasQ
Back to top
View user's profile Send private message
FastTurtle
Guru
Guru


Joined: 03 Sep 2002
Posts: 386
Location: Shake & Bake

PostPosted: Wed May 10, 2006 7:23 pm    Post subject: Reply with quote

seatec: the icon I'm referring to is the firefox icon. rt clk and edit the properties by adding the -artsd to the tail of the command on the application tab.

sasq: As the thread title states: This is in regards to getting sound working for flash with Firefox 1.5 and kde 3.4. Don't know how to get it working for anyone else
_________________
AMD 640 - 16GB - Radeon 5670
Back to top
View user's profile Send private message
sasq
Apprentice
Apprentice


Joined: 09 Sep 2005
Posts: 181
Location: Poland

PostPosted: Thu May 11, 2006 12:50 am    Post subject: Reply with quote

I have some parts of KDE 3.4 but my main WM is Fluxbox. I have also Firefox, but I use also Opera. I wrote that I use plain ALSA, because I don't use Arts for my KDE apps. So why I couldn't to ask in that topic?
_________________
SasQ
Back to top
View user's profile Send private message
01mf02
Veteran
Veteran


Joined: 21 Nov 2004
Posts: 1070
Location: Innsbruck, Austria

PostPosted: Thu May 11, 2006 8:51 am    Post subject: Reply with quote

Quote:

And what if somenone hasn't Arts?


Code:
aoss firefox

Code:
aoss32 firefox-bin
Back to top
View user's profile Send private message
seatec
n00b
n00b


Joined: 05 Jul 2003
Posts: 50
Location: Munich.de

PostPosted: Fri May 26, 2006 3:54 pm    Post subject: Reply with quote

firefox -artsd doesn't change a thing for me. Having to boot windows to show ppl a flash movie cause my linux can't handle it is quite embarassing btw :>
I'm running arts, I do have sound all over in linux/kde, I don't have sound muted for flash, nor is the volume set to 0. Any ideas guys and girls?
Back to top
View user's profile Send private message
bunder
Bodhisattva
Bodhisattva


Joined: 10 Apr 2004
Posts: 5213

PostPosted: Fri May 26, 2006 3:56 pm    Post subject: Reply with quote

use `artsdsp firefox` instead... works for me. i'm not sure if mmap is needed (-m flag)
_________________
goodbye fgo. it was nice knowing you.
Back to top
View user's profile Send private message
seatec
n00b
n00b


Joined: 05 Jul 2003
Posts: 50
Location: Munich.de

PostPosted: Mon May 29, 2006 10:42 am    Post subject: Reply with quote

Woot! Works! Finally! Thank you very much. That was annoying me for months already.
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2073
Location: ロヂで

PostPosted: Mon Nov 06, 2006 10:27 pm    Post subject: Reply with quote

I was get used to use
Code:
aoss32 firefox

but sometimes sound (I'm on amd64 and I'm using firefox-bin) stops and I must restart alsasound (causing firefox to get closed).
Do you thinks that with
Code:
firefox -artsd

this problem desappears?

By the way.... thank you very much, your how-to works very well!
At the moment. :P
Back to top
View user's profile Send private message
Deathwing00
Moderator
Moderator


Joined: 13 Jun 2003
Posts: 4078
Location: Barcelona, Spain

PostPosted: Tue Nov 07, 2006 1:48 pm    Post subject: Reply with quote

Moved from Multimedia to Documentation, Tips & Tricks.
Back to top
View user's profile Send private message
irondog
l33t
l33t


Joined: 07 Jul 2003
Posts: 715
Location: Voor mijn TV. Achter mijn pc.

PostPosted: Tue Nov 07, 2006 2:48 pm    Post subject: Reply with quote

You can use Flash 9 now. This version has ALSA support built-in.
_________________
Alle dingen moeten onzin zijn.
Back to top
View user's profile Send private message
anxt
Apprentice
Apprentice


Joined: 25 Feb 2003
Posts: 251
Location: Frozen Tundra, Canada

PostPosted: Sat Jan 06, 2007 5:12 am    Post subject: Reply with quote

i am trying to get firefox or mozilla to use jack via artsd. i cannot use artsdsp as the firefox is just a launch wrapper and artsdsp only uses binary files.

that said firefox -artsd yeilds no sound

i continue on the quest. i freally want a jackified browser
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum