Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[HOWTO] wakeonlan
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
RayVad
n00b
n00b


Joined: 10 Nov 2005
Posts: 67
Location: Netherlands

PostPosted: Fri Jan 05, 2007 12:53 pm    Post subject: Reply with quote

Dun,

What more should there be configured in /etc/conf.d/rc for the NIC except RC_DOWN_INTERFACE="yes" ?
There was no RC_DOWN_INTERFACE= in the rc file here, so i added it.

Will try WOL later.
Back to top
View user's profile Send private message
anigel
Bodhisattva
Bodhisattva


Joined: 14 Apr 2003
Posts: 1889
Location: Un petit bled pas loin de Limoges ;-)

PostPosted: Fri Jan 05, 2007 2:06 pm    Post subject: Reply with quote

Dun wrote:
Wake On Lan works out of the box without any change in /etc/conf.d/rc file.

Moreover if I set RC_DOWN_INTERFACE to no WakeOnLan doesnt work anymore. Dont know why :)

Lucky ! But I don't know why. I can only try to guess...

This must probably be related to your cards "hard defaults". I remember that on some 3COM PCI cards, a little utility allowed the user to set "hardware behaviour" against WOL : after that, the card WOL-bit was set at every boot-time, during the card initialisation. Maybe your BIOS / hardware revision works like this ?
_________________
Il y a 10 sortes d'individus en ce bas-monde : ceux qui causent binaire, et les autres.
Back to top
View user's profile Send private message
Yukimura
Apprentice
Apprentice


Joined: 25 Aug 2006
Posts: 161
Location: Slovenia

PostPosted: Sat Jan 06, 2007 1:53 pm    Post subject: Reply with quote

I'm also using forcedeth but I can't even get my PC to wake up.
Maybe I'm doing something wrong but I can't see my mistake.

My ethtool eth0 gives me this:

Quote:
Settings for eth0:
Supported ports: [ MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: MII
PHYAD: 1
Transceiver: external
Auto-negotiation: on
Supports Wake-on: g
Wake-on: g
Link detected: yes


Also I have set RC_DOWN_INTERFACE to no.

What more should I do?

Kind regards
Back to top
View user's profile Send private message
anigel
Bodhisattva
Bodhisattva


Joined: 14 Apr 2003
Posts: 1889
Location: Un petit bled pas loin de Limoges ;-)

PostPosted: Sat Jan 06, 2007 10:39 pm    Post subject: Reply with quote

Wel... Maybe this post can help you ?

If not, I just don't have any idea, sorry.
_________________
Il y a 10 sortes d'individus en ce bas-monde : ceux qui causent binaire, et les autres.
Back to top
View user's profile Send private message
Yukimura
Apprentice
Apprentice


Joined: 25 Aug 2006
Posts: 161
Location: Slovenia

PostPosted: Sun Jan 07, 2007 12:14 am    Post subject: Reply with quote

It seems the problem was in wakeonlan utility. I installed etherwake on my linux router and now it works.

BTW really good how to (simple, and quick to do) ;)

Kind regards. :)
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2397

PostPosted: Thu Feb 15, 2007 6:48 pm    Post subject: Reply with quote

i noticed that there is a little tripwire in the WOL thing.
even if the two machines are on the same subnet it can be mandatory to specify the -i option of wakeonlan.
i believe this is the case when the box which is sending the magic packet has multiple network connections, which is the case on my gentoo internet gateway.
in my case
Code:
wakeonlan -i 192.168.0.255 -f xeon_mac
did the trick.
Back to top
View user's profile Send private message
Devport
Guru
Guru


Joined: 15 Dec 2004
Posts: 361

PostPosted: Mon Apr 16, 2007 12:15 am    Post subject: Reply with quote

Is there a way to detect if the system has been started threw wakeonlan ? I only want to start ssh on wakeonlan.
Back to top
View user's profile Send private message
Yukimura
Apprentice
Apprentice


Joined: 25 Aug 2006
Posts: 161
Location: Slovenia

PostPosted: Mon Apr 16, 2007 5:52 am    Post subject: Reply with quote

To check that out, I connect on my machine through ssh. :)
Back to top
View user's profile Send private message
RayVad
n00b
n00b


Joined: 10 Nov 2005
Posts: 67
Location: Netherlands

PostPosted: Fri May 18, 2007 10:37 pm    Post subject: Reply with quote

OK, got it solved!

I used another NIC again(with WOL cable), not the onboard one, to receive the wol packed (yes, got 2 NIC's because its a VPN server) and only APM, not ACPI!
Well, these are my configs:

Did NOT compile ACPI into kernel 2.6.20-r8, only enabled APM, nothing more!

[*] Power Management support │ │
│ │ [ ] Legacy Power Management API (DEPRECATED) │ │
│ │ [ ] Power Management Debug Support │ │
│ │ [ ] Driver model /sys/devices/.../power/state files (DEPRECATED│ │
│ │ [ ] Software Suspend │ │
│ │ ACPI (Advanced Configuration and Power Interface) Support --│ │
│ │ APM (Advanced Power Management) BIOS Support ---> │ │
│ │ CPU Frequency scaling ---> │ │
│ │

[ ] ACPI Support

<*> APM (Advanced Power Management) BIOS support │ │
│ │ [ ] Ignore USER SUSPEND │ │
│ │ [ ] Enable PM at boot time │ │
│ │ [ ] Make CPU Idle calls when idle │ │
│ │ [ ] Enable console blanking using APM │ │
│ │ [ ] RTC stores time in GMT │ │
│ │ [ ] Allow interrupts during APM BIOS calls │ │
│ │ [ ] Use real mode APM BIOS call to power off


Compiled the drivers of the NIC as module in the kernel.

/etc/conf.d/rc: RC_DOWN_INTERFACE="yes"
/etc/init.d/shutdown.sh: Just default!

Installed ethtool to set the WOL parameter on g

Added "ethtool -s eth0 wol g" to /etc/conf.d/local.start and, to be sure, to /etc/conf.d/local.stop

And Voila! it works!!!

Okay, some new issue.... to be fixed later... it starts spontanious now as it happens 3 times. Strange...but WOL works and will find out about this spontanious boot later and report here.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum