Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problem about "emerge -e system"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
zhuyan
n00b
n00b


Joined: 30 Mar 2006
Posts: 48

PostPosted: Thu May 04, 2006 7:06 pm    Post subject: problem about "emerge -e system" Reply with quote

I am a newer...

I reinstalled my gentoo this time (only /home wasn't removed). But I used the old "make.conf" this time...There is a problem when I "emerge -e system". It seems to be an endless process. I mean this process repeat again and again... I think the problem may be that I set some incorrect parameters in flag "USE". Here is my make.conf

Code:

# These settings were set by the catalyst build script that automatically built this stage
# Please consult /etc/make.conf.example for a more detailed example
CFLAGS="-march=pentium4 -O3 -pipe"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
USE="unicode doc sdk nptl nptlonly gdm zh_CN hal howl X acpi alsa bcmath bzip2 cdr cjk cups dri dvd emacs encode fftw ftp gnome gtk gtk2 ipv6 libg++ mp3 mpeg msn nls nptl ogg opengl openal oss pdf perl python qt samba socket spell xml vcd usb win32codecs wmf xine xml2 xmms jabber jpeg jepg2k -kde"
MAKEOPTS="-j3"
ALSA_CARDS="hda-intel"
VIDEO_CARDS="radeon"
#ACCEPT_KEYWORDS="~x86"
#PORTDIR_OVERLAY="/usr/local/chinese-beautify-overlay"
Back to top
View user's profile Send private message
sternklang
Veteran
Veteran


Joined: 10 Sep 2005
Posts: 1641
Location: Somewhere in time and space

PostPosted: Thu May 04, 2006 9:07 pm    Post subject: Reply with quote

Hello,

This is a known problem as discussed in this forum thread. Take a look and see if it solves your problem.
Back to top
View user's profile Send private message
SirYes
Apprentice
Apprentice


Joined: 15 Jan 2006
Posts: 282
Location: Lodz, Poland

PostPosted: Thu May 04, 2006 10:22 pm    Post subject: Reply with quote

Short answer: try masking the newest stable portage and downgrade it a little bit.
See this other topic for exact instructions.
_________________
My blog: In search for ultimate programming language
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Thu May 04, 2006 11:21 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Duplicate Threads, please see this topic: Portage looping.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum