Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200605-02 ] X.Org: Buffer overflow in XRender extension
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Tue May 02, 2006 8:26 pm    Post subject: [ GLSA 200605-02 ] X.Org: Buffer overflow in XRender extensi Reply with quote

Gentoo Linux Security Advisory

Title: X.Org: Buffer overflow in XRender extension (GLSA 200605-02)
Severity: high
Exploitable: local
Date: May 02, 2006
Bug(s): #130979
ID: 200605-02

Synopsis


A buffer overflow in the XRender extension potentially allows any X.Org
user to execute arbitrary code with elevated privileges.


Background


X.Org is X.Org Foundation's public implementation of the X Window
System.


Affected Packages

Package: x11-base/xorg-x11
Vulnerable: < 6.8.2-r7
Unaffected: >= 6.8.2-r7
Architectures: All supported architectures


Description


X.Org miscalculates the size of a buffer in the XRender extension.


Impact


An X.Org user could exploit this issue to make the X server
execute arbitrary code with elevated privileges.


Workaround


There is no known workaround at this time.


Resolution


All X.Org users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=x11-base/xorg-x11-6.8.2-r7"


References

CVE-2006-1526


Last edited by GLSA on Sat Sep 08, 2012 4:21 am; edited 9 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum