Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
!!! ERROR: x11-libs/qt-3.3.6 failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
mistermax
n00b
n00b


Joined: 03 May 2005
Posts: 59

PostPosted: Tue May 02, 2006 11:18 am    Post subject: !!! ERROR: x11-libs/qt-3.3.6 failed Reply with quote

Hi guys,

after upgading my portage system it seems that qt-3.3.6 doesn't compile.
Here the error:

Code:

g++ -c -pipe -I/usr/include/mysql -fno-exceptions -Wall -W -mcpu=athlon-xp -O2 -pipe -fno-strict-aliasing -D_REENTRANT  -DQT_INTERNAL_XML -DUIC -DQT_TABLET_SUPPORT -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -I/var/tmp/portage/qt-3.3.6/work/qt-x11-free-3.3.6/mkspecs/linux-g++ -I. -I/usr/include/freetype2 -I../shared -I../../../include -I/usr/include -I.moc/release-shared-mt/ -o .obj/release-shared-mt/widgetdatabase.o ../shared/widgetdatabase.cpp
`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
g++ -c -pipe -I/usr/include/mysql -fno-exceptions -Wall -W -mcpu=athlon-xp -O2 -pipe -fno-strict-aliasing -D_REENTRANT  -DQT_INTERNAL_XML -DUIC -DQT_TABLET_SUPPORT -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -I/var/tmp/portage/qt-3.3.6/work/qt-x11-free-3.3.6/mkspecs/linux-g++ -I. -I/usr/include/freetype2 -I../shared -I../../../include -I/usr/include -I.moc/release-shared-mt/ -o .obj/release-shared-mt/domtool.o ../shared/domtool.cpp
`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
g++ -c -pipe -I/usr/include/mysql -fno-exceptions -Wall -W -mcpu=athlon-xp -O2 -pipe -fno-strict-aliasing -D_REENTRANT  -DQT_INTERNAL_XML -DUIC -DQT_TABLET_SUPPORT -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -I/var/tmp/portage/qt-3.3.6/work/qt-x11-free-3.3.6/mkspecs/linux-g++ -I. -I/usr/include/freetype2 -I../shared -I../../../include -I/usr/include -I.moc/release-shared-mt/ -o .obj/release-shared-mt/parser.o ../shared/parser.cpp
`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
test -d ../../../bin/ || mkdir -p ../../../bin/
g++ -fno-exceptions -o ../../../bin/uic .obj/release-shared-mt/main.o .obj/release-shared-mt/uic.o .obj/release-shared-mt/form.o .obj/release-shared-mt/object.o .obj/release-shared-mt/subclassing.o .obj/release-shared-mt/embed.o .obj/release-shared-mt/widgetdatabase.o .obj/release-shared-mt/domtool.o .obj/release-shared-mt/parser.o    -L/usr/lib/mysql -L/var/tmp/portage/qt-3.3.6/work/qt-x11-free-3.3.6/lib -L/usr/X11R6/lib -lqt-mt -lmng -ljpeg -lpng -lz -lXi -lXrender -lXrandr -lXcursor -lXft -lfreetype -lfontconfig -lXext -lX11 -lm -lSM -lICE -ldl -lpthread
/usr/lib/gcc/i686-pc-linux-gnu/3.4.6/../../../../i686-pc-linux-gnu/bin/ld: warning: libexpat.so.0, needed by /usr/X11R6/lib/libfontconfig.so, not found (try using -rpath or -rpath-link)
/usr/X11R6/lib/libfontconfig.so: undefined reference to `XML_SetElementHandler'
/usr/X11R6/lib/libfontconfig.so: undefined reference to `XML_SetDoctypeDeclHandler'
/usr/X11R6/lib/libfontconfig.so: undefined reference to `XML_ParserFree'
/usr/X11R6/lib/libfontconfig.so: undefined reference to `XML_SetCharacterDataHandler'
/usr/X11R6/lib/libfontconfig.so: undefined reference to `XML_ErrorString'
/usr/X11R6/lib/libfontconfig.so: undefined reference to `XML_ParseBuffer'
/usr/X11R6/lib/libfontconfig.so: undefined reference to `XML_ParserCreate'
/usr/X11R6/lib/libfontconfig.so: undefined reference to `XML_SetUserData'
/usr/X11R6/lib/libfontconfig.so: undefined reference to `XML_GetErrorCode'
/usr/X11R6/lib/libfontconfig.so: undefined reference to `XML_GetBuffer'
/usr/X11R6/lib/libfontconfig.so: undefined reference to `XML_GetCurrentLineNumber'
collect2: ld returned 1 exit status
make[3]: *** [../../../bin/uic] Error 1
make[3]: Leaving directory `/var/tmp/portage/qt-3.3.6/work/qt-x11-free-3.3.6/tools/designer/uic'
make[2]: *** [sub-uic] Error 2
make[2]: Leaving directory `/var/tmp/portage/qt-3.3.6/work/qt-x11-free-3.3.6/tools/designer'
make[1]: *** [sub-designer] Error 2
make[1]: Leaving directory `/var/tmp/portage/qt-3.3.6/work/qt-x11-free-3.3.6/tools'
make: *** [sub-tools] Error 2

!!! ERROR: x11-libs/qt-3.3.6 failed.
Call stack:
  ebuild.sh, line 1525:   Called dyn_compile
  ebuild.sh, line 928:   Called src_compile
  qt-3.3.6.ebuild, line 197:   Called die

!!! (no error message)
!!! If you need support, post the topmost build error, and the call stack if relevant.


Any idea about?
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Tue May 02, 2006 11:33 am    Post subject: Reply with quote

mistermax wrote:
Code:
/usr/lib/gcc/i686-pc-linux-gnu/3.4.6/../../../../i686-pc-linux-gnu/bin/ld: warning: libexpat.so.0, needed by /usr/X11R6/lib/libfontconfig.so, not found

Looks like you've hit the expat upgrading chaos. Please see this thread for more information: libexpat 2.0.0 ABI breakage.

Moved from Portage & Programming to Duplicate Threads.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum