Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
>=xorg-server-1.0.99 blocks nvidia/ati binary drivers
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4 ... 13, 14, 15  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
przemos
Guru
Guru


Joined: 30 May 2005
Posts: 433
Location: HWDP

PostPosted: Sun May 28, 2006 8:04 pm    Post subject: Reply with quote

przemos wrote:
I heard about this note somewhere but today I made an update emerge -uD world and now I got:
Code:

* x11-base/xorg-server
     Installed:           1.1.0
* x11-base/xorg-x11
     Installed:           7.1_rc2
* media-video/nvidia-glx
     Installed:           1.0.8762

xorg.conf:
Code:

    Driver         "nvidia"

Then I run some 3D game i.e. quake3 and everything seems going fine, so I don't get it what's wrong?


My fault - 3D is definitely broken.
Back to top
View user's profile Send private message
Shazam
Apprentice
Apprentice


Joined: 23 Nov 2004
Posts: 191
Location: Germany

PostPosted: Wed May 31, 2006 7:36 pm    Post subject: Reply with quote

i know, it's not 100% fitting into this topic, but do the 8762 nvidia-driver working with xorg-server-1.0.2-r4, which is currently in portage for ~x86? because i just 'migrated' to gcc-4.1 and xorg-x7, and everything is running except this part.

xorg will only start with the vesa drivers on, but i can't figure out, how to get the nvidia drivers working. or does the 1.0.9x issue apply to this server version, too?
Back to top
View user's profile Send private message
Headrush
Watchman
Watchman


Joined: 06 Nov 2003
Posts: 5597
Location: Bizarro World

PostPosted: Wed May 31, 2006 8:45 pm    Post subject: Reply with quote

Works perfect on amd64, so I would say x86 is no different.
Back to top
View user's profile Send private message
MorLipf
Apprentice
Apprentice


Joined: 09 Nov 2004
Posts: 226
Location: Solingen, Germany

PostPosted: Thu Jun 01, 2006 2:09 pm    Post subject: Reply with quote

Shazam wrote:
i know, it's not 100% fitting into this topic, but do the 8762 nvidia-driver working with xorg-server-1.0.2-r4, which is currently in portage for ~x86? because i just 'migrated' to gcc-4.1 and xorg-x7, and everything is running except this part.

xorg will only start with the vesa drivers on, but i can't figure out, how to get the nvidia drivers working. or does the 1.0.9x issue apply to this server version, too?


I have problems too! The X-Server reports "Caught Signal 8" in the Xorg.0.log. Do we have the same problem?
Back to top
View user's profile Send private message
Shazam
Apprentice
Apprentice


Joined: 23 Nov 2004
Posts: 191
Location: Germany

PostPosted: Thu Jun 01, 2006 7:10 pm    Post subject: Reply with quote

not really, it just says, that it can't load the nvidia-drivers, however it's working quite fine with vesa ...

is there any sort of useflag to set, or change to the xorg.conf to make, except putting down 'nvidia' in the driver section...
Back to top
View user's profile Send private message
Shazam
Apprentice
Apprentice


Joined: 23 Nov 2004
Posts: 191
Location: Germany

PostPosted: Fri Jun 02, 2006 1:16 pm    Post subject: Reply with quote

mm, after recompiling the nvidia-drivers and xorg-x11 package (only this package) it fixed the problem for me. now everything runs fine...
Back to top
View user's profile Send private message
Jeroend
n00b
n00b


Joined: 16 Aug 2005
Posts: 29

PostPosted: Fri Jun 02, 2006 3:25 pm    Post subject: Reply with quote

Dunno if this is any help, but enabeling sub pixel hinting in xfce control center fixed the problem for me

Greetz
Jeroen
Back to top
View user's profile Send private message
vPat
n00b
n00b


Joined: 17 Feb 2006
Posts: 47

PostPosted: Sat Jun 03, 2006 7:29 am    Post subject: Reply with quote

I have never had an issue with the latest xorg-server and nvidia-glx but now xorg-server-1.0.99 is blocked by nvidia-glx. So no updates for us =(
Back to top
View user's profile Send private message
CyberFoxx
n00b
n00b


Joined: 31 Jan 2006
Posts: 25

PostPosted: Sat Jun 03, 2006 3:52 pm    Post subject: Reply with quote

Well, after seeing the block message with the nvidia drivers when I did an "emerge -pv --update --newuse --deep world" and reading all the reports here, I just added

Code:
>=x11-base/xorg-server-1.0.99
>=x11-drivers/xf86-input-mouse-1.1.1
>=x11-drivers/xf86-input-keyboard-1.1.0
>=x11-base/xorg-x11-7.1
>=app-doc/xorg-docs-1.2
>=x11-apps/xev-1.0.2


to my /etc/portage/package.mask. Not sure if xev needs to be masked, just thought I'd be safe for now. Everything else seems to be running ok.
Back to top
View user's profile Send private message
interested1
Tux's lil' helper
Tux's lil' helper


Joined: 22 Feb 2006
Posts: 129

PostPosted: Sat Jun 03, 2006 5:39 pm    Post subject: Reply with quote

Just to make this last post a bit more clear for the noob. If you want to get the xorg-server issue out of your mind you need to find out the dependencies which a world deep upgrade wants to install. What CyberFoxx has done in his last post is to identify the packages that cause problems, and then add them to his package.mask file so they are excluded from consideration. Here is what this process looks like in practice:

Code:
Silentspeed ~ # emerge -pvuND world

These are the packages that would be merged, in order:

Calculating world dependencies -
!!! All ebuilds that could satisfy ">=x11-base/xorg-server-1.0.99" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-base/xorg-server-1.1.0 (masked by: package.mask)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "x11-drivers/xf86-input-joystick-1.1.0" [ebuild])



!!! Problem resolving dependencies for kde-base/kdeartwork-kscreensaver
!!! Depgraph creation failed.

In this case you need to add part of the output to your package.mask, viz. x11-drivers/xf86-input-joystick-1.1.0
Code:

Silentspeed ~ # vi /etc/portage/package.mask

And add,
Code:

>=x11-drivers/xf86-input-joystick-1.1.0


You may have to do this a few times, but at least you will get a system that you can upgrade and not have to worry about the xorg conflict.
Back to top
View user's profile Send private message
drphibes
Guru
Guru


Joined: 30 Nov 2004
Posts: 432

PostPosted: Sat Jun 03, 2006 7:34 pm    Post subject: Reply with quote

CyberFoxx wrote:
Well, after seeing the block message with the nvidia drivers when I did an "emerge -pv --update --newuse --deep world" and reading all the reports here, I just added

Code:
>=x11-base/xorg-server-1.0.99
>=x11-drivers/xf86-input-mouse-1.1.1
>=x11-drivers/xf86-input-keyboard-1.1.0
>=x11-base/xorg-x11-7.1
>=app-doc/xorg-docs-1.2
>=x11-apps/xev-1.0.2


to my /etc/portage/package.mask. Not sure if xev needs to be masked, just thought I'd be safe for now. Everything else seems to be running ok.


I'm using this locally, after reading all the ChangeLogs (xev is ok to upgrade):

Code:
# mask off xorg 7.1 until nvidia release ABI-compatible driver
>=app-doc/xorg-docs-1.2
>=x11-base/xorg-x11-7.1
>=x11-base/xorg-server-1.0.99
>=x11-drivers/xf86-input-keyboard-1.1.0
>=x11-drivers/xf86-input-mouse-1.1.1
>=x11-drivers/xf86-video-nv-1.1.2
>=x11-drivers/xf86-video-v4l-0.1.1
Back to top
View user's profile Send private message
drphibes
Guru
Guru


Joined: 30 Nov 2004
Posts: 432

PostPosted: Sat Jun 03, 2006 8:21 pm    Post subject: Reply with quote

Damn, now I am getting a huge list of blockers. How do I prevent the attempted downgrade to xorg 6.8?
I was using xorg 7.0 with <=virtual/x11-6.9 in my package.mask. I added the 7.1 masks from the previous
post and then did emerge -DNu world. Doing an emerge -DNu world now yields this mess below:

Code:
These are the packages that would be merged, in order:

Calculating world dependencies... done!
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXxf86misc-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xf86miscproto-0.9.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/liblbxutil-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/dmxproto-2.2.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXt-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libSM-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libICE-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libxkbui-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libxkbfile-1.0.3)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/resourceproto-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXres-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xf86dgaproto-2.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-base/xorg-server-1.0.2-r4)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXpm-3.5.5)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXaw-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXmu-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/trapproto-3.4.3)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXtst-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/recordproto-1.13.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/rgb-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xf86driproto-2.0.3)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/iceauth-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/fontsproto-2.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-adobe-75dpi-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/mkfontscale-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libfontenc-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/mkfontdir-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/encodings-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-util-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/bdftopcf-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXfont-1.1.0-r1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/fontcacheproto-0.1.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-alias-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xf86rushproto-1.1.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-misc-misc-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/damageproto-1.0.3)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-cursor-misc-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/glproto-1.4.7)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXxf86vm-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xf86vidmodeproto-2.2.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xkbcomp-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/evieext-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libdmx-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xauth-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-misc/xbitmaps-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-misc/makedepend-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-libs/mesa-6.5-r3)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libdrm-2.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXi-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xinit-1.0.2-r4)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXft-2.1.9)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xclock-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xrdb-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-wm/twm-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/compositeproto-0.3.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/scrnsaverproto-1.1.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/randrproto-1.1.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXrandr-1.1.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xfs-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libFS-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-bh-ttf-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-adobe-utopia-75dpi-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xset-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-bh-lucidatypewriter-75dpi-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-misc/imake-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-misc/xorg-cf-files-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xdriinfo-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-bh-75dpi-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-bh-lucidatypewriter-100dpi-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-bitstream-type1-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xdpyinfo-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXinerama-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXxf86dga-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXp-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/printproto-1.0.3)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-adobe-utopia-100dpi-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xprop-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xwininfo-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xev-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-bh-100dpi-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-ibm-type1-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-bh-type1-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-v4l-0.0.1.5)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-bitstream-100dpi-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-bitstream-75dpi-1.0.0)
[ebuild  N    ] x11-base/opengl-update-3.0.0
[ebuild     UD] x11-base/xorg-x11-6.8.2-r7 [7.0-r1] USE="bitmap-fonts% mmx% nls% opengl% sse% truetype-fonts% type1-fonts% xv% -3dnow% -cjk% -debug% -dlloader% -dmx% -doc% -font-server% -insecure-drivers% -ipv6% -minimal% -nocxx% -pam% -sdk% -static% -xprint%"
[ebuild  N    ] virtual/xft-6.8


Last edited by drphibes on Sat Jun 03, 2006 8:38 pm; edited 1 time in total
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Sat Jun 03, 2006 8:32 pm    Post subject: Reply with quote

Try
Code:
emerge -pv =x11-base/xorg-x11-7.0-r1

to see how that is blocked
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
drphibes
Guru
Guru


Joined: 30 Nov 2004
Posts: 432

PostPosted: Sat Jun 03, 2006 8:38 pm    Post subject: Reply with quote

no blockers there:

Code:
# emerge -pv =x11-base/xorg-x11-7.0-r1

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-base/xorg-x11-7.0-r1  USE="-3dfx" INPUT_DEVICES="keyboard mouse -acecad -aiptek -calcomp -citron -digitaledge -dmc -dynapro -elo2300 -elographics -evdev -fpit -hyperpen -jamstudio -joystick -magellan -magictouch -microtouch -mutouch -palmax -penmount -spaceorb -summa -synaptics -tek4957 -ur98 -vmmouse -void -wacom" VIDEO_CARDS="nv -apm -ark -chips -cirrus -cyrix -dummy -fbdev -fglrx -glint -i128 -i740 -i810 -imstt -mach64% -mga -neomagic -nsc -nvidia -r128% -radeon% -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb -tdfx -tga -trident -tseng -v4l -vesa -vga -via -vmware -voodoo" 0 kB

Total size of downloads: 0 kB
Back to top
View user's profile Send private message
Gergan Penkov
Veteran
Veteran


Joined: 17 Jul 2004
Posts: 1464
Location: das kleinste Kuhdorf Deutschlands :)

PostPosted: Sat Jun 03, 2006 8:45 pm    Post subject: Reply with quote

Could someone explain me what for abi-change is this. I don't have problems with xfce4-svn, but using gnome with the same theme, simply makes gtk+ to forget to render most of the fonts.
The only misbehaving application with xfce is firefox, which only sometimes "forgets" to render some fonts.
Now my question is what sort of an abi-change is this, as it behaves in different DEs differently, although XFCE and Gnome use gtk+, the same applications behave different on them.
_________________
"I knew when an angel whispered into my ear,
You gotta get him away, yeah
Hey little bitch!
Be glad you finally walked away or you may have not lived another day."
Godsmack
Back to top
View user's profile Send private message
sternklang
Veteran
Veteran


Joined: 10 Sep 2005
Posts: 1641
Location: Somewhere in time and space

PostPosted: Sat Jun 03, 2006 9:00 pm    Post subject: Reply with quote

Gergan Penkov wrote:
Could someone explain me what for abi-change is this.

Here is a message from the xorg mailing list that goes into details. Note that the NVidia developer writing it seems to express some frustration at some of the changes.

And it also seems to explain why some of us have more severe problems than bad font rendering as the biggest change affects x86-64 platforms.
Back to top
View user's profile Send private message
Gergan Penkov
Veteran
Veteran


Joined: 17 Jul 2004
Posts: 1464
Location: das kleinste Kuhdorf Deutschlands :)

PostPosted: Sat Jun 03, 2006 9:19 pm    Post subject: Reply with quote

It is still strange, but well :), probably will use nv for now, although I don't have that many problems (except for firefox and this only rarely).
But I still don't get this not deterministic behaviour it either works or it doesn't...
Anyway thanks for the thread
_________________
"I knew when an angel whispered into my ear,
You gotta get him away, yeah
Hey little bitch!
Be glad you finally walked away or you may have not lived another day."
Godsmack
Back to top
View user's profile Send private message
drphibes
Guru
Guru


Joined: 30 Nov 2004
Posts: 432

PostPosted: Sat Jun 03, 2006 9:21 pm    Post subject: Reply with quote

Portage is trying to pull in virtual/xft-6.8 and that is causing my problem. Adding virtual/xft-6.8 to package.provided quiets the problem and removes the attempt to downgrade to xorg 6.8, but it's a hack. What is trying to pull in virtual/xft-6.8?

EDIT: ok found it. virtual/xft was missing from package.keywords. that allows virtual/xft-7.0 to be installed.
Back to top
View user's profile Send private message
sternklang
Veteran
Veteran


Joined: 10 Sep 2005
Posts: 1641
Location: Somewhere in time and space

PostPosted: Sat Jun 03, 2006 10:16 pm    Post subject: Reply with quote

Gergan Penkov wrote:
But I still don't get this not deterministic behaviour it either works or it doesn't...

Maybe we should paraphrase Heinlein and not worry about theory even when the machinery doesn't do what it's supposed to do? :D
Back to top
View user's profile Send private message
Gergan Penkov
Veteran
Veteran


Joined: 17 Jul 2004
Posts: 1464
Location: das kleinste Kuhdorf Deutschlands :)

PostPosted: Sat Jun 03, 2006 10:22 pm    Post subject: Reply with quote

because it would not help in any case ;)
_________________
"I knew when an angel whispered into my ear,
You gotta get him away, yeah
Hey little bitch!
Be glad you finally walked away or you may have not lived another day."
Godsmack
Back to top
View user's profile Send private message
nesl247
Veteran
Veteran


Joined: 15 Jun 2004
Posts: 1614
Location: Florida

PostPosted: Sun Jun 04, 2006 1:55 am    Post subject: Reply with quote

It looks like Xorg7.1 was marked ~x86, so either mask it or deal with it I guess.. This kinda sucks, but I use XGL so no problems here other than an ABI warning. But it seems nvidia-glx now makes >=xorg-server-1.0.99 a blocker.
Back to top
View user's profile Send private message
grofaz
Guru
Guru


Joined: 18 Sep 2005
Posts: 319

PostPosted: Sun Jun 04, 2006 1:58 am    Post subject: Reply with quote

What's with this xorg-server-1.0.99 anyway ? I mean why does emerge keep wanting to install it when I already have xorg-server-1.1.0 on board ?? How do you tell it to quit that ??

Looks like I'm going back to monolithic xorg-x11. I forget I went to modular X and emerged the last stable version which is 6.8.2 something or other.

This whole update today really sucks!
Back to top
View user's profile Send private message
nesl247
Veteran
Veteran


Joined: 15 Jun 2004
Posts: 1614
Location: Florida

PostPosted: Sun Jun 04, 2006 2:00 am    Post subject: Reply with quote

Hmm yeah, I get that too now that I look at it.. I already have xorg-server-1.1 installed, why is 0.99 even a blocker..
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3065
Location: Korea

PostPosted: Sun Jun 04, 2006 3:18 am    Post subject: Reply with quote

sternklang wrote:
b. open-source the damn things so the community can improve the drivers more quickly than their no-doubt-talented developers can all by themselves, all we can do is wait.


Could be illegal for them to do that. They might be keeping the software closed source if it uses source code they don't have the right to open up.
Back to top
View user's profile Send private message
Hydraulix
Guru
Guru


Joined: 12 Dec 2003
Posts: 447
Location: Baltimore, Maryland

PostPosted: Sun Jun 04, 2006 3:27 am    Post subject: Reply with quote

I'm getting this error.

Code:

[blocks B     ] >=x11-base/xorg-server-1.0.99 (is blocking x11-drivers/ati-drivers-8.25.18)
[ebuild     U ] sys-apps/portage-2.1_rc4 [2.1_rc3-r5] USE="-build -doc" LINGUAS="-pl" 269 kB
*** Portage will stop merging at this point and reload itself,
    then resume the merge.
[ebuild     U ] x11-libs/libXft-2.1.9 [2.1.8.2] USE="-debug" 246 kB
[ebuild     U ] x11-libs/libXcursor-1.1.7 [1.1.6] USE="-debug" 218 kB
[ebuild     U ] media-libs/mesa-6.5-r3 [6.4.2-r2] USE="motif nptl% -debug" VIDEO_CARDS="radeon -i810 -mach64 -mga -none -r128 -s3virge -savage -sis -tdfx -trident -via" 2,990 kB
[ebuild  N    ] sys-libs/libutempter-1.1.2.1  21 kB
[ebuild     U ] x11-misc/xorg-cf-files-1.0.2 [1.0.1-r2] USE="-debug" 258 kB
[ebuild     U ] x11-misc/imake-1.0.2 [1.0.1-r1] USE="-debug" 110 kB
[ebuild     U ] x11-terms/xterm-213-r1 [213] USE="truetype -Xaw3d -doc -toolbar -unicode" 0 kB
[ebuild     U ] app-doc/xorg-docs-1.2 [1.1-r1] USE="-debug -doc" 8,132 kB
[ebuild     U ] x11-apps/mesa-progs-6.5 [6.4.2] 803 kB
[ebuild  N    ] x11-base/xorg-server-1.1.0  USE="dri ipv6 nptl sdl xorg -3dfx -debug -dmx -kdrive -minimal -xprint" INPUT_DEVICES="keyboard mouse -acecad -aiptek -calcomp -citron -digitaledge -dmc -dynapro -elo2300 -elographics -evdev -fpit -hyperpen -jamstudio -joystick -magellan -magictouch -microtouch -mutouch -palmax -penmount -spaceorb -summa -synaptics -tek4957 -ur98 -vmmouse -void -wacom" VIDEO_CARDS="fglrx radeon vesa -apm -ark -chips -cirrus -cyrix -dummy -epson -fbdev -glint -i128 -i740 -i810 -imstt -mach64 -mga -neomagic -nsc -nv -nvidia -r128 -rendition -s3 -s3virge
a -trident -tseng -v4l -vga -via -vmware -voodoo" 6,174 kB
[ebuild     U ] x11-base/xorg-x11-7.1 [7.0-r1] 0 kB
[ebuild     U ] x11-drivers/xf86-video-vesa-1.2.1 [1.0.1.3] USE="-debug" 210 kB
[ebuild     U ] x11-drivers/xf86-video-ati-6.6.0 [6.5.8.0] USE="dri -debug" 706
[ebuild     U ] x11-drivers/xf86-input-mouse-1.1.1 [1.0.4] USE="-debug" 261 kB
[ebuild     U ] x11-drivers/xf86-input-keyboard-1.1.0 [1.0.1.3] USE="-debug" 226
[ebuild     U ] x11-misc/gccmakedep-1.0.2 [1.0.1-r1] USE="-debug" 68 kB
[ebuild     U ] dev-libs/nspr-4.6.2 [4.6.1-r3] USE="ipv6" 1,271 kB
[ebuild     U ] dev-libs/nss-3.11.1 [3.11-r1] 3,564 kB
[ebuild     U ] media-libs/xine-lib-1.1.2_pre20060328-r10 [1.1.2_pre20060328-r9]
on gnome ipv6 mad nls opengl oss sdl vorbis win32codecs xv -a52 -aalib -debug -d
mng -modplug -samba -speex -theora -v4l -vcd -vidix -xinerama -xvmc" VIDEO_CARDS
[ebuild     U ] dev-python/pyrex-0.9.4.1 [0.9.3.1] 177 kB
[ebuild     U ] dev-lang/tcl-8.4.13 [8.4.12] USE="-debug% -threads" 3,431 kB
[ebuild     U ] www-client/mozilla-firefox-1.5.0.4 [1.5.0.3] USE="gnome ipv6 jav
 kB

Total size of downloads: 63,730 kB

!!! Error: The above package list contains packages which cannot be installed
!!!        at the same time on the same system.


Code:

Portage 2.1_rc3-r5 (default-linux/x86/2006.0, gcc-4.1.1, glibc-2.4-r3, 2.6.17-rc3-no2 i686)
=================================================================
System uname: 2.6.17-rc3-no2 i686 AMD Sempron(tm) Processor 3500+
Gentoo Base System version 1.12.0
ccache version 2.4 [enabled]
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r1
dev-util/confcache:  0.4.2-r1
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.91.0.7, 2.16.92, 2.16.93
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r5
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -pipe -ftracer -fweb -frename-registers"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -pipe -ftracer -fweb -frename-registers -fvisibility-inlines-hidden"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache confcache distlocks metadata-transfer sandbox sfperms"
GENTOO_MIRRORS="http://mirror.datapipe.net/gentoo http://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://gentoo.mirrored.ca/ http://gentoo.seren.com/gentoo"
LDFLAGS="-Wl,-O1 -Wl,--sort-common"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="x86 3dnow 3dnowext X aac acpi alsa apache2 apm arts asf avi berkdb bitmap-fonts cdr cdrom cli crypt cups dga directfb dri dvd dvdr eds emboss encode esd fbcon ffmpegftp foomaticdb fortran gdbm gif gnome gpm gstreamer gtk gtk2 ieee1394 imlib ipod ipv6 isdnlog java jpeg kde libg++ libwww lm_sensors mad maildir mbox mikmod mmx mmxext motif mp3 mpeg ncurses nls nptl nptlonly nsplugin ogg opengl oss pam pcre pdflib perl pmu png pppd python qt quicktime readline real reflection sdl session spell spl sse sse2 ssl tcpd truetype truetype-fonts type1-fonts udev usb visualization vorbis win32codecs xml xmms xorg xv xvid zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux userland_GNU video_cards_radeon video_cards_fglrx video_cards_vesa"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_RSYNC_EXTRA_OPTS


I tried removing ati-drivers but that didn't work. So I tried removing xorg-server and that didn't work. What should I do?
_________________
It is the fate of operating systems to become free.
- Neal Stephenson

If only You and Dead people can read hex, how many people can read hex?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2, 3, 4 ... 13, 14, 15  Next
Page 3 of 15

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum