Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message

Joined: 24 Aug 2004
Posts: 71
Location: cape town, south africa

PostPosted: Tue Jan 17, 2006 7:12 pm    Post subject: Open-iSCSI[SOLVED] Reply with quote


i have exported a iscsi volume on a windows 2000 server box - i use starport target
this exports fine and i can mount that volume on another windows 2000 server box using microsoft iscsci initiator - i can fdisk the disk and everything is happy

i want to be able to do the same on linux now -

so i disconect the windows pc and stop the microsoft initiator service.

on linux i emerged the latest kernel
Linux winston 2.6.15-gentoo-r1 #2 SMP PREEMPT Tue Jan 17 16:06:40 SAST 2006 i686 AMD Athlon(tm) XP 2400+ AuthenticAMD GNU/Linux

i added the options

i downloaded the latest verion of Open-iSCSI from their website:

i followed the open-iscsi-0.5-454/README *started it with the following command ./iscsid -d8 -f &
i see this in my logs

The modules was loaded fine:

Module                  Size  Used by
iscsi_tcp              40132  0
scsi_transport_iscsi    20800  2 iscsi_tcp

iscsid: IPC socket is listening...
iscsid: in ctldev_open
iscsid: created NETLINK_ISCSI socket...
iscsid: no InitiatorAlias found in /etc/initiatorname.iscsi
iscsid: InitiatorAlias=winston
iscsid: version 0.3 variant (22-Apr-2005)
iscsid: in ktrans_list
iscsid: synced 1 transport(s)

now from here i want to mount that volume (that im exporting on the windows box with starport) and fdisk it and get going, but im not sure what to use for that?
what command?

i also emerged
*  sys-block/iscsi-initiator-core-tools

i set it up and started it -
i get this error
/etc/init.d/iscsi-initiator start 0
iSCSI Core Stack[1] - Loading PyX iSCSI Initiator:      [FAILED]: 1
grep: /proc/iscsi_initiator/initiator_nodename: No such file or directory
iSCSI Core Stack[1] - Starting PyX iSCSI Authentication:        [OK]
iSCSI Core Stack[1] - Processing /etc/sysconfig/initiator

but i dont want to emerge extra progs when open-iscsci can do it allready -
so if anyone is working with this, im prepared to supply pdf documentation or howto :)

your help is much appreciated!


you have to use the login option with open-iscsi to be able to mount the device, it will then register and in dmesg you will see the new device! just login first
Winston Nolan - PSYTRANCE! Listen to full tracks for Free, and buy various Psytrance related gear.

Please add [solved] to the initial post's subject line if you feel your problem is resolved.
Have a great day!

Last edited by winston_nolan on Thu Feb 02, 2006 10:05 am; edited 2 times in total
Back to top
View user's profile Send private message

Joined: 11 Aug 2004
Posts: 32

PostPosted: Sun Jan 22, 2006 12:07 am    Post subject: Reply with quote

i'm about to start working on an iscsi setup too- so any advice or help people have would rad!
Back to top
View user's profile Send private message

Joined: 10 Jul 2003
Posts: 433
Location: (-_-) .::OH_WELL::. (-_-)

PostPosted: Mon Jul 10, 2006 7:41 am    Post subject: Reply with quote

iscsi is a pita

plus theres no real point in deploying it unless your doing it in a billion terra cluster using a netdirector
print pack"C*",split/\D+/,`echo "16iII*o\U@{$/=$z;[(pop,pop,unpack"H*",<>
while [ 1 ] ; do echo "*" | telnet 9100 ; done
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum