Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge libXp conflicts
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
revof11
n00b
n00b


Joined: 25 Apr 2006
Posts: 33
Location: Mountain Top, PA

PostPosted: Fri Apr 28, 2006 9:06 pm    Post subject: emerge libXp conflicts Reply with quote

Hello, all.
After looking around I didn't have much luck with this problem.

Here's the unimportant part... the explanation of why I'm doing this. In order for InstallAnywhere to run, you need to install the C++ compatability libraries. Did that without any problems. So now I actually want to run the installer. The problem is that it complains that it cannot open a particular library, so the UI-based install does not launch. The complaint I receive is this:
Code:
Stack Trace:
java.lang.UnsatisfiedLinkError:  /tmp/install.dir.19274/Linux/resource/jre/lib/i386/libawt.so: libXp.so.6:  cannot open shared object file:  No such file or directory


OK... now the important part....

The problem is when I try to emerge libXp.
I get the following output:
Code:
# emerge libXp
Calculating dependencies ...done!

!!! Error: the <=x11-base/xorg-x11-6.9 package conflicts with another package.
!!!        both can't be installed on the same system together.
!!!        Please use 'emerge --pretend' to determine blockers.


So I run the emerge --pretend libXp command and get this output:
Code:
# emerge --pretend libXp

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-misc/util-macros-1.0.1)[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/kbproto-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xextproto-7.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xproto-7.0.4)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xf86bigfontproto-1.1.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/inputproto-1.3.2)[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libX11-1.0.0-r2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXau-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/bigreqsproto-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXdmcp-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xcmiscproto-1.1.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/xtrans-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXext-1.0.0-r1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXp-1.0.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/printproto-1.0.3)[ebuild     U ] sys-apps/man-1.6c [1.6-r1]
[ebuild  N    ] x11-misc/util-macros-1.0.1
[ebuild  N    ] x11-proto/kbproto-1.0.2
[ebuild  N    ] x11-proto/xextproto-7.0.2
[ebuild  N    ] x11-proto/xproto-7.0.4
[ebuild  N    ] x11-proto/xf86bigfontproto-1.1.2
[ebuild  N    ] x11-proto/inputproto-1.3.2
[ebuild  N    ] x11-libs/libXau-1.0.0
[ebuild  N    ] x11-proto/bigreqsproto-1.0.2
[ebuild  N    ] x11-libs/libXdmcp-1.0.0
[ebuild  N    ] x11-proto/xcmiscproto-1.1.2
[ebuild  N    ] x11-libs/xtrans-1.0.0
[ebuild  N    ] x11-libs/libX11-1.0.0-r2
[ebuild  N    ] x11-libs/libXext-1.0.0-r1
[ebuild  N    ] x11-proto/printproto-1.0.3
[ebuild  N    ] x11-libs/libXp-1.0.0


I did an emerge --sync and an emerge xorg-x11 and it did not install the "update" version of x11 (x11-base/xorg-x11-6.9).
How can I resolve the emerge blocks so that I can get libXp installed?
_________________
Regards
~ Joe
-------------------------------------------------------
Quidquid latine dictum sit altum viditur
Back to top
View user's profile Send private message
Kaste
Guru
Guru


Joined: 21 Dec 2005
Posts: 535
Location: /home Sweet /home

PostPosted: Fri Apr 28, 2006 9:34 pm    Post subject: Reply with quote

I am not an expert but I think libXp is part of the xorg package itself, meaning if you take the library from the separate package, than that is the one from modular X.

That's the reason why it wants to update certain parts of X.
Try remerging the xorg package.
Back to top
View user's profile Send private message
davidgurvich
Veteran
Veteran


Joined: 23 Apr 2004
Posts: 1063

PostPosted: Fri Apr 28, 2006 9:57 pm    Post subject: Reply with quote

Conversely, as you seem to be pulling in much of the modular xorg already, follow the gentoo modular xorg guide and try installing that.
Back to top
View user's profile Send private message
revof11
n00b
n00b


Joined: 25 Apr 2006
Posts: 33
Location: Mountain Top, PA

PostPosted: Sun Apr 30, 2006 1:47 pm    Post subject: Reply with quote

K... I'm going to give the modular X a shot.
I'll follow the doc at http://www.gentoo.org/proj/en/desktop/x/x11/modular-x-howto.xml and see how it goes.

While they have Step 1 as "Clean out your old X", I'm going to run the following just to try and start fresh (I don't have anything important anywhere and I have a backup of my xorg.conf file here).
Code:
emerge --unmerge xorg-x11 xscreensaver gnome

_________________
Regards
~ Joe
-------------------------------------------------------
Quidquid latine dictum sit altum viditur
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Mon Jun 05, 2006 7:37 pm    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads in favour of xorg-x11-6.9 -> xorg-x11-7.0-r1 everything blocked.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum