Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
MorbidDK
n00b
n00b


Joined: 13 Feb 2003
Posts: 48

PostPosted: Thu Apr 27, 2006 8:35 pm    Post subject: emerge problem Reply with quote

I've just been doing some system cleaning and I think I may have done something bad. I have been using gcc-3.4.6 for a while now and found that I still had gcc-3.3.6 installed, so I removed that, now when I try to emerge world I get:

Code:
# emerge -Dup world

These are the packages that would be merged, in order:

Calculating world dependencies... done!
[ebuild  N    ] sys-libs/libstdc++-v3-3.3.6  USE="nls nptl -build"
[ebuild  NS   ] sys-kernel/hardened-sources-2.6.16-r5  USE="-build -doc -symlink"
[ebuild     U ] perl-core/CGI-3.19 [3.15] USE="-minimal%"
[ebuild     U ] virtual/perl-CGI-3.19 [3.15]
[ebuild     U ] dev-perl/HTML-Parser-3.51 [3.48] USE="-minimal%"
[ebuild     U ] app-crypt/gnupg-1.4.3 [1.4.2.2]
[ebuild     U ] net-fs/samba-3.0.22-r2 [3.0.22] USE="-msdfs%"

Which is no problem but when I remove -p to build the apps I get:

Code:
# emerge -Du world
Calculating world dependencies... done!
>>> Emerging (1 of 7) sys-libs/libstdc++-v3-3.3.6 to /
>>> checking ebuild checksums
!!! Digest verification failed:
!!! /usr/portage/sys-libs/libstdc++-v3/libstdc++-v3-3.3.4.ebuild
!!! Reason: Failed on SHA256 verification
!!! Got: 8b69285ba85a78e17363642dc865194bafaf592c09d3fc39b01ddabe9cfd063c
!!! Expected: b9b46591f48d283887331f4aa6afe61757cf22a125f8d457c8fd3665273f40ec

What am I missing here? Why is it comparing the hash of 3.3.4 when its specifically building 3.3.6?
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Thu Apr 27, 2006 8:48 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, please see this topci: Portage: SHA256 verification failed....
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum