Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg and accelerated video on a Radeon?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
ldeviator
n00b
n00b


Joined: 25 Apr 2006
Posts: 8
Location: Kansas City, Missouri

PostPosted: Tue Apr 25, 2006 11:17 pm    Post subject: Xorg and accelerated video on a Radeon? Reply with quote

I've been pouring over the forums, but I haven't found anything that works for me yet. Anyone get the ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE] working on a SunBlade 1000?

I have the frame buffer one working as is talked about here... but I was hoping to get the accelerated driver working...

uname -a
Code:

Linux transcendence 2.6.15-gentoo-r8 #4 Wed Apr 19 00:16:11 CDT 2006 sparc64 sun4u GNU/Linux


I patched x11-base/xorg-x11-6.8.2-r6 to find the card on my PCI bus

lspci (just the video card)
Code:

0001:00:01.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE]


here's the various stuff I've tried (what is uncommented is what I'm running now, but in unaccelerated mode.. commented stuff is stuff I've tried to switch on and off)

Code:

Section "Device"
        Identifier  "Videocard0"
#       Driver      "radeon"
        Driver      "fbdev"
        VideoRam    32768
        BusID       "PCI:00@0001:01:00"
        ChipID      0x5159
        Option      "reference_clock"   "27.0 MHz"
#        IOBase      0x04000000
# NO!        IOBase      0x00140000
# NO!        IOBase      0x00000500
#Option "BusType" "PCI"
#Option "MonitorLayout" "CRT"
#Option "UseFBDev" "true"
EndSection


It finds my card OK, loads ati and radeon modules, and then just exists saying: Screens(s) found but none of them have a usable configuration.

Is this supposed to work?

Let me know if I should post more.. I kept it brief in case the answer is "nope doesn't work" :)
Back to top
View user's profile Send private message
fidel
Guru
Guru


Joined: 16 Jul 2004
Posts: 390
Location: CH

PostPosted: Wed Apr 26, 2006 11:09 am    Post subject: Reply with quote

I have a Radeon 7000 as well, works well here (no SunBlade). I use the radeon driver from xorg-x11 though, needs the kernel module agpgart, via-agp (or whatever chipset), drm and radeon (all as modules).
Back to top
View user's profile Send private message
ldeviator
n00b
n00b


Joined: 25 Apr 2006
Posts: 8
Location: Kansas City, Missouri

PostPosted: Wed Apr 26, 2006 1:47 pm    Post subject: Reply with quote

So, on a different kind of sparc? I can't get the drm modules to compile on my sparc (x11-drm package right?)
Back to top
View user's profile Send private message
fidel
Guru
Guru


Joined: 16 Jul 2004
Posts: 390
Location: CH

PostPosted: Wed Apr 26, 2006 2:08 pm    Post subject: Reply with quote

I don't have a sparc... You can get direct rendering with the card by using the xorg-drivers for the radeon card, so why compiling x11-drm? You can build xorg-x11 and use the radeon driver. The only thing needed are agpgart, the agp driver for your chipset (via-agp, intel-agp..), drm and radeon compiled as modules...
Back to top
View user's profile Send private message
ldeviator
n00b
n00b


Joined: 25 Apr 2006
Posts: 8
Location: Kansas City, Missouri

PostPosted: Wed Apr 26, 2006 2:31 pm    Post subject: Reply with quote

I am using the xorg-x11 radeon driver as well (/usr/lib/modules/drivers/radeon_drv.so). I thought you were talking about the drm stuff... my bad. I'm not using any x11-drm stuff, as it won't compile.

I have the drm and radeon kernel options compiled as modules as well... but ya, they don't seem to function without the MTRR or the AGP stuff...

which....

As far as I can tell, the agpgart and MTRR kernel options are not valid options in the kernel config for 2.6.15-gentoo-r8 for sparc.

/usr/src/linux/drivers/char/agp/Kconfig
Code:

config AGP
        tristate "/dev/agpgart (AGP Support)" if !GART_IOMMU
        depends on ALPHA || IA64 || PPC || X86
        default y if GART_IOMMU
....


... no SPARC64 in the "depends" line there. Are you saying it should be in there?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum