Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
%e is depreciated ... yada yada
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
moob7
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jan 2006
Posts: 80

PostPosted: Fri Apr 21, 2006 3:23 am    Post subject: %e is depreciated ... yada yada Reply with quote

So after a recent emerge, I noticed that during boot, I've got a new error message. Everything seems to work so I suppose I could ignore it but the text bothers me. ;)

Code:
udevd-event[1177]: find_free_number: %e is depreciated, will be removed and is unlikey to work


Oddly enough, a search through these forums revealed nothing. Usually when an error message has a typo (such as "unlikey"), it makes it easier to search. ;) Google also failed me (apparently it eats the "%" character and searches for e instead of %e).

A hunch made me suspect the udev rules files

I Checked in my my udev rules files in /etc/udev/rules.d and sure enough:
Code:

grep "%e" *
50-udev.rules:ENV{ID_CDROM}=="?*",              SYMLINK+="cdrom%e", GROUP="cdrom"
50-udev.rules:ENV{ID_CDROM_CD_RW}=="?*",        SYMLINK+="cdrw%e"
50-udev.rules:ENV{ID_CDROM_DVD}=="?*",  SYMLINK+="dvd%e"
50-udev.rules:ENV{ID_CDROM_DVD_R}=="?*",        SYMLINK+="dvdrw%e"

What is odd is that the use of "%e" is in one of the "default" (means a file that emerge put there and that I never edited) rules files.

Even odder, the man page for udev has no mention of %e.

So I have three obvious solutions (pick one)

  • leave it. if it ain't broke don't fix it
  • delete the four lines from 50-udev.rules and cross my fingers and hope 'puter don't go BOOM
  • find out wtf %e is and replace it with an equivalent that won't cause udev to bitch during boot (so far this has been what I have been trying but without success)

Any ideas? For now I'm following the first option ;)

update: google found this link but apparently they (in the link) haven't figured it out either:
http://www.gentooforum.de/post/64325/lastpost.html#post64325
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7820

PostPosted: Fri Apr 21, 2006 3:41 am    Post subject: Reply with quote

What %e means, quoth man 8 udev:
Quote:
%e, $enum
If a device node already exists with the name, the smallest next free number is used. This can be used to create compatibility symlinks and enumerate devices of the same type originating from different kernel subsystems.
Note: The use of the enumeration facility is unreliable for events that request a number at the same time. The use of enumerations in todays setups where devices can come and go at any time is not recomended.

An oft used replacement, same source:
Quote:
%n, $number
The kernel number for this device. For example, 'sda3' has kernel number of '3'


For now, the first option makes most sense, unless you want to update sys-fs/udev which may or may not solve the problem.
Back to top
View user's profile Send private message
moob7
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jan 2006
Posts: 80

PostPosted: Fri Apr 21, 2006 10:41 pm    Post subject: Reply with quote

Quote:
What %e means, quoth man 8 udev:

This is a separate problem but:
Code:

$ man 8 udev
No entry for udev in section 8 of the manual
$


Quote:
%n, $number
The kernel number for this device. For example, 'sda3' has kernel number of '3'


Thank you. This I will try (replacing all "%e" with "%n"). When next I reboot I will see if it works.
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7820

PostPosted: Fri Apr 21, 2006 11:16 pm    Post subject: Reply with quote

moob7 wrote:
This is a separate problem but:
Code:

$ man 8 udev
No entry for udev in section 8 of the manual
$

What version of udev are you using?
Back to top
View user's profile Send private message
Mad Merlin
Veteran
Veteran


Joined: 09 May 2005
Posts: 1141

PostPosted: Sat Apr 22, 2006 8:42 am    Post subject: Reply with quote

The udev manpage is found in section 7 for me, not 8. I'm using sys-fs/udev-087. It should be noted that
Code:
man udev
works also.
_________________
Game! - Where the stick is mightier than the sword!
Back to top
View user's profile Send private message
Paapaa
l33t
l33t


Joined: 14 Aug 2005
Posts: 955
Location: Finland

PostPosted: Sat Apr 22, 2006 10:12 am    Post subject: Re: %e is depreciated ... yada yada Reply with quote

moob7 wrote:
Code:
udevd-event[1177]: find_free_number: %e is depreciated, will be removed and is unlikey to work


Oddly enough, a search through these forums revealed nothing. Usually when an error message has a typo (such as "unlikey"), it makes it easier to search. ;)


You should try searching again with the word "find_free_number". Also, it is "deprecated" not "depreciated" - no wonder you found nothing :)
Back to top
View user's profile Send private message
dsd
Developer
Developer


Joined: 30 Mar 2003
Posts: 2162
Location: nr London

PostPosted: Sat Apr 22, 2006 10:26 am    Post subject: Reply with quote

you should leave %e as-is. the warning you see is not addressed to you, its addressed to the people who maintain the ebuilds.
_________________
http://dev.gentoo.org/~dsd
Back to top
View user's profile Send private message
mirojira
l33t
l33t


Joined: 18 Feb 2006
Posts: 685

PostPosted: Sat Apr 22, 2006 12:38 pm    Post subject: Reply with quote

This is not the new problem. See
https://forums.gentoo.org/viewtopic-t-444874-highlight-udevevent.html
Back to top
View user's profile Send private message
batistuta
Veteran
Veteran


Joined: 29 Jul 2005
Posts: 1384
Location: Aachen

PostPosted: Sat Apr 22, 2006 9:47 pm    Post subject: Reply with quote

dsd wrote:
you should leave %e as-is. the warning you see is not addressed to you, its addressed to the people who maintain the ebuilds.

I really don't get this. Since when is a warning not addressed to the people reading that? Or are ebuild maintaners reading my monitor? :roll:
I really, I mean really don't wanna have that warning messing up my beautiful gensplash screen while I boot.

Other threads suggest replacing %e with %n in /etc/udev/rules.d/50-udev.rules
Is this the solution?
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7820

PostPosted: Sun Apr 23, 2006 6:07 am    Post subject: Reply with quote

The idea dsd appears to have been trying to convey is that this is an issue to be fixed by the maintainer of the affected udev rules, if you maintain a set of custom udev rules that could mean you but as a user you should be able to let the developers fix it. Which of course, begs the question: why not let the user update /etc/udev/rules/50-udev.rules locally and just accept the update when the developers fix it in sys-fs/udev?
Back to top
View user's profile Send private message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1507
Location: Edinburgh, Scotland

PostPosted: Sun Apr 23, 2006 6:28 am    Post subject: Reply with quote

Hi all,

Unfortunately, while I updated udev and ignored the messages, I had some problems with my DVD drives. Namely, while the second drive, a DVD burner, worked fine, the first was inaccessible as no device seemed to have been created. My temporary solution has been to downgrade udev to the previous version until the package maintainers fix what is wrong (I noticed this has been posted to bugs.gentoo.org). Is there any 'correct' solution to the problem at this time?

Best,

Alex
Back to top
View user's profile Send private message
dsd
Developer
Developer


Joined: 30 Mar 2003
Posts: 2162
Location: nr London

PostPosted: Sun Apr 23, 2006 4:53 pm    Post subject: Reply with quote

it's quite common for various processes to spit out messages which arent designed for the user (ever seen a QA Notice while emerging something? how about a warning from gcc?)
the upstream udev developers added that message as a method of informing all distros not to use %e
gentoo (i.e. downstream) now need to fix the rules

%n is probably not a suitable replacement for %e, because both /dev/hdc and /dev/hdd will have %n=0 (another example, both /dev/hda1 and /dev/hdb1 will have %n=1)

if you are that bothered by the message then you should remove the warning statement from udev, or go back to the stable tree (i dont think the message exists there - right?)
_________________
http://dev.gentoo.org/~dsd
Back to top
View user's profile Send private message
-fenice-
n00b
n00b


Joined: 23 Jul 2005
Posts: 51
Location: Limoges

PostPosted: Sun Apr 23, 2006 7:20 pm    Post subject: Reply with quote

This message is displayed with the last stable release of udev...
Back to top
View user's profile Send private message
batistuta
Veteran
Veteran


Joined: 29 Jul 2005
Posts: 1384
Location: Aachen

PostPosted: Sun Apr 23, 2006 7:24 pm    Post subject: Reply with quote

thanks guys for the clarification. At least I know that I shouldn't mess up the %e.
Back to top
View user's profile Send private message
theoakwise
n00b
n00b


Joined: 15 May 2004
Posts: 37

PostPosted: Thu May 04, 2006 3:09 am    Post subject: Reply with quote

dsd wrote:
if you are that bothered by the message then you should remove the warning statement from udev, or go back to the stable tree (i dont think the message exists there - right?)


I'm getting it with udev-087, which seems to be marked stable x86.
Back to top
View user's profile Send private message
sesamsys
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jun 2005
Posts: 114
Location: Kobe, Japan

PostPosted: Tue May 09, 2006 11:02 am    Post subject: Reply with quote

It is also the stable one for amd64, and I am getting the warnings too. :) No messing up of gensplash for me, but it does look fairly nasty on a simple text boot too. I was frightened at the first time... :)
_________________
SeSam.hu - Kansai Edition
Linux lillemor 2.6.23-gentoo-r6 #1 SMP Mon Jan 28 08:41:19 JST 2008 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
Bob P
Advocate
Advocate


Joined: 20 Oct 2004
Posts: 3355
Location: Jackass! Development Labs

PostPosted: Thu May 11, 2006 3:22 pm    Post subject: Reply with quote

batistuta wrote:
dsd wrote:
you should leave %e as-is. the warning you see is not addressed to you, its addressed to the people who maintain the ebuilds.

I really don't get this. Since when is a warning not addressed to the people reading that? Or are ebuild maintaners reading my monitor? :roll:
I really, I mean really don't wanna have that warning messing up my beautiful gensplash screen while I boot.

I share your frustration. I'm building a Live CD, and I don't want the error message showing up when my Live CD boots. IMHO this is an ebuild QA issue, as this situation should have been resolved before the ebuild was marked stable.

It would appear that our only options are to: a) live with it, b) manually edit udev to quash the output of the error message, or c) nag the ebuild maintainer to get their act together.

Acoording to Bugzilla Alex's bug report was RESOLVED INVALID. In other words, the developers expect you to live with it. :roll: Perhaps if @nesl247 could reopen the bug...
_________________
.
Stage 1/3 | Jackass! | Rockhopper! | Thanks | Google Sucks
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2035
Location: Konradsreuth (Germany)

PostPosted: Tue May 16, 2006 9:01 am    Post subject: Reply with quote

Living with it sucks.
Back to top
View user's profile Send private message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1507
Location: Edinburgh, Scotland

PostPosted: Sun May 28, 2006 5:34 pm    Post subject: Reply with quote

Libby wrote:
Living with it sucks.


Just realized one doesn't have to live with it! What I did was downgrade back to udev-079-r1 and then I re-upgraded back to udev-087, but the crucial thing is that I did not allow etc-update to change 50-udev.rules. Everything seems to be working ok now!

Hopefully the people maintaining it will fix this. I posted a bug report today, so my fingers are crossed.

Best,

Alex
Back to top
View user's profile Send private message
evilshenaniganz
Tux's lil' helper
Tux's lil' helper


Joined: 18 Dec 2003
Posts: 101
Location: /dev/random

PostPosted: Sat Jun 03, 2006 11:19 pm    Post subject: Reply with quote

I was running into the same %e problem. I edited three lines in my 50-udev.rules file-- If I recall correctly they were cdrom, dvd, and cdrw? Anywho, I changed them to %n as desultory suggested and now udev doesn't bitch on setup. This is *likey* the proper solution to this little problem. :)
_________________
"I swear to God, I'll pistol whip the next guy that says 'shenanigans'."
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Mon Jul 17, 2006 7:22 pm    Post subject: Reply with quote

I feel quite pissed because this is not fixed until this day :wink: Why do the gentoo devs not just change the rules and update the package? It's such a small change...
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
dsd
Developer
Developer


Joined: 30 Mar 2003
Posts: 2162
Location: nr London

PostPosted: Mon Jul 17, 2006 7:44 pm    Post subject: Reply with quote

change it to what? changing %e to %n is wrong and will not give the desired behaviour
_________________
http://dev.gentoo.org/~dsd
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Mon Jul 17, 2006 7:48 pm    Post subject: Reply with quote

dsd wrote:
change it to what? changing %e to %n is wrong and will not give the desired behaviour


Yes I read about it... Then blame the udev devs 8)
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7820

PostPosted: Tue Jul 18, 2006 6:10 am    Post subject: Reply with quote

To clarify, I did not mean that %n would magically replace all of the features of %e, but it does provide a replacement in some cases (especially those where %e was, at least arguably, a poor solution in the first place), in other cases %n can be used as part of a solution to replace %e, though it would generally result in different node or link names, but %n is not a general replacement for %e. Hopefully dsd will no longer need to tell people that different features are different and will act differently, developers have enough to deal with.
Back to top
View user's profile Send private message
przeuj
Tux's lil' helper
Tux's lil' helper


Joined: 11 May 2004
Posts: 94
Location: Krakow

PostPosted: Sun Aug 13, 2006 10:47 am    Post subject: Reply with quote

Quote:

I share your frustration. I'm building a Live CD, and I don't want the error message showing up when my Live CD boots. IMHO this is an ebuild QA issue, as this situation should have been resolved before the ebuild was marked stable.


Maybe you can add a 'grep -v "unlikey to work"' to the scripts and you wont be bothered by this message.

I believe the issue is udev itself. In Gentoo its working so far -- so why fixing it? does anyone with the error message have had a problem after boot up? Just to clear up this thing as Im not sure if its just about the beauty of the boot up messages...

Bartek
_________________
[img]http://www.openwengo.org/static/eng_eng/images/banners/wengophone.png[/img]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum