Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Stream video in Opera/Firefox-bin on AMD64 (mplayerplug-in)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
blossa
Apprentice
Apprentice


Joined: 13 Jan 2005
Posts: 155

PostPosted: Tue Aug 29, 2006 11:26 pm    Post subject: Reply with quote

I am trying to get this working in Opera...

Ok, I get no errors staring Opera 9.00. When I go to a homepage with a movie, the browser buffers the movie but then it just stops. It does not crash Opera or something, it only stops.

When doing the 'emerge stuff' from first post in this thread i looks like I got v.3.21 instead because the only mplayerplug-in file I have in /usr/portage/distfiles is version 3.21.

So, do I have to unmask v.3.25 or will that solve nothing? Or should I go with even newer versions like 3.30 or 3.31? Or, maybe, maybe there is another solution ot there now? :)

Any other suggestion?

Thanks in advance.
_________________
QX9650, P5E64WS Pro, 4x1GB
Back to top
View user's profile Send private message
Jarda
n00b
n00b


Joined: 12 Sep 2006
Posts: 6

PostPosted: Sat Sep 16, 2006 1:36 pm    Post subject: Reply with quote

Hi, thanks for the howto!

In firefox-bin, this works fine for me. Except, I can't turn the video to fullscreen. That's why i tried to configure the plugin with
Code:
./configure --with-gecko-sdk=/emul/linux/x86/usr/lib/gecko-sdk/ --enable-x86_64 --x-libraries=/emul/linux/x86/usr/lib32/ --enable-gtk1

After installing the plugins configured this way, I get the toolbar, and the plugin buffers the video, but then it just stops. Well, I can live without the fullscreen.

Then, I tried the plugin with Opera, but when trying to watch a trailer, the only thing I get is white blank area.

Here's the debugmessage:
Code:

 ~ $ opera -debugplugin
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
opera: [plugin path   ] #001: /opt/opera/lib/opera/plugins
opera: [plugin path   ] #002: /usr/lib64/opera/plug-ins
opera: [plugin path   ] #003: /usr/lib32/nsbrowser/plugins
opera: Search operapluginwrapper: [Ok] /opt/opera/lib/opera/plugins/operapluginwrapper
operapluginwrapper: [plugin probing] /opt/opera/lib/opera/plugins/libnpp.so
opera: plugin detection successful: /opt/opera/lib/opera/plugins/libnpp.so
operapluginwrapper: [plugin probing] /usr/lib64/opera/plug-ins/nppdf.so
opera: plugin detection successful: /usr/lib64/opera/plug-ins/nppdf.so
operapluginwrapper: [plugin probing] /usr/lib64/opera/plug-ins/libflashplayer.so
opera: plugin detection successful: /usr/lib64/opera/plug-ins/libflashplayer.so
operapluginwrapper: [plugin probing] /usr/lib32/nsbrowser/plugins/libflashplayer.so
opera: plugin detection successful: /usr/lib32/nsbrowser/plugins/libflashplayer.so
operapluginwrapper: [plugin probing] /usr/lib32/nsbrowser/plugins/nphelix.so
opera: plugin detection successful: /usr/lib32/nsbrowser/plugins/nphelix.so
operapluginwrapper: [plugin probing] /usr/lib32/nsbrowser/plugins/mplayerplug-in-dvx.so
opera: plugin detection successful: /usr/lib32/nsbrowser/plugins/mplayerplug-in-dvx.so
operapluginwrapper: [plugin probing] /usr/lib32/nsbrowser/plugins/mplayerplug-in-qt.so
opera: plugin detection successful: /usr/lib32/nsbrowser/plugins/mplayerplug-in-qt.so
operapluginwrapper: [plugin probing] /usr/lib32/nsbrowser/plugins/mplayerplug-in-rm.so
opera: plugin detection successful: /usr/lib32/nsbrowser/plugins/mplayerplug-in-rm.so
operapluginwrapper: [plugin probing] /usr/lib32/nsbrowser/plugins/mplayerplug-in-wmp.so
opera: plugin detection successful: /usr/lib32/nsbrowser/plugins/mplayerplug-in-wmp.so
operapluginwrapper: [plugin probing] /usr/lib32/nsbrowser/plugins/mplayerplug-in.so
opera: plugin detection successful: /usr/lib32/nsbrowser/plugins/mplayerplug-in.so
opera: [plugin path   ] #001: /opt/opera/lib/opera/plugins
opera: [plugin path   ] #002: /usr/lib64/opera/plug-ins
opera: [plugin path   ] #003: /usr/lib32/nsbrowser/plugins
opera: Search operapluginwrapper: [Ok] /opt/opera/lib/opera/plugins/operapluginwrapper
/opt/opera/lib/opera/plugins/operapluginwrapper: symbol lookup error: /usr/lib32/nsbrowser/plugins/mplayerplug-in-qt.so: undefined symbol: pthread_create
opera: Plug-in 23054 is not responding. It will be closed.
opera: Define environment variable OPERA_KEEP_BLOCKED_PLUGIN to keep blocked plug-ins.


Any suggestions what to check?
Back to top
View user's profile Send private message
rwf
Apprentice
Apprentice


Joined: 24 Jan 2004
Posts: 234
Location: mi.us

PostPosted: Sat Sep 16, 2006 3:44 pm    Post subject: Reply with quote

Stadard disclaimer: I don't run an AMD64 system -- strictly x86 architecture.

  • The modifications to np_entry.cpp are only needed if you are running Opera 8.54. If you have Opera 9.mumble, then the mods
    Code:

    // if(aNPNFuncs->size < sizeof(NPNetscapeFuncs))
    //   return NPERR_INVALID_FUNCTABLE_ERROR;

    are not needed.


  • Most people have more success w/ mplayerplug-in 3.21 vs newer versions of mplayerplug-in.
  • Some sites just don't work i.e. the video/audio crap at http://news.yahoo.com. They don't work for me with either Opera of Firefox.
  • If you don't get Opera and Mplayerplug-in to work, it's always a good idea to post the url where it doesn't work.
  • Opera gives a lot of debugging information if you set the environment variable OPERA_PLUGINWRAPPER_DEBUG, possible debugging values are 0 to 20. I normally set to 10.
  • --enable-x versus --enable-gtk1 or --enable-gtk2. Opera and mplayerplug-in will not work if enable-{gtk1,gtk2}, if mplayerplug-in is compiled with these options. Clearly firefox needs gtk. This means you need two (2) binaries of mplayerplug-in, one that firefox uses and another that Opera finds.
  • This thread seems to indicate that someone had 'some' success with a gtk enabled version of mplayerplug-in and Opera http://my.opera.com/community/forums/topic.dml?id=154160
  • The above link was posted by somebody on a x86 system, not AMD64. I never bothered to try it out, since I don't think much of mplayerplug-in.
  • The no controls issue. You won't get any controls when mplayerplug-in is compiled with --enable-x. You can try setting the noembedded option in /etc/mplayerplug-in.conf to 1. That way you might be able to use the keyboard to control mplayer (see man mplayer).
  • The undefined symbol: pthread_create issue. I also get the error when using mplayerplug-in version 3.31. pthread_create is in libpthread.so so I preloaded this library (LD_PRELOAD set to /lib/libpthread.so.0). Not sure what's going on, but since I'm in the middle of update to gcc-4.1.1 and glibc-2.4, probably a week to finish emerge -ave system and world, I'm not too concerned.
  • If you use the LD_PRELOAD trick, make sure you load the 32-bit library.
  • You can always get architecture of a .so library by using

Code:

~% objdump -a /lib/libpthread.so.0

/lib/libpthread.so.0:     file format elf32-i386
/lib/libpthread.so.0

~% file -L /lib/libpthread.so.0
/lib/libpthread.so.0: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), for GNU/Linux 2.6.9, not stripped
~%
Back to top
View user's profile Send private message
Disparu
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jun 2006
Posts: 149

PostPosted: Sun Nov 26, 2006 4:27 pm    Post subject: Reply with quote

this guide has really been a day maker and life saver. i thank you soooooo much!!!!
Back to top
View user's profile Send private message
float-
Apprentice
Apprentice


Joined: 31 Aug 2003
Posts: 174

PostPosted: Tue Dec 12, 2006 1:12 am    Post subject: Reply with quote

a little off topic, sorry..
im trying to watch nasa tv in mplayer (-bin).

as http://www.nasa.gov/multimedia/nasatv/live_tv.html
just gave me a screen with buffering 0%, then immediately stops.

i thought this might not be a mplayerplug-in error, so i tried

mplayer-bin rtsp://a1914.l1857058329.c18570.g.lq.akamaistream.net/D/1914/18570/v0001/reflector:52211

but got the following result

Code:

mplayer-bin rtsp://a1914.l1857058329.c18570.g.lq.akamaistream.n
et/D/1914/18570/v0001/reflector:52211
MPlayer 1.0pre8-3.4.5 (C) 2000-2006 MPlayer Team
CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ (Family: 15, Model: 75, Step
ping: 2)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.


93 audio & 211 video codecs
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.

Playing rtsp://a1914.l1857058329.c18570.g.lq.akamaistream.net/D/1914/18570/v0001
/reflector:52211.
STREAM_RTSP, URL: rtsp://a1914.l1857058329.c18570.g.lq.akamaistream.net/D/1914/1
8570/v0001/reflector:52211
Resolving a1914.l1857058329.c18570.g.lq.akamaistream.net for AF_INET6...
Couldn't resolve name for AF_INET6: a1914.l1857058329.c18570.g.lq.akamaistream.n
et
Resolving a1914.l1857058329.c18570.g.lq.akamaistream.net for AF_INET...
Connecting to server a1914.l1857058329.c18570.g.lq.akamaistream.net[213.248.112.
90]: 554...
rtsp_session: Not a Real server. Server type is 'QTSS-Akamai/5.0.2 (Build/452.2.
1; Platform/Linux; Release/Panther; )'.
STREAM_HTTP(2), URL: rtsp://a1914.l1857058329.c18570.g.lq.akamaistream.net/D/191
4/18570/v0001/reflector:52211
Resolving a1914.l1857058329.c18570.g.lq.akamaistream.net for AF_INET6...
Couldn't resolve name for AF_INET6: a1914.l1857058329.c18570.g.lq.akamaistream.n
et
Resolving a1914.l1857058329.c18570.g.lq.akamaistream.net for AF_INET...
Connecting to server a1914.l1857058329.c18570.g.lq.akamaistream.net[213.248.112.
90]: 80...
Server returned 503: error
File not found: 'a1914.l1857058329.c18570.g.lq.akamaistream.net/D/1914/18570/v00
01/reflector:52211'
Failed to open rtsp://a1914.l1857058329.c18570.g.lq.akamaistream.net/D/1914/1857
0/v0001/reflector:52211.


Exiting... (End of file)


anyone who has an idea?
Back to top
View user's profile Send private message
rwf
Apprentice
Apprentice


Joined: 24 Jan 2004
Posts: 234
Location: mi.us

PostPosted: Wed Dec 13, 2006 4:05 am    Post subject: Reply with quote

It played for me using the vlc plugin w/ Opera 9.10-507(.1)

It appears to be an application/x-mplayer2 file type.

Note: I run x86 not AMD 64

Code:

~% emerge -pv vlc

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] media-video/vlc-0.8.6 [0.8.5-r5] USE="X a52 alsa bidi cdda cddb dts dvd flac gnutls httpd live matroska mp3 mpeg ncurses nsplugin ogg opengl png sdl shout stream svga theora vcd vlm vorbis win32codecs wxwindows xml xv -3dfx -aalib (-altivec) -arts -avahi -corba -daap -debug -directfb -dvb -esd -fbcon -ggi -hal -libcaca -libnotify% -lirc -mod -optimisememory -oss -rtsp -samba -seamonkey -skins -speex -svg -truetype -upnp -v4l -xinerama -xosd" 10,268 kB

Total size of downloads: 10,268 kB
~%
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum