Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xgl and compiz window resize problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Zardam
n00b
n00b


Joined: 20 May 2005
Posts: 17

PostPosted: Wed Mar 08, 2006 9:38 am    Post subject: Xgl and compiz window resize problem Reply with quote

Hello,

I managed to get Xgl and compiz working on my system. The main problem that remains is that I can't resize windows more than a certain size (approx 1/3 of the screen). Maximization is also affected by this limit. Windows can start bigger, but as soon as resized, they are bound to this limit.

I'm using an up to date xgl-coffee overlay. My videocard is a mobility radeon 9000, using builtin xorg drivers.

If anyone has an idea on how to fix this? I found nobody with the same problem...
Back to top
View user's profile Send private message
oeser
n00b
n00b


Joined: 22 Mar 2006
Posts: 2

PostPosted: Wed Mar 22, 2006 3:51 pm    Post subject: Same Problem on my iBook Reply with quote

I have installed XGL and gnome using compiz on an Apple iBook G4. It has also an ATI Mobility Radeon card but its an 9200. My opinion is that the problem resides on the window manager compiz since i don't have this problem when starting fluxbox on top of XGL.
Back to top
View user's profile Send private message
Zardam
n00b
n00b


Joined: 20 May 2005
Posts: 17

PostPosted: Wed Mar 22, 2006 4:42 pm    Post subject: Reply with quote

You are certainly right, but it is strange that I cannot find any other report on this problem.

It may be xorg dependant, like xorg not reporting the correct size to an xgl aware window manager.
Back to top
View user's profile Send private message
oeser
n00b
n00b


Joined: 22 Mar 2006
Posts: 2

PostPosted: Wed Mar 22, 2006 5:05 pm    Post subject: Reply with quote

Yes, I thought about it as well. But on the other hand it was strange to me that the Gnome-Panel and the fullscreen mode (tryed it with Epiphany) are working properly. Do they communicate with the WM or directly with the X-Server? I think they don't need an WM but I don't know.
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 555
Location: Halle (Saale), Germany

PostPosted: Tue Apr 11, 2006 4:45 pm    Post subject: Reply with quote

Same Problem here....

I can only maximise the windows to approx. 1/3 of the screen.

Using latest xgl-coffee overlay and I have a Radeon mobility M6 LY

When I starting kdm (ServerCmd=/usr/bin/Xgl -br -kb -ac -accel glx:pbuffer -accel xv) without

Code:
LD_LIBRARY_PATH=/usr/lib/opengl/xorg-x11/lib compiz --replace decoration wobbly fade minimize cube rotate zoom scale move resize place switcher &
sleep 3
gnome-window-decorator &


in /usr/kde/3.5/share/config/kdm/Xstartup

I have no Windows Decoration, but the applications (for example opera) are maximised to fullscreen.

Any ideas yet?

regards
blubbi
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2665
Location: Slovenia

PostPosted: Tue Apr 11, 2006 6:27 pm    Post subject: Reply with quote

You all seem to have something in common: mobile graphic cards. Do they by any chance share their RAM with the rest of the system? If yes, it's very much possible that these cards simply don't have enough RAM.
Back to top
View user's profile Send private message
Zardam
n00b
n00b


Joined: 20 May 2005
Posts: 17

PostPosted: Wed Apr 12, 2006 9:03 am    Post subject: Reply with quote

I emerged the latest xgl-cofee last day and now it works perfectly.
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 555
Location: Halle (Saale), Germany

PostPosted: Wed Apr 12, 2006 10:32 am    Post subject: Reply with quote

Could you please paste the version of xgl, compiz etc you are using?
Back to top
View user's profile Send private message
Zardam
n00b
n00b


Joined: 20 May 2005
Posts: 17

PostPosted: Wed Apr 12, 2006 11:28 am    Post subject: Reply with quote

xgl : 0.0.1_p20060410
compiz-vanilla : 0.0.9_p20060410

All the packages comes from xgl-coffee overlay, revision 127, and modular xorg from gentoo offical ebuilds

I'm also using xorg radeon driver.
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 555
Location: Halle (Saale), Germany

PostPosted: Fri Apr 14, 2006 9:43 am    Post subject: Reply with quote

Thanks,

right now I am compiling compiz-vanilla and new version of xgl from overlay version 235.

Bevore I used compiz not compiz-vanilla ebuild, lets see what differenze that makes.

regargs
blubbi
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum