Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Erro ao tentar instalar xmms e outros programas <Resolvido>
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
oompawampa
Apprentice
Apprentice


Joined: 21 Sep 2005
Posts: 183
Location: São Paulo - Brasil

PostPosted: Tue Mar 28, 2006 4:40 pm    Post subject: Erro ao tentar instalar xmms e outros programas <Resolvid Reply with quote

Estou utilizando o gentoo x86_64 2006.0

Ao tentar instalar o xmms ocorre o erro abaixo, o que poderia ser???




* Done with patching
You should update your `aclocal.m4' by running aclocal.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = "pt_BR",
LANG = "pt_BR"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
/var/tmp/portage/xmms-1.2.10-r15/work/m4/xmms_local.m4:7: warning: underquoted definition of AM_PATH_LIBXML
run info '(automake)Extending aclocal'
or see http://sources.redhat.com/automake/automake.html#Extending-aclocal
/var/tmp/portage/xmms-1.2.10-r15/work/m4/xmms_local.m4:157: warning: underquoted definition of XMMS_FUNC_POSIX
/var/tmp/portage/xmms-1.2.10-r15/work/m4/libmikmod.m4:11: warning: underquoted definition of AM_PATH_LIBMIKMOD
/usr/share/aclocal/ao.m4:9: warning: underquoted definition of XIPH_PATH_AO
aclocal:configure.in:67: warning: macro `AM_PATH_GLIB' not found in library
aclocal:configure.in:68: warning: macro `AM_PATH_GTK' not found in library
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = "pt_BR",
LANG = "pt_BR"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = "pt_BR",
LANG = "pt_BR"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
autoheader-2.59: WARNING: Using auxiliary files such as `acconfig.h', `config.h.bot'
autoheader-2.59: WARNING: and `config.h.top', to define templates for `config.h.in'
autoheader-2.59: WARNING: is deprecated and discouraged.
autoheader-2.59:
autoheader-2.59: WARNING: Using the third argument of `AC_DEFINE' and
autoheader-2.59: WARNING: `AC_DEFINE_UNQUOTED' allows to define a template without
autoheader-2.59: WARNING: `acconfig.h':
autoheader-2.59:
autoheader-2.59: WARNING: AC_DEFINE([NEED_FUNC_MAIN], 1,
autoheader-2.59: [Define if a function `main' is needed.])
autoheader-2.59:
autoheader-2.59: WARNING: More sophisticated templates can also be produced, see the
autoheader-2.59: WARNING: documentation.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = "pt_BR",
LANG = "pt_BR"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = "pt_BR",
LANG = "pt_BR"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
configure.in:67: error: possibly undefined macro: AM_PATH_GLIB
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
configure.in:68: error: possibly undefined macro: AM_PATH_GTK

!!! ERROR: media-sound/xmms-1.2.10-r15 failed.
!!! Function src_unpack, Line 82, Exitcode 1
!!! autoconf failed
!!! If you need support, post the topmost build error, NOT this status message.
_________________
*Meu micro * Mobo Gigabyte GA8165GME Processador Pentium D 945 S775 3.4Ghz 1024Mb Dual Channel DDR 3200 2x HD Pata 80Gb Samsung VGA Ati 8550 DVDRW LG 4163 (Gentoo 2006.1 x86)


Last edited by oompawampa on Fri Mar 31, 2006 2:31 pm; edited 1 time in total
Back to top
View user's profile Send private message
MetalGod
Bodhisattva
Bodhisattva


Joined: 10 Mar 2003
Posts: 816
Location: Portugal

PostPosted: Tue Mar 28, 2006 8:57 pm    Post subject: Reply with quote

coloca aqui o teu emerge info e tira as LINGUAS="pt_BR"
_________________
ex: Gentoo Linux Developer: amd64 media-optical sound gnome
ex: Portuguese Moderator
------------------------------------------------------------------------------
God Doesn't Play Dice
Back to top
View user's profile Send private message
oompawampa
Apprentice
Apprentice


Joined: 21 Sep 2005
Posts: 183
Location: São Paulo - Brasil

PostPosted: Wed Mar 29, 2006 9:48 pm    Post subject: Reply with quote

Ai esta:

Hamster ~ # emerge info
Portage 2.0.54 (default-linux/amd64/2006.0, gcc-3.4.4, glibc-2.3.5-r2, 2.6.15-gentoo-r5 x86_64)
=================================================================
System uname: 2.6.15-gentoo-r5 x86_64 Intel(R) Pentium(R) 4 CPU 3.00GHz
Gentoo Base System version 1.6.14
dev-lang/python: 2.4.2
sys-apps/sandbox: 1.2.12
sys-devel/autoconf: 2.13, 2.59-r6
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils: 2.16.1
sys-devel/libtool: 1.5.22
virtual/os-headers: 2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib64/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="pt_BR"
LC_ALL="pt_BR"
LINGUAS="pt_BR"
MAKEOPTS="-j3"
PKGDIR="/mnt/cdrom"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 X alsa apache2 audiofile avi berkdb bitmap-fonts bzip2 cdr cdrw cli crypt ctype cups curl dba dri dvdrw eds emboss encode esd exif expat fam fastbuild ffmpeg foomaticdb force-cgi-redirect fortran ftp gd gif glut gnome gpm gstreamer gtk gtk2 gtkhtml hal how idn imlib ipv6 jpeg kde lcms lzw lzw-tiff mad memlimit mng mozilla mp3 mpeg ncurses nls nptl opengl pam pcre pdflib perl png posix python qt quicktime readline sdl session simplexml soap sockets spell spl sse3 ssl tcpd tiff tokenizer truetype truetype-fonts type1-fonts udev usb xml xml2 xmms xpm xsl xv zlib linguas_pt_BR userland_GNU kernel_linux elibc_glibc"
Unset: ASFLAGS, CTARGET, LDFLAGS, PORTDIR_OVERLAY
_________________
*Meu micro * Mobo Gigabyte GA8165GME Processador Pentium D 945 S775 3.4Ghz 1024Mb Dual Channel DDR 3200 2x HD Pata 80Gb Samsung VGA Ati 8550 DVDRW LG 4163 (Gentoo 2006.1 x86)
Back to top
View user's profile Send private message
MetalGod
Bodhisattva
Bodhisattva


Joined: 10 Mar 2003
Posts: 816
Location: Portugal

PostPosted: Thu Mar 30, 2006 3:21 am    Post subject: Reply with quote

ja fizeste o que eu recomendei ?
ja agora olhando para o teu emerge info as tuas CFLAGS estao erradas e' -02 e nao -O2 :wink:
_________________
ex: Gentoo Linux Developer: amd64 media-optical sound gnome
ex: Portuguese Moderator
------------------------------------------------------------------------------
God Doesn't Play Dice
Back to top
View user's profile Send private message
oompawampa
Apprentice
Apprentice


Joined: 21 Sep 2005
Posts: 183
Location: São Paulo - Brasil

PostPosted: Thu Mar 30, 2006 11:43 am    Post subject: Reply with quote

Sim, removi o LANG="pt_BR" LC_ALL="pt_BR" e o LINGUAS="pt_BR" mas só não ocorre mais o erro do perl, mas mesmo assim não compila o xmms e nem outros aplicativos.
No caso da CFLAGS, terei que recompilar o sistema todo devido a este erro, ou não?
_________________
*Meu micro * Mobo Gigabyte GA8165GME Processador Pentium D 945 S775 3.4Ghz 1024Mb Dual Channel DDR 3200 2x HD Pata 80Gb Samsung VGA Ati 8550 DVDRW LG 4163 (Gentoo 2006.1 x86)
Back to top
View user's profile Send private message
MetalGod
Bodhisattva
Bodhisattva


Joined: 10 Mar 2003
Posts: 816
Location: Portugal

PostPosted: Thu Mar 30, 2006 11:47 am    Post subject: Reply with quote

esse erro e' gravissimo eu aconselhava a isso.
_________________
ex: Gentoo Linux Developer: amd64 media-optical sound gnome
ex: Portuguese Moderator
------------------------------------------------------------------------------
God Doesn't Play Dice
Back to top
View user's profile Send private message
oompawampa
Apprentice
Apprentice


Joined: 21 Sep 2005
Posts: 183
Location: São Paulo - Brasil

PostPosted: Thu Mar 30, 2006 12:34 pm    Post subject: Reply with quote

Vou instalar tudo novamente então, fui instalar meio as pressas e saiu meio as coxas!!!
Vou aproveitar somente os pacotes que estão no /usr/portage/distfiles e os arquivos de configuração (claro vou corrigir o make.conf)

Mas muito obrigado!!!
_________________
*Meu micro * Mobo Gigabyte GA8165GME Processador Pentium D 945 S775 3.4Ghz 1024Mb Dual Channel DDR 3200 2x HD Pata 80Gb Samsung VGA Ati 8550 DVDRW LG 4163 (Gentoo 2006.1 x86)
Back to top
View user's profile Send private message
oompawampa
Apprentice
Apprentice


Joined: 21 Sep 2005
Posts: 183
Location: São Paulo - Brasil

PostPosted: Fri Mar 31, 2006 2:31 pm    Post subject: Reply with quote

:lol: Instalei tudo de novo e funcionou tks!!!


PS >> Eram problemas no make.conf mesmo mas o cxfkags é O2 (letra O maiuscula) mesmo e não 02 (numero 0)
_________________
*Meu micro * Mobo Gigabyte GA8165GME Processador Pentium D 945 S775 3.4Ghz 1024Mb Dual Channel DDR 3200 2x HD Pata 80Gb Samsung VGA Ati 8550 DVDRW LG 4163 (Gentoo 2006.1 x86)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum