Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Probleem met installatie alsa-driver
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
ThaFusion
n00b
n00b


Joined: 26 Mar 2006
Posts: 7

PostPosted: Sun Mar 26, 2006 4:16 pm    Post subject: Probleem met installatie alsa-driver Reply with quote

Hey,
Ik heb een (waarschijnlijk simpele) vraag.
Ik probeer de alsa-driver te installeren om ervoor te zorgen dat mijn geluidskaart werkt. Ik heb de documentatie op deze pagina proberen te volgen:

http://www.gentoo.org/doc/en/alsa-guide.xml

Er zijn 2 opties:
1 Use ALSA provided by your kernel. This is the preferred/recommended method.
2 Use Gentoo's media-sound/alsa-driver package.

Bij de eerste optie loop ik op punt 2.2 vast:
# cd /usr/src/linux
# make menuconfig

Er bestaat bij mij geen /usr/src/linux, user/src is zelfs leeg.

emerge alsa-driver geeft ook een probleem met deze dir:

* Determining the location of the kernel source code
* Found kernel source directory:
* /usr/src/linux
* Could not find a usable .config in the kernel source directory.
* Please ensure that /usr/src/linux points to a configured set of Linux sources .
* If you are using KBUILD_OUTPUT, please set the environment var so that
* it points to the necessary object directory so that it might find .config.

Zou hier dan niet de kernel source moeten staan? Of is dat niet het geval omdat ik een stage 3 installatie heb gedaan? En wat is dan de oplossing?
Ik doe alles via root...

Alvast bedankt!

P.S. Sorry, maar weet nog erg weinig. Heb gentoo gisteren geinstalleerd na een paar maanden ubuntu te hebben geprobeerd op de desktop.
Back to top
View user's profile Send private message
houtworm
Apprentice
Apprentice


Joined: 08 Mar 2003
Posts: 284
Location: Den Haag, Netherlands

PostPosted: Sun Mar 26, 2006 4:57 pm    Post subject: Re: Probleem met installatie alsa-driver Reply with quote

ThaFusion wrote:
Er bestaat bij mij geen /usr/src/linux, user/src is zelfs leeg.

Haal dan eerst een kernel source op
Je kunt zien welke kernel je nu gebruikt:
#uname -r
bij mij is dat:
2.6.15-gentoo-r7
(niet de nieuwste :) )
voeg de USE flag "symlink" toe in make.conf, dan wordt /usr/src/linux aangepast.
Code:
emerge gentoo-sources

Nu kan je wel naar /usr/src/linux gaan en werkt make menuconfig
Ik weet even niet wat je er moet instellen voor de geluidskaart.
Ik heb soundcard support wel aangevinkt, maar ALSA niet (jouw 2e optie dus :) )
De rest van de kernel instellingen moet je zelf nakijken :-) vergeet vooral de file systems niet.
compileren gaat als volgt: make bzImage modules modules_install
Nu staat er in /usr/linux/arch/<processor..>/boot een bestand bzImage, dat is de kernel
Die moet je naar/boot kopieren en aan de bootmanager toevoegen. Laat de oude kernel staan want daar kan je altijd nog mee opstarten als het misgaat.
Als je de tweede optie hebt gekozen, dan moet je daarna ook de alsa-drivers nog emergen en dan moet de gluidskaart werken.
_________________
niemand is onbekwamer, dan een timmerman zonder hamer

Kees
Back to top
View user's profile Send private message
fragske
n00b
n00b


Joined: 07 Feb 2006
Posts: 14

PostPosted: Thu Apr 20, 2006 12:29 pm    Post subject: Reply with quote

Ik heb een probleempje met mijn geluid
Het werkt namelijk alleen niet onder KDE
Amarok, xine enz werkt allemaal wel maar in KDE werkt het dus niet
Eerst kon ik ook bv geen sound device selecteren in het control center, maar na dat ik arts had geëmerged
had ik wel deze keuze.
Maar zelfs als ik het zet op ALSA of OSS of zo dan hoor ik nog steeds niets
Nu op zich vind ik dat niet zon probleem want ik moet geen geluidjes horen in KDE zelf, maar ik zou toch graag geluid bij flashfilmpjes willen horen bij bv firefox

Iemand die nog dit probleem had/heeft ?

Moet ik bv nog enkele arts-plugins best installeren of zo?

Ik heb al verscheidene dingen geprobeerd maar nu ben ik wel radeloos

btw ik heb een shuttle SN25P ( das met onboard sound )
Back to top
View user's profile Send private message
Q-collective
Advocate
Advocate


Joined: 22 Mar 2004
Posts: 2056

PostPosted: Thu Apr 20, 2006 5:56 pm    Post subject: Reply with quote

Je kunt het beste arts uitzetten en de systeemgeluiden laten uitvoeren door een externe player, alsa-player ofzo, kun je in kcontrol configureren.
Arts zuigt, ben blij dat het in KDE4 verdwijnt :roll:
Back to top
View user's profile Send private message
fragske
n00b
n00b


Joined: 07 Feb 2006
Posts: 14

PostPosted: Fri Apr 21, 2006 6:38 am    Post subject: Reply with quote

Dat was het net, ik kon bv geen externe player selecteren omdat ik arts niet geïnstalleerd had :)
Ma goed, ik zal straks thuis nog eens verder prutsen en is proberen met die alsa-player
Back to top
View user's profile Send private message
bushvin
Tux's lil' helper
Tux's lil' helper


Joined: 20 Feb 2004
Posts: 142
Location: Leuven, Belgium

PostPosted: Wed Apr 26, 2006 8:07 am    Post subject: Reply with quote

Kijk eens metr welke USE flags uw kdemultimedia ge-emerged is?
Code:
maul ~ # emerge -pv kdemultimedia
[ebuild   R   ] kde-base/kdemultimedia-3.4.3  +alsa +arts +audiofile -debug +encode +flac +gstreamer -jack -kdeenablefinal +mp3 -musicbrainz -speex -theora +vorbis +xine +xinerama 5,366 kB

alsa is nodig als USE flag als ge geluid wilt in KDE (of welke DE dan ook)
_________________
"Don't be too proud of this technological terror you've constructed. The ability to destroy a planet is insignificant next to the power of the Force." - Lord Vader
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum