Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to mount hard disk with Russian filenames? [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
mprzybyla
n00b
n00b


Joined: 07 Aug 2005
Posts: 15

PostPosted: Sun Mar 26, 2006 1:36 pm    Post subject: How to mount hard disk with Russian filenames? [SOLVED] Reply with quote

Hi,
I've got a harddisk with Russian named files copied onto it on a Windows machine.

I tried to mount it:
Code:
mount -o codepage=866,iocharset=cp1251,utf8 /dev/sda1 /mnt/usb

Also tried codepage 855 and iocharsets iso-8865-5 and koi8-r. Every time filenames are either "?????" or garbage.


Please help


regards
m


Last edited by mprzybyla on Mon Mar 27, 2006 12:54 pm; edited 1 time in total
Back to top
View user's profile Send private message
sa10
Apprentice
Apprentice


Joined: 20 Jan 2005
Posts: 251
Location: Minsk

PostPosted: Mon Mar 27, 2006 7:04 am    Post subject: Reply with quote

Check up you system:
Code:
locale -a|grep ru
ru
ru_RU
ru_RU.cp1251
ru_RU.cp866
ru_RU.koi8
ru_RU.koi8r
ru_RU.utf8


Code:
locale
LANG=ru_RU.UTF-8
LC_CTYPE="ru_RU.UTF-8"
LC_NUMERIC="ru_RU.UTF-8"
LC_TIME="ru_RU.UTF-8"
LC_COLLATE="ru_RU.UTF-8"
LC_MONETARY="ru_RU.UTF-8"
LC_MESSAGES="ru_RU.UTF-8"
LC_PAPER="ru_RU.UTF-8"
LC_NAME="ru_RU.UTF-8"
LC_ADDRESS="ru_RU.UTF-8"
LC_TELEPHONE="ru_RU.UTF-8"
LC_MEASUREMENT="ru_RU.UTF-8"
LC_IDENTIFICATION="ru_RU.UTF-8"
LC_ALL=


Code:
zgrep utf8 /proc/config.gz
CONFIG_FAT_DEFAULT_IOCHARSET="utf8"
CONFIG_NLS_DEFAULT="utf8"


and...

Code:
fat32
mount -o codepage=866,iocharset=utf8 /dev/sda1 /mnt/usb
NTFS
mount -o nls=utf8 /dev/sda1 /mnt/usb
Back to top
View user's profile Send private message
mprzybyla
n00b
n00b


Joined: 07 Aug 2005
Posts: 15

PostPosted: Mon Mar 27, 2006 7:54 am    Post subject: Reply with quote

Thanx, I'll try.
Back to top
View user's profile Send private message
mprzybyla
n00b
n00b


Joined: 07 Aug 2005
Posts: 15

PostPosted: Mon Mar 27, 2006 12:53 pm    Post subject: Reply with quote

got it working, thanks sa10 ;)

Locale were ok, I've recompiled kernel - was not enough... I had to enable UNICODE in /etc/rc.conf. Now it's fine.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum