Joined: 12 May 2004
|Posted: Wed Mar 22, 2006 11:26 pm Post subject: [ GLSA 200603-22 ] PHP: Format string and XSS vulnerabilitie
|Gentoo Linux Security Advisory
Title: PHP: Format string and XSS vulnerabilities (GLSA 200603-22)
Date: March 22, 2006
Multiple vulnerabilities in PHP allow remote attackers to inject arbitrary HTTP headers, perform cross site scripting or in some cases execute arbitrary code.
PHP is a general-purpose scripting language widely used to develop web-based applications. It can run on a web server with the mod_php module or the CGI version and also stand-alone in a CLI.
Vulnerable: < 4.4.2
Vulnerable: >= 5.1.1 < 5.1.2
Vulnerable: >= 5.0.5 < 5.0.6
Vulnerable: >= 5.0.4 < 5.0.5
Unaffected: >= 5.1.2
Architectures: All supported architectures
Stefan Esser of the Hardened PHP project has reported a few vulnerabilities found in PHP:
- Input passed to the session ID in the session extension isn't properly sanitised before being returned to the user via a "Set-Cookie" HTTP header, which can contain arbitrary injected data.
- A format string error while processing error messages using the mysqli extension in version 5.1 and above.
By sending a specially crafted request, a remote attacker can exploit this vulnerability to inject arbitrary HTTP headers, which will be included in the response sent to the user. The format string vulnerability may be exploited to execute arbitrary code.
There is no known workaround at this time.
All PHP 5.x users should upgrade to the latest version:
All PHP 4.x users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/php-5.1.2"
|# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/php-4.4.2"
Hardened-PHP Advisory 01/2006
Hardened-PHP Advisory 02/2006
Last edited by GLSA on Sun May 07, 2006 5:00 pm; edited 1 time in total