Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with keyboard
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
drillsar
n00b
n00b


Joined: 08 Sep 2010
Posts: 33

PostPosted: Fri Sep 10, 2010 2:23 pm    Post subject: Problem with keyboard Reply with quote

I got no keyboard at all, when I hit ctrl>alt>bksp nothing so I have to actually turn off computer:

this is what I did:

cp /usr/share/hal/fdi/policy/10osvendor/10-input-policy.fdi /etc/hal/fdi/policy
cp /usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi /etc/hal/fdi/policy


nano -w /etc/hal/fdi/policy/10-x11-input.fdi

added this line to input.keys
<merge key="input.xkb.options" type="string">terminate:ctrl_alt_bksp</merge>

/etc/init.d/hal restart

Xorg -configure

X -retro -config /root/xorg.conf.new

my keyboard don't work

in the xorg.conf Keyboard driver is kbd should this be changed to evdev?

I changed the mouse driver to evdev still no mouse
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7564
Location: Goose Creek SC

PostPosted: Fri Sep 10, 2010 3:07 pm    Post subject: Reply with quote

Need more info, pls run
Code:
emerge wgetpaste
emerge --info | wgetpaste
rc-update show | wgetpaste
lspci -k | wgetpaste
wgetpaste -s ca /usr/src/linux/.config

and post the url's returned.

If you have not emerged display manager/window manager/desktop please do so.
ensure /etc/env.d/90xsession contains
Quote:

XSESSION=Gnome

substitute your choice for Gnome
ensure /etc/rc.conf contains
Quote:
XSESSION="Gnome"

substitute your choice for Gnome
ensure /etc/conf.d contains
Quote:
DISPLAYMANAGER="xdm"

substitute your choice for xdm

Useful guides:
Quote:

http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-1.5-upgrade-guide.xml
http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-1.6-upgrade-guide.xml
http://www.gentoo.org/doc/en/xorg-config.xml
http://www.gentoo.org/proj/en/desktop/x/x11/libxcb-1.4-upgrade-guide.xml
If using xorg-server-1.8 or newer
http://dev.gentoo.org/~scarabeus/xorg-server-1.8-upgrade-guide.xml
If using openrc/baselayout2:
http://www.gentoo.org/doc/en/openrc-migration.xml


Last edited by DONAHUE on Fri Sep 10, 2010 4:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7564
Location: Goose Creek SC

PostPosted: Fri Sep 10, 2010 3:27 pm    Post subject: Reply with quote

Need more info, pls run
Code:
emerge wgetpaste
emerge --info | wgetpaste
rc-update show | wgetpaste
lspci -k | wgetpaste
wgetpaste -s ca /usr/src/linux/.config

and post the url's returned.

If you have not emerged display manager/window manager/desktop please do so.
ensure /etc/env.d/90xsession contains
Quote:
XSESSION=Gnome

substitute your choice for Gnome
ensure /etc/rc.conf contains
Quote:
XSESSION="Gnome"

substitute your choice for Gnome
ensure /etc/conf.d contains
Quote:
DISPLAYMANAGER="xdm"

substitute your choice for xdm

Useful guides:
Quote:
http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-1.5-upgrade-guide.xml
http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-1.6-upgrade-guide.xml
http://www.gentoo.org/doc/en/xorg-config.xml
http://www.gentoo.org/proj/en/desktop/x/x11/libxcb-1.4-upgrade-guide.xml
If using xorg-server-1.8 or newer
http://dev.gentoo.org/~scarabeus/xorg-server-1.8-upgrade-guide.xml
If using openrc/baselayout2:
http://www.gentoo.org/doc/en/openrc-migration.xml
Back to top
View user's profile Send private message
drillsar
n00b
n00b


Joined: 08 Sep 2010
Posts: 33

PostPosted: Fri Sep 10, 2010 3:37 pm    Post subject: Reply with quote

by the way the keyboard is a Microsoft wireless keyboard

Display manager ="kdm"

Ok here is the url's

emerge --info | wgetpaste results:

http://paste.pocoo.org/show/260342

rc-update show | wgetpaste results:

http://paste.pocoo.org/show/260343

lspci -k | wgetpaste results

http://paste.pocoo.org/show/260344

Kernel Configuration results:

http://pastebin.ca/1937346
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7197

PostPosted: Fri Sep 10, 2010 3:53 pm    Post subject: Reply with quote

Here's a hint to help you find your solve.

/etc/init.d/kdm start & sleep 30 && /etc/init.d/kdm stop

start kdm, wait 30s, stop kdm
Good if you don't have a keyboard/mouse to switch back to the console or stop kdm, and you're bore to reboot at every try
Back to top
View user's profile Send private message
drillsar
n00b
n00b


Joined: 08 Sep 2010
Posts: 33

PostPosted: Fri Sep 10, 2010 4:05 pm    Post subject: Reply with quote

did you mean xdm? I don't have kdm in rc-update, anyway it seems my keyboard works now but didnt work in Xorg so maybe a bug?

But now it seems I need fonts because all I see is boxes, lol so shouldnt have installed the minimum? Im confused, sorry im new
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7564
Location: Goose Creek SC

PostPosted: Fri Sep 10, 2010 4:33 pm    Post subject: Reply with quote

To clarify:
you ran (in a CLI terminal):
Code:
etc/init.d/xdm start & sleep 30 && /etc/init.d/xdm stop

and for 30 secs you were in a kdm GUI with keyboard working but producing gibberish characters? Did you have mouse?

Quote:
If you want <CTRL ALT BACKSPACE> to be able to shutdown X:
If you don't have /etc/hal/fdi/policy/10-keymap.fdi:
run:
'cp /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi /etc/hal/fdi/policy/10-keymap.fdi'

open /etc/hal/fdi/policy/10-keymap.fdi and add as the last <merge key:
'<merge key="input.xkb.options" type="string">grp:alt_shift_toggle,terminate:ctrl_alt_bksp</merge>'

here the modified /etc/hal/fdi/policy/10-keymap.fdi looks like:
<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
<device>
<match key="info.capabilities" contains="input.keymap">
<append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
</match>

<match key="info.capabilities" contains="input.keys">
<merge key="input.xkb.rules" type="string">base</merge>

<!-- If we're using Linux, we use evdev by default (falling back to
keyboard otherwise). -->
<merge key="input.xkb.model" type="string">keyboard</merge>
<match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
string="Linux">
<merge key="input.xkb.model" type="string">evdev</merge>
</match>

<merge key="input.xkb.layout" type="string">us</merge>
<merge key="input.xkb.variant" type="string" />
<merge key="input.xkb.options" type="string">terminate:ctrl_alt_bksp</merge>
</match>
</device>
</deviceinfo>


What happens now if you run startx in the terminal?

What happens now if you run X -retro in the terminal?

Have you done anything with languages, locales, keymaps or just let the defaults happen?


Last edited by DONAHUE on Fri Sep 10, 2010 5:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
drillsar
n00b
n00b


Joined: 08 Sep 2010
Posts: 33

PostPosted: Fri Sep 10, 2010 4:58 pm    Post subject: Reply with quote

When i type in startx

I get a blue screen and nothing on it, able to use mouse but it seems ctrl alt bcksp not working I right clicked mouse and had a logout so i clicked that.

/etc/init.d/xdm brings up login box

by the way im in root, maybe i should try it in user?

X -retro -config xorg.conf.new I get a black screen with a mouse able to use mouse not keyboard
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7564
Location: Goose Creek SC

PostPosted: Fri Sep 10, 2010 5:16 pm    Post subject: Reply with quote

see the edit above for ctrl-alt-bkspce.
Quote:
X -retro -config xorg.conf.new I get a black screen with a mouse able to use mouse not keyboard
So the xorg-server is working.

Quote:
When i type in startx
I get a blue screen and nothing on it
right color for kdm

Quote:
etc/init.d/xdm brings up login box
can you login? and what happens?

kde guide

Quote:
by the way im in root, maybe i should try it in user?
I believe in staying root until up and running (should eliminate permissions as problem source) then trying as user.
Back to top
View user's profile Send private message
drillsar
n00b
n00b


Joined: 08 Sep 2010
Posts: 33

PostPosted: Fri Sep 10, 2010 5:45 pm    Post subject: Reply with quote

Ok I figuredd it out, I have to add widgets, Im used to other kde with menu, etc.

Thanks for all your help, I will add that ctrl > Alt > Bksp

Im getting somewhere now.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum