Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
The module has not been deployed. (netbeans-5.5-r6)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Almucard
n00b
n00b


Joined: 23 Jul 2005
Posts: 27

PostPosted: Fri Jun 22, 2007 9:57 pm    Post subject: The module has not been deployed. (netbeans-5.5-r6) Reply with quote

I emerged new version of netbeans from portage (netbeans-5.5-r6)..
After this i can't run all my java (servlet) projects:

Code:

/home/andrzej/html/net/home/nbproject/build-impl.xml:440: Deployment error:
The module has not been deployed.
See the server log for details.


~/.netbeans/5.5/var/log/messages.log (part):
Code:

...
[org.netbeans.modules.tomcat5] INFORMATIONAL *********** Exception occurred ************ at 11:57 PM on Jun 22, 2007
java.io.IOException: Server returned HTTP response code: 400 for URL: http://localhost:8080/manager/list
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
        at sun.net.www.protocol.http.HttpURLConnection$6.run(HttpURLConnection.java:1298)
        at java.security.AccessController.doPrivileged(Native Method)
        at sun.net.www.protocol.http.HttpURLConnection.getChainedException(HttpURLConnection.java:1292)
        at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:948)
[catch] at org.netbeans.modules.tomcat5.TomcatManagerImpl.run(TomcatManagerImpl.java:559)
        at org.netbeans.modules.tomcat5.TomcatManagerImpl.list(TomcatManagerImpl.java:364)
        at org.netbeans.modules.tomcat5.TomcatManager.modules(TomcatManager.java:596)
        at org.netbeans.modules.tomcat5.TomcatManager.getAvailableModules(TomcatManager.java:405)
        at org.netbeans.modules.tomcat5.ide.TMIDResolver.lookupTargetModuleID(TMIDResolver.java:54)
        at org.netbeans.modules.j2ee.deployment.impl.TargetServer.checkUndeployForSharedReferences(TargetServer.java:230)
        at org.netbeans.modules.j2ee.deployment.impl.TargetServer.checkUndeployForSharedReferences(TargetServer.java:203)
        at org.netbeans.modules.j2ee.deployment.impl.TargetServer.checkUndeployForSharedReferences(TargetServer.java:200)
        at org.netbeans.modules.j2ee.deployment.impl.TargetServer.processLastTargetModules(TargetServer.java:320)
        at org.netbeans.modules.j2ee.deployment.impl.TargetServer.init(TargetServer.java:108)
        at org.netbeans.modules.j2ee.deployment.impl.TargetServer.deploy(TargetServer.java:445)
        at org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy(Deployment.java:106)
        at org.netbeans.modules.j2ee.ant.Deploy.execute(Deploy.java:82)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
        at sun.reflect.GeneratedMethodAccessor78.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
        at org.apache.tools.ant.Task.perform(Task.java:348)
        at org.apache.tools.ant.Target.execute(Target.java:357)
        at org.apache.tools.ant.Target.performTasks(Target.java:385)
        at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
        at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
        at org.apache.tools.ant.module.bridge.impl.BridgeImpl.run(BridgeImpl.java:240)
        at org.apache.tools.ant.module.run.TargetExecutor.run(TargetExecutor.java:293)
        at org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:131)
Caused by: java.io.IOException: Server returned HTTP response code: 400 for URL: http://localhost:8080/manager/list
        at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1245)
        at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:373)
        at org.netbeans.modules.tomcat5.TomcatManagerImpl.run(TomcatManagerImpl.java:526)
        ... 27 more
...


Please help...
_________________
Hellsing...
Back to top
View user's profile Send private message
alistair
Retired Dev
Retired Dev


Joined: 15 Jul 2005
Posts: 869

PostPosted: Fri Jun 22, 2007 11:12 pm    Post subject: Reply with quote

what version of tomcat do you have installed? is it a gentoo package or external?

What happens if you browse to tomcats manager manually?
_________________
______________
Help the gentoo-java project. Visit Gentoo Java Project

what good are admin powers if you don't abuse them for personal gain - mark_alec
Back to top
View user's profile Send private message
Almucard
n00b
n00b


Joined: 23 Jul 2005
Posts: 27

PostPosted: Sat Jun 23, 2007 9:03 am    Post subject: Reply with quote

alistair wrote:

what version of tomcat do you have installed?


I have both tomcat-5.5.23-r6 and tomcat-6.0.13-r3, but with netbeans i use tomcat-5.5

alistair wrote:

is it a gentoo package or external?


It is emerged from portage so i guess gentoo package (what do you mean external?)

alistair wrote:

What happens if you browse to tomcats manager manually?


It just works..


This is strange:


When i started server manually (with /etc/init.d/tomcat-5.5 script) it works.
I can run projects with netbeans...

But when i shutdown server netbeans starts it at his own:
Code:

Starting server Tomcat 5.5
Waiting for Tomcat...
Tomcat server started.

and i get "Deployment error"...

So the solution seems to be to turn on server before run but when
i again started server manually nothing changed.

With
Code:

/etc/init.d/tomcat-5.5 status
 * status:  started


Netbeans still turn on server at his own
Code:

Starting server Tomcat 5.5
Waiting for Tomcat...
Tomcat server started.

like it didn't notice it is already running... (and deployment error occurs)

Is there any way to tell netbeans that server is running and just to use it?

Why when netbeans starts tomcat at his own it didn't work?
_________________
Hellsing...
Back to top
View user's profile Send private message
alexbuell
Guru
Guru


Joined: 18 Jul 2002
Posts: 482
Location: "Hemp"shire, UK

PostPosted: Sat Jun 23, 2007 10:27 pm    Post subject: webapps not deploying from NetBean to Tomcat Reply with quote

I've got the exact same problem as the previous poster. webapps do fail to be deployed from within NetBeans. Did anyone ever figure this out yet?
_________________
Cheers,
Alex.

Linux - the best text adventure game ever.
Back to top
View user's profile Send private message
Almucard
n00b
n00b


Joined: 23 Jul 2005
Posts: 27

PostPosted: Thu Jun 28, 2007 12:44 pm    Post subject: Reply with quote

For now i start sever (tomcat) manually after boot and it works...

When it is starting at boot i can't run my projects (btw. it is starting fine -localhost:8080 works)

I am waiting for another solution...
Help please..
_________________
Hellsing...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum