Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pam-login blocks shadow
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
bdgenz
n00b
n00b


Joined: 28 Oct 2006
Posts: 13
Location: TX, US

PostPosted: Wed Nov 01, 2006 10:16 pm    Post subject: Reply with quote

amne wrote:
Merged bdgenz' post here.

bdgenz - please take a look at the posts in this thread - shadow and pam-login block each other because pam-login was merged into shadow iirc. So unless you still have problems logging a second session (don't close the old one yet ;) ) in right now, things should be fine.


Thanks for the tip,

I should have been able to log into a second session w/only shadow but couldn't. Did emerge -C pam-login && emerge -1 shadow without any luck.

auth.log snippet

Nov 1 14:05:04 home sshd[6111]: error: ssh_rsa_sign: EVP_get_digestbynid 64 failed
Nov 1 14:05:04 home sshd[6111]: fatal: mm_answer_sign: key_sign failed

Tryed logging in as unprived user w/same result.

I'll go thru the thread looking for clues.

Nerve-wracking to say the least.
Back to top
View user's profile Send private message
amne
Bodhisattva
Bodhisattva


Joined: 17 Nov 2002
Posts: 6378
Location: Graz / EU

PostPosted: Wed Nov 01, 2006 10:19 pm    Post subject: Reply with quote

Did you run etc-update/dispatch-conf?

edit: Seems this is a different issue in the first place: Openssh:ssh_rsa_sign: EVP_get_digestbynid 64 failed[SOLVED]
_________________
Dinosaur week! (Ok, this thread is so last week)
Back to top
View user's profile Send private message
bdgenz
n00b
n00b


Joined: 28 Oct 2006
Posts: 13
Location: TX, US

PostPosted: Wed Nov 01, 2006 10:27 pm    Post subject: Reply with quote

Yep, just found that.

Thanks, looking into it now.
Back to top
View user's profile Send private message
bdgenz
n00b
n00b


Joined: 28 Oct 2006
Posts: 13
Location: TX, US

PostPosted: Thu Nov 02, 2006 12:53 am    Post subject: Reply with quote

Reinstalled openssh and couldn't log into a second session.

Power went out at the Co-Lo - what timing!

Magically ssh worked (didn't have the, um... parts... to restart ssh beforehand).

Gentoo is amazing!
Back to top
View user's profile Send private message
ErnieS
n00b
n00b


Joined: 14 Jan 2003
Posts: 49
Location: South FL

PostPosted: Sat Jan 06, 2007 12:59 am    Post subject: Reply with quote

Haven't updated this box in forever. I ran into the pam-login blocks shadow thing and did
Code:
emerge -C pam-login && emerge shadow

Now I can't log in. (from terminal) I type
Code:
 root # and receive:
   login incorrect

My root and user accounts still exist as I can chroot in and change passwords etc..
I've added pam to my USE flags and remerged pam and shadow.
/var/log/messages tells me nothing and frankly I'm lost. Please help a frail, old man
_________________
Regards, Ernie
100% Microsoft and Intel free
Back to top
View user's profile Send private message
ErnieS
n00b
n00b


Joined: 14 Jan 2003
Posts: 49
Location: South FL

PostPosted: Sat Jan 06, 2007 4:34 am    Post subject: Reply with quote

OK got it fixed. I moved /etc/pam.d/login and re merged shadow all is well
_________________
Regards, Ernie
100% Microsoft and Intel free
Back to top
View user's profile Send private message
anroy
n00b
n00b


Joined: 19 May 2007
Posts: 25

PostPosted: Tue Jun 05, 2007 2:33 pm    Post subject: Reply with quote

ecatmur wrote:
[edit: changed to be safer]

emerge --buildpkgonly --nodeps shadow && emerge -C pam-login && emerge --usepkgonly shadow


I tried this and got the following


Code:
gemini ~ # emerge --buildpkgonly --nodeps shadow && emerge -C pam-login && emerge --usepkgonly shadow

Calculating dependencies... done!
>>> Emerging (1 of 1) sys-apps/shadow-4.0.15-r2 to /
>>> Downloading http://mirror.gentoo.gr.jp/distfiles/shadow-4.0.15.tar.bz2
--23:29:04--  http://mirror.gentoo.gr.jp/distfiles/shadow-4.0.15.tar.bz2
           => `/usr/portage/distfiles/shadow-4.0.15.tar.bz2'
Resolving mirror.gentoo.gr.jp... 219.106.242.53
Connecting to mirror.gentoo.gr.jp|219.106.242.53|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
23:29:04 ERROR 404: Not Found.

>>> Downloading http://gentoo.gg3.net/distfiles/shadow-4.0.15.tar.bz2
--23:29:04--  http://gentoo.gg3.net/distfiles/shadow-4.0.15.tar.bz2
           => `/usr/portage/distfiles/shadow-4.0.15.tar.bz2'
Resolving gentoo.gg3.net... 220.157.235.239
Connecting to gentoo.gg3.net|220.157.235.239|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
23:29:04 ERROR 404: Not Found.

>>> Downloading ftp://ftp.ecc.u-tokyo.ac.jp/GENTOO/distfiles/shadow-4.0.15.tar.bz2
--23:29:04--  ftp://ftp.ecc.u-tokyo.ac.jp/GENTOO/distfiles/shadow-4.0.15.tar.bz2
           => `/usr/portage/distfiles/shadow-4.0.15.tar.bz2'
Resolving ftp.ecc.u-tokyo.ac.jp... 133.11.205.121
Connecting to ftp.ecc.u-tokyo.ac.jp|133.11.205.121|:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD /GENTOO/distfiles ... done.
==> PASV ... done.    ==> RETR shadow-4.0.15.tar.bz2 ...
No such file `shadow-4.0.15.tar.bz2'.

>>> Downloading http://ftp.jaist.ac.jp/pub/Linux/Gentoo/distfiles/shadow-4.0.15.tar.bz2
--23:29:05--  http://ftp.jaist.ac.jp/pub/Linux/Gentoo/distfiles/shadow-4.0.15.tar.bz2
           => `/usr/portage/distfiles/shadow-4.0.15.tar.bz2'
Resolving ftp.jaist.ac.jp... 150.65.7.130
Connecting to ftp.jaist.ac.jp|150.65.7.130|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
23:29:05 ERROR 404: Not Found.

>>> Downloading http://gentoo.channelx.biz/distfiles/shadow-4.0.15.tar.bz2
--23:29:05--  http://gentoo.channelx.biz/distfiles/shadow-4.0.15.tar.bz2
           => `/usr/portage/distfiles/shadow-4.0.15.tar.bz2'
Resolving gentoo.channelx.biz... 220.221.19.205
Connecting to gentoo.channelx.biz|220.221.19.205|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
23:29:06 ERROR 404: Not Found.

>>> Downloading ftp://ftp.pld.org.pl/software/shadow/shadow-4.0.15.tar.bz2
--23:29:06--  ftp://ftp.pld.org.pl/software/shadow/shadow-4.0.15.tar.bz2
           => `/usr/portage/distfiles/shadow-4.0.15.tar.bz2'
Resolving ftp.pld.org.pl... failed: Name or service not known.
!!! Couldn't download shadow-4.0.15.tar.bz2. Aborting.


So it is being stopped by
!!! Couldn't download shadow-4.0.15.tar.bz2. Aborting.

Is it possible a download path is wrong? Where are these download paths specified?
Back to top
View user's profile Send private message
Arfrever
Bodhisattva
Bodhisattva


Joined: 29 Apr 2006
Posts: 2460
Location: 異世界

PostPosted: Tue Jun 05, 2007 2:49 pm    Post subject: Reply with quote

anroy wrote:
Code:
!!! Couldn't download shadow-4.0.15.tar.bz2. Aborting.


You forgot about:
Code:
emerge --sync && emerge portage


Perduodu linkėjimus
Arfrever
Back to top
View user's profile Send private message
jeremykoppel
n00b
n00b


Joined: 02 Mar 2007
Posts: 4

PostPosted: Thu Jun 28, 2007 2:14 pm    Post subject: Reply with quote

One of my users has updated his system, including the move from pam-login to the new shadow, and while the local users can log in fine, the machine's connection to our openldap domain has broken. I've replicated this problem by updating a test box we have. Both can still do an ldapsearch successfully, but it seems as if the local system is no longer checking ldap for logins. Also, 'getent passwd' only returns results from /etc/passwd. None of the relevant config files have changed. Has anyone else run across this?

I wanted to test if this upgrade was the culprit by downgrading back to the old version of shadow and pam-login, but it seems like pam-login has been removed from portage entirely, so I'm not sure how to downgrade and test. Maybe with the new shadow, /etc/pam.d/system-auth is no longer used, and I should be updating some other config file? I can't seem to find any information on any config changes that should be made when updating to shadow 4.0.18.

I wanted to find some way to either confirm this suspicion and fix it, or a compelling reason to rule it out and look for other anomalies. Any ideas?

--Jeremy
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6
Page 6 of 6

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum