Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200603-10 ] Cube: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Mon Mar 13, 2006 12:26 am    Post subject: [ GLSA 200603-10 ] Cube: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: Cube: Multiple vulnerabilities (GLSA 200603-10)
Severity: high
Exploitable: remote
Date: March 13, 2006
Bug(s): #125289
ID: 200603-10

Synopsis

Cube is vulnerable to a buffer overflow, invalid memory access and remote client crashes, possibly leading to a Denial of Service or remote code execution.

Background

Cube is an open source first person shooter game engine supporting multiplayer via LAN or internet.

Affected Packages

Package: games-fps/cube
Vulnerable: <= 20050829
Architectures: All supported architectures


Description

Luigi Auriemma reported that Cube is vulnerable to a buffer overflow in the sgetstr() function (CVE-2006-1100) and that the sgetstr() and getint() functions fail to verify the length of the supplied argument, possibly leading to the access of invalid memory regions (CVE-2006-1101). Furthermore, he discovered that a client crashes when asked to load specially crafted mapnames (CVE-2006-1102).

Impact

A remote attacker could exploit the buffer overflow to execute arbitrary code with the rights of the user running cube. An attacker could also exploit the other vulnerabilities to crash a Cube client or server, resulting in a Denial of Service.

Workaround

Play solo games or restrict your multiplayer games to trusted parties.

Resolution

Upstream stated that there will be no fixed version of Cube, thus the Gentoo Security Team decided to hardmask Cube for security reasons. All Cube users are encouraged to uninstall Cube:
Code:
# emerge --ask --unmerge games-fps/cube


References

CVE-2006-1100
CVE-2006-1101
CVE-2006-1102


Last edited by GLSA on Sun May 07, 2006 5:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum