Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[APACHE] Symbolic link not allowed <-- _warum_?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Diskussionsforum
View previous topic :: View next topic  
Author Message
mr_stigmata
Tux's lil' helper
Tux's lil' helper


Joined: 24 Nov 2004
Posts: 119
Location: München

PostPosted: Wed Mar 15, 2006 1:55 pm    Post subject: [APACHE] Symbolic link not allowed <-- _warum_? Reply with quote

Ich habe hier einen Apache (apache-2.0.55-r1) und möchte in einem VHost eine Typo3 Installation ansprechen. Typo3 arbeitet mit Symlinks, also muss der Apache diese auch unterstüzen.

Hier die Vhost-Config:

############################################################################
NameVirtualHost *:80

<VirtualHost *:80>
ServerName xxx.xx.x.xxx
ServerAdmin blah@blubbs.com
DocumentRoot "/var/www/localhost/htdocs"

<Directory "/var/www/localhost/htdocs">
Options Indexes FollowSymlinks MultiViews
Order deny,allow
Deny from All
Allow from xxx.xx.x.xxx
</Directory>

ErrorLog /var/log/apache2/error_log
CustomLog /var/log/apache2/access_log combined

</VirtualHost>
############################################################################

dieses bekomme ich in der error_log vom Apache beim Zugriff auf den VHost:

[Wed Mar 15 15:28:49 2006] [error] [client xxx.xx.x.xxx] Symbolic link not allowed: /var/www/localhost/htdocs/cms/index.php

ich werd noch wahnsinnig... sieht jemand meinen Fehler? ich dreh seit ner Stunde am Rad.... :o)

Gruß,
stigmata
Back to top
View user's profile Send private message
misterjack
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1481
Location: Germany -> Saxony -> Leipzig

PostPosted: Wed Mar 15, 2006 3:09 pm    Post subject: Reply with quote

Quote:
ServerName xxx.xx.x.xxx

wird die installation wirklich über eine IP-adresse angesprochen? oder über domain ;) wenn über domain, dann sollte dort die domain hin, z.b.:

Code:

<VirtualHost *:80>
    Servername www.ohne-rhythmus.de
    DocumentRoot "/var/www/ohne-rhythmus.de/htdocs"
    <Directory "/var/www/ohne-rhythmus.de/htdocs">
        Options -Indexes FollowSymLinks
        AllowOverride All
        ErrorDocument 404 default
        RewriteEngine On
        RewriteRule ^media_(.*).html$ index.php?site=media&show=$1
        RewriteRule ^(.*).html$ index.php?site=$1
        Order allow,deny
        Allow from all
    </Directory>
</VirtualHost>
<VirtualHost *:80>
    Servername ohne-rhythmus.de
    DocumentRoot "/var/www/ohne-rhythmus.de/htdocs"
    <Directory "/var/www/ohne-rhythmus.de/htdocs">
        Redirect permanent   /   http://www.ohne-rhythmus.de/
    </Directory>
</VirtualHost>


ach ja, und das nächste mal bitte forenregeln beachten und [code] tags verwenden ;)
_________________
„Meine Meinung steht fest! Bitte verwirren Sie mich nicht mit Tatsachen.“
Back to top
View user's profile Send private message
mr_stigmata
Tux's lil' helper
Tux's lil' helper


Joined: 24 Nov 2004
Posts: 119
Location: München

PostPosted: Wed Mar 15, 2006 3:20 pm    Post subject: Reply with quote

ja, der vhost wird während der einrichtungsphase via IP angesprochen - warum nicht?

ich sehe keine wirkliche hilfe in deiner antwort, _was_ ist in deinem vhost anders als in meinem außer dem "[code] tag"?

Gruß,
stigmata
Back to top
View user's profile Send private message
misterjack
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1481
Location: Germany -> Saxony -> Leipzig

PostPosted: Wed Mar 15, 2006 3:32 pm    Post subject: Reply with quote

mr_stigmata wrote:
ich sehe keine wirkliche hilfe in deiner antwort

kann ja sein, dass du ip angegeben hast und über domain zugegriffen hast. war meine vermutung. sorry für meine antwort, werde nicht mehr antworten
_________________
„Meine Meinung steht fest! Bitte verwirren Sie mich nicht mit Tatsachen.“
Back to top
View user's profile Send private message
mr_stigmata
Tux's lil' helper
Tux's lil' helper


Joined: 24 Nov 2004
Posts: 119
Location: München

PostPosted: Wed Mar 15, 2006 3:38 pm    Post subject: Reply with quote

sind wir uns beide auf die füße getreten :)

sorry *handgeb*
Back to top
View user's profile Send private message
nic0000
l33t
l33t


Joined: 25 Sep 2005
Posts: 658

PostPosted: Thu Mar 16, 2006 9:19 am    Post subject: Reply with quote

mr_stigmata wrote:
sind wir uns beide auf die füße getreten :)

sorry *handgeb*

*fußhinhalt*

Nach welcher Installationssnleitung verfährst du?
Ich habe keinen so tiefen Einblick in apache&webapp-config&typo3 wie du, aber bitte zeige mir doch mal deine /etc/apache2/conf/commonapache2.conf

Ich kann mich dunkel daran erinnern mal auch so etwas gehabt zu haben...
_________________
grüße
nico
Back to top
View user's profile Send private message
Anarcho
Advocate
Advocate


Joined: 06 Jun 2004
Posts: 2959
Location: Wuppertal (Germany)

PostPosted: Thu Mar 16, 2006 11:50 am    Post subject: Reply with quote

Code:
<Directory /var/www/blah>
Options FollowSymlinks # oder All
</Directory>


Sowas in der Art solltest du konfigurieren. Falls du einen Eintrag für das entsprechende Verzeichnis hast, dann überpüfe ob dort FollowSymlinks oder All steht. Falls nicht, dann musst du es ergänzen.
_________________
...it's only Rock'n'Roll, but I like it!
HOWTO:WLAN mit OpenVPN absichern | TOOL:useedit - USE-flag editor/changer
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Diskussionsforum All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum