Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
como banir definitivamente o blackdow-jdk?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Mon Mar 06, 2006 12:30 am    Post subject: como banir definitivamente o blackdow-jdk? Reply with quote

pessoal tenho pavor desse pacote, sinceramente ele é inutil pra min, toda aplicação que tem a variavel java, esse monstro resolve vir junto, e toda hora eu tenho que ficar tirando o suporte dele, setei meu java-config pra trabalhar com jre da SUN, mas esse monstro insiste em vir pelo portage e ai com faço pra acabar com ele de vez??

obrigado
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
meetra
Tux's lil' helper
Tux's lil' helper


Joined: 18 Nov 2002
Posts: 135
Location: Porto, Portugal

PostPosted: Mon Mar 06, 2006 12:54 am    Post subject: Reply with quote

crias/editas o ficheiro /etc/portage/virtuals
Code:
virtual/jdk dev-java/sun-jdk


deve chegar para ele não te chatear mais.
Back to top
View user's profile Send private message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Mon Mar 06, 2006 1:03 am    Post subject: Reply with quote

meetra wrote:
crias/editas o ficheiro /etc/portage/virtuals
Code:
virtual/jdk dev-java/sun-jdk


deve chegar para ele não te chatear mais.


tem que ser obrigatoriamente o JDK?

nao pode ser o JSE mesmo?

ou derrepente falei besteira e isso nao tem nada a ver? :)

eu so quero maquina virtual mesmo, nao quero esses kits de desenvolvimento, que so vao gastar espaço atoa
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd


Last edited by domus-br on Mon Mar 06, 2006 1:09 am; edited 1 time in total
Back to top
View user's profile Send private message
meetra
Tux's lil' helper
Tux's lil' helper


Joined: 18 Nov 2002
Posts: 135
Location: Porto, Portugal

PostPosted: Mon Mar 06, 2006 1:09 am    Post subject: Reply with quote

depois de ler não me lembrei ao escrever que era o jre em vez de o jdk mas agora todos sabem como fazer para qualquer virtual.

tens aqui a listagem de todos os virtuals que podes alterar.

http://www.gentoo.org/cgi-bin/viewcvs.cgi/profiles/base/virtuals?rev=1.87&view=markup
Back to top
View user's profile Send private message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Mon Mar 06, 2006 1:16 am    Post subject: Reply with quote

meetra wrote:
depois de ler não me lembrei ao escrever que era o jre em vez de o jdk mas agora todos sabem como fazer para qualquer virtual.

tens aqui a listagem de todos os virtuals que podes alterar.

http://www.gentoo.org/cgi-bin/viewcvs.cgi/profiles/base/virtuals?rev=1.87&view=markup


opa meetra, obrigado pelo link, mas no meu caso vc acha que se aplicaria isto?

Code:
virtual/jre   dev-java/sun-jre-bin


curioso que nao consta isso na lista, fiz essa adaptação, que ainda nao coloquei em pratica, queria saber se é correto?

grato
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
meetra
Tux's lil' helper
Tux's lil' helper


Joined: 18 Nov 2002
Posts: 135
Location: Porto, Portugal

PostPosted: Mon Mar 06, 2006 1:23 am    Post subject: Reply with quote

bem, se fores ver o ebuild, lá dentro tem
Code:
PROVIDE="virtual/jre"


o emerge mete lá na db a apontar o virtual/jre -> sun-jre-bin. possivelmente tenha acontecido qualquer cena mal. é uma questão de emergires de novo o sun-jre-bin. (sem o blackdown instalado aka emerge -C blackdown-jre)

se não der, experimenta fazer aquilo do /etc/portage/virtuals mas não devia ser necessário.
Back to top
View user's profile Send private message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Tue Mar 07, 2006 2:07 am    Post subject: Reply with quote

olá ainda nao tive sucesso, os SDK's insistem em vir, e eu nao quero eles

ja tentei pesquisar sobre o assunto mas tb noa btive sucesso
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
Operador Nabla
Apprentice
Apprentice


Joined: 06 Feb 2004
Posts: 176
Location: Salesópolis - SP - Brasil

PostPosted: Tue Mar 28, 2006 12:27 pm    Post subject: Reply with quote

Uma medida meio "drástica" que eu costumo adotar, em casos como este, é forçar o mascaramento do pacote, adicionando-o em /etc/portage/package.mask. Assim, caso algum outro pacote insista em instalá-lo como dependência, o Portage retorna um erro e, pelo menos, fica mais fácil para mim investigar o que está acontecendo. Recentemente, quando eu migrei para o X.Org 7.0, eu fiz isto com os pacotes <x11-base/xorg-x11-7.0 e virtual/x11, pois diversos ebuilds antigos ainda pedem para o meu Portage instalar o X.Org 6.8.2.

Opcionalmente, você poderia ainda "injetar" o pacote no Portage (adicionando-o em /etc/portage/profile/package.provided) para evitar que o Portage retorne um erro, caso você acate a sugestão acima.
Back to top
View user's profile Send private message
oandarilho01
Tux's lil' helper
Tux's lil' helper


Joined: 17 Nov 2005
Posts: 132
Location: Rio de Janeiro/RJ - Brasil

PostPosted: Fri Jun 30, 2006 3:17 pm    Post subject: Reply with quote

Já eu estou com o seguinte problema:

Estava tentando rodar o Looking Glass mas tive um problema com java.

Code:
$ ./lg3d-dev

Starting up Project Looking Glass...

Exception in thread "main" java.lang.UnsupportedClassVersionError: org/jdesktop/lg3d/displayserver/Main (Unsupported major.minor version 49.0)


E li num outro tópico que alguém conseguiu rodar instalando os jdk e jai da sun. Como eu sempre usei o blackdown e percebi que alguns não apreciam, resolvi mudar para os pacotes da Sun, baseado no Guia de Java do Gentoo. Baixei e dei emerge nos pacotes todos (JDK, JRE, JAI) da maneira exata com o próprio emerge instruiu, baixando direto do site e colocando dentro de distfiles. Mas por algum motivo o sistema não consegue declarar os pacotes da sun como padrão. Já desinstalei os blackdown que haviam aqui, rodei novamente o emerge no sun-jdk mas sempre me vem o mesmo:

Code:
# java-config --list-available-vms
[sun-jdk-1.4.2.10] "Sun JDK 1.4.2.10" (/etc/env.d/java/20sun-jdk-1.4.2.10)
[sun-jre-bin-1.5.0.06] "Sun JRE 1.5.0.06" (/etc/env.d/java/20sun-jre-bin-1.5.0.06)

Code:
# java-config --set-system-vm=sun-jdk-1.4.2.10
System Virtual Machine set
You may want to update your enviroment by running:
        "/usr/sbin/env-update && source /etc/profile"


Alguma idéia? Ainda sou iniciante, e não descobri como resolver ainda.
Grato pela atenção e ajuda..
Back to top
View user's profile Send private message
Operador Nabla
Apprentice
Apprentice


Joined: 06 Feb 2004
Posts: 176
Location: Salesópolis - SP - Brasil

PostPosted: Mon Jul 03, 2006 11:35 am    Post subject: Reply with quote

Code:
You may want to update your enviroment by running:
        "/usr/sbin/env-update && source /etc/profile"


Você já tentou executar os comandos entre aspas no quadro acima? Depois de alterar a JVM padrão pelo java-config, é preciso executar os comandos acima para atualizar as suas variáveis de ambiente.
Back to top
View user's profile Send private message
oandarilho01
Tux's lil' helper
Tux's lil' helper


Joined: 17 Nov 2005
Posts: 132
Location: Rio de Janeiro/RJ - Brasil

PostPosted: Mon Jul 03, 2006 11:48 am    Post subject: Reply with quote

Mas o problema é justamente esse.
Se eu rodo o java-config ele não altera a JVM, e ainda me apresenta a instrução de rodar env-update && source /etc/profile
Eu também tentei rodá-los, mas nao muda nada. Nem mesmo depois de rodá-los, tentando rodar o java-config novamente eu consigo setar a JVM. ELe sempre me vem com a mesma informação..
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4734
Location: Angra do Heroísmo (PT)

PostPosted: Mon Jul 03, 2006 10:49 pm    Post subject: Reply with quote

Boas.

O sistema de configuração do java foi alterado substancialmente nos últimos dias. Para quem não tiver actualizado recentemente o sistema, aconselho um emerge --sync.
_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
oandarilho01
Tux's lil' helper
Tux's lil' helper


Joined: 17 Nov 2005
Posts: 132
Location: Rio de Janeiro/RJ - Brasil

PostPosted: Tue Jul 04, 2006 12:56 am    Post subject: Reply with quote

Ok, mas que mudanças tão significativas foram essas, hein?
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4734
Location: Angra do Heroísmo (PT)

PostPosted: Tue Jul 04, 2006 1:22 am    Post subject: Reply with quote

Bem, nada como ver a última GWN e o Guia de Upgrade.
_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
oandarilho01
Tux's lil' helper
Tux's lil' helper


Joined: 17 Nov 2005
Posts: 132
Location: Rio de Janeiro/RJ - Brasil

PostPosted: Tue Jul 04, 2006 1:27 am    Post subject: Reply with quote

Beleza.. fica melhor assim..
Vou dar uma olhada atenciosa amanhã.. grato pela informação..
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum