Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[HOWTO] HP LaserJet 10xx
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
baigsabeeh
Guru
Guru


Joined: 28 Sep 2005
Posts: 520
Location: North Brunswick, NJ

PostPosted: Mon Jul 31, 2006 3:09 am    Post subject: Reply with quote

This is what I did to get it to work.

Emerge cupsd per first post.

Then emerge hplip 1.6.6a. It might be masked, so use a keyword. Do not use any additional flags.

Then start cupsd and hplip. Run "hp-setup" to see if the printer is detected.

Then configure your printer in CUPS web interface per instructions in first post.

Mine didn't work after this, so I downloaded the foo2zjs tarball from the actual website. I extracted it and then I uploaded the firmware. I restarted my PC and then it worked without a hitch, so I would recommend loading up the firmware using cat.
Back to top
View user's profile Send private message
hrnick
Guru
Guru


Joined: 31 Aug 2002
Posts: 304
Location: Linköping, Sweden

PostPosted: Wed Aug 30, 2006 10:25 am    Post subject: Reply with quote

I've followed this TODO but the printer doesn't work, dmesg prints the following:
Code:
ppdev0: registered pardevice
ppdev0: negotiated back to compatibility mode because user-space forgot

I have a HP LaserJet 1005 Series printer connected to a parallel port. Any ideas where to start?
Back to top
View user's profile Send private message
saturday
Apprentice
Apprentice


Joined: 20 Dec 2004
Posts: 246
Location: de/munich/home

PostPosted: Thu Sep 21, 2006 9:42 am    Post subject: Reply with quote

Success! I am using 1005w via USB without hplip.

1) Configure the kernel as mentioned in http://www.gentoo.org/doc/en/printing-howto.xml and reboot to new kernel
2) emerge cups
3) Configure cups as mentioned in the guide
4) rc-update -a cupsd default
5) Add the line "FOO2ZJS_DEVICES="hp1005" to /etc/make.conf
6) emerge foo2zjs
7) switch on printer
8) /etc/init.d/cupsd (re)start
9) Configure printer via the cups webfrontend (see printing guide)
10) Print testpage

I am using hotplug and coldplug, and the firmware was loaded automagically to the printer, as you can see in this logfile excerpt:
(edit: Forget about hotplug, udev does the magic. The hotplug message resulted from an earlier installation of foo2zjs, I suppose!)

Code:
Sep 21 11:15:51 athlon usb 3-1: new full speed USB device using uhci_hcd and address 2
Sep 21 11:15:51 athlon usb 3-1: configuration #1 chosen from 1 choice
Sep 21 11:15:51 athlon drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto 2 vid 0x03F0 pid 0x1317
Sep 21 11:15:52 athlon /etc/hotplug/usb/hplj1005: HP LaserJet 1005 firmware was not downloaded...
Sep 21 11:15:52 athlon /etc/hotplug/usb/hplj1005: ...couldn't find /usr/bin/usb_printerid and DEV is not set
Sep 21 11:15:52 athlon udevd-event[32180]: find_free_number: %e is deprecated, will be removed and is unlikey to work correctly. Don't use it.
Sep 21 11:15:52 athlon /sbin/foo2zjs-loadfw: loading HP LaserJet 1005 firmware /lib/firmware/sihp1005.dl to /dev/usb/lp0 ...
Sep 21 11:15:53 athlon /sbin/foo2zjs-loadfw: ... download successful.


I haven't tested yet if I have to restart cupsd when I'm powering on the printer after booting, but even if I had to, that's no problem then at all.

So, henrik, if you have the chance to use an USB connection, that would be far more easy. I never got it workingwell with parallel port.
Back to top
View user's profile Send private message
hrnick
Guru
Guru


Joined: 31 Aug 2002
Posts: 304
Location: Linköping, Sweden

PostPosted: Thu Oct 19, 2006 11:04 am    Post subject: Reply with quote

Thanks for your reply saturday! I've got it working now!

The only thing is that I need to run this as root before using the printer:
Code:
cat /lib64/firmware/sihp1005.dl > /dev/lp0
Back to top
View user's profile Send private message
saturday
Apprentice
Apprentice


Joined: 20 Dec 2004
Posts: 246
Location: de/munich/home

PostPosted: Thu Oct 19, 2006 10:01 pm    Post subject: Reply with quote

henrik wrote:
Thanks for your reply saturday! I've got it working now!
The only thing is that I need to run this as root before using the printer:
Code:
cat /lib64/firmware/sihp1005.dl > /dev/lp0

Yeah, I had got it working that way long ago, too. But I am really happy with the new USB-connection now. I had to buy the cable first, but the handling is much simpler.

Anyway, if you feel comfortable with the parallel connection, that's fine, of course. :)
Back to top
View user's profile Send private message
hrnick
Guru
Guru


Joined: 31 Aug 2002
Posts: 304
Location: Linköping, Sweden

PostPosted: Fri Oct 20, 2006 8:20 am    Post subject: Reply with quote

It's no big deal, I've added the following to /etc/sudoers:
Code:
username   ALL=(root) NOPASSWD: /bin/cat /lib64/firmware/sihp1005.dl

I've also added the cat command to my fvwm menu so all I have to do is to start the printer and select this line in the menu to make it work.
Back to top
View user's profile Send private message
gasparov
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2006
Posts: 101

PostPosted: Tue Oct 24, 2006 10:04 am    Post subject: Reply with quote

or you cant add that line in /etc/init.d/local... :)
Back to top
View user's profile Send private message
hrnick
Guru
Guru


Joined: 31 Aug 2002
Posts: 304
Location: Linköping, Sweden

PostPosted: Tue Oct 24, 2006 1:47 pm    Post subject: Reply with quote

gasparov wrote:
or you cant add that line in /etc/init.d/local... :)
I thought of running this command on startup but I don't have the printer on all the time... :)
Back to top
View user's profile Send private message
jleejj
n00b
n00b


Joined: 18 Jan 2004
Posts: 57
Location: Eugene, OR

PostPosted: Sat Jan 27, 2007 6:35 am    Post subject: Reply with quote

I ran into a lot of problems trying to get this printer to work. My final solution is here:

https://forums.gentoo.org/viewtopic-p-3868823.html#3868823

If there's one thing I have noticed about this product line .. the same solution doesn't work for everyone. Hopefully this helps.
Back to top
View user's profile Send private message
bigdave1
Tux's lil' helper
Tux's lil' helper


Joined: 03 May 2005
Posts: 106
Location: Raleigh, NC

PostPosted: Wed Feb 07, 2007 5:13 am    Post subject: Reply with quote

When I try to emerge foo2zjs using the following:

Code:
USE="cups ppds foomaticdb usb" ACCEPT_KEYWORDS=~x86 emerge foo2zjs


I get this:

Code:

--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-net-print_-_foo2zjs-20061130-21051.log"

unlink:    /usr/share/ppd/Minolta/Minolta-magicolor_2300_DL-foo2zjs.ppd.gz
unlink:    /usr/share/ppd/Minolta/Minolta-magicolor_2430_DL-foo2zjs.ppd.gz
unlink:    /usr/share/ppd/Minolta/Minolta-Color_PageWorks_Pro_L-foo2zjs.ppd.gz
unlink:    /usr/share/ppd/Minolta/Minolta-magicolor_2200_DL-foo2zjs.ppd.gz
unlink:    /usr/share/ppd/HP/HP-LaserJet_1005-foo2zjs.ppd.gz
unlink:    /usr/share/ppd/HP/HP-LaserJet_1018-foo2zjs.ppd.gz
unlink:    /usr/share/ppd/HP/HP-LaserJet_1020-foo2zjs.ppd.gz
unlink:    /usr/share/ppd/HP/HP-LaserJet_1022-foo2zjs.ppd.gz
unlink:    /usr/share/ppd/HP/HP-LaserJet_1000-foo2zjs.ppd.gz
unlink:    /usr/share/ppd/KonicaMinolta/KonicaMinolta-magicolor_2300_DL-foo2zjs.ppd.gz
unlink:    /usr/share/ppd/KonicaMinolta/KonicaMinolta-magicolor_2430_DL-foo2zjs.ppd.gz
unlink:    /usr/share/ppd/Generic/Generic-GDI_Printer-foo2zjs.ppd.gz
unlink:    /usr/share/ppd/Generic/Generic-ZjStream_Printer-foo2zjs.ppd.gz
unlink:    /usr/share/ppd/HP/HP-Color_LaserJet_1600-foo2hp.ppd.gz
unlink:    /usr/share/ppd/HP/HP-Color_LaserJet_2600n-foo2hp.ppd.gz
unlink:    /usr/share/ppd/Generic/Generic-GDI_Printer-foo2hp.ppd.gz
unlink:    /usr/share/ppd/Generic/Generic-ZjStream_Printer-foo2hp.ppd.gz
--------------------------------------------------------------------------------


What do I need to do in order for this to emerge successfully?

Thanks!
Back to top
View user's profile Send private message
jleejj
n00b
n00b


Joined: 18 Jan 2004
Posts: 57
Location: Eugene, OR

PostPosted: Wed Feb 07, 2007 6:20 am    Post subject: Reply with quote

As I mention in my linked post (just above yours), the driver works better if you install it directly. The author mentions this on his site, and I ignored it, but it really did turn out to be true. I never could get the foo2zjs package in Gentoo to work for me (this has not been the case for others though).

Sorry, I haven't seen the exact problem you mentioned.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum