Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2005.1 r1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
Angel
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2005
Posts: 118
Location: Moscow

PostPosted: Mon Feb 20, 2006 9:38 pm    Post subject: 2005.1 r1 Reply with quote

Накрылся у меня раздел на харде.

Вот переставил линух из stage1 заново.

До бутстрапа было всё нормально, но сам бутсрап вынул из инета здоровенный файлы которые не относятся к моей тачке и времени.

/usr/portage/distfiles/linux-2.6.11.tar.bz2
/usr/portage/distfiles/linux-2.6.11-m68k-headers.patch.bz2

Потом он опомнился при emerge -e system качнул /usr/portage/distfiles/linux-2.6.15.tar.bz2
(ничего не трогал, просто следующая команда)

Хотя ещё до бутстрапа я емерджил синк.

Доки с руссификацией не сработали и он пишет:

# locale
LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=

/etc/make.conf

CFLAGS="-march=k8 -O2"
CHOST="x86_64-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j2"
USE="gnome gtk nvidia -kde -qt"

До этого ещё на ставой тачке решил поставить php mysql apache phpmyadmin.
Подумал и набрал emerge phpmyadmin и действительно всё остальное приципилось.
Заработал только апач. Php не работал, mysql писал что вообще без баз данных и просил создать хоть какую-нить. На сколько я знаю для phpmyadmin должна была проинсталиться база.
Back to top
View user's profile Send private message
bobdva
Apprentice
Apprentice


Joined: 25 Nov 2003
Posts: 207
Location: Moscow

PostPosted: Mon Feb 20, 2006 10:10 pm    Post subject: Re: 2005.1 r1 Reply with quote

Angel wrote:
Накрылся у меня раздел на харде.

Вот переставил линух из stage1 заново.

До бутстрапа было всё нормально, но сам бутсрап вынул из инета здоровенный файлы которые не относятся к моей тачке и времени.

/usr/portage/distfiles/linux-2.6.11.tar.bz2
/usr/portage/distfiles/linux-2.6.11-m68k-headers.patch.bz2



linux-headers ?
Back to top
View user's profile Send private message
Angel
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2005
Posts: 118
Location: Moscow

PostPosted: Mon Feb 20, 2006 10:44 pm    Post subject: Reply with quote

* sys-kernel/linux-headers
Latest version available: 2.6.11-r2
Latest version installed: 2.6.11-r2
Size of downloaded files: 36,470 kB
Homepage: http://www.kernel.org/ http://www.gentoo.org/
Description: Linux system headers
License: GPL-2

Раскрыв архив я понял что это старое ядро, нафига оно?
И зачем качать что-то для моторолы 68030 или 68040, я же её ещё в 96 году продал(это маки такие были)?
Back to top
View user's profile Send private message
IFL
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jun 2005
Posts: 117

PostPosted: Tue Feb 21, 2006 11:09 am    Post subject: Reply with quote

Angel wrote:

Раскрыв архив я понял что это старое ядро, нафига оно?
И зачем качать что-то для моторолы 68030 или 68040, я же её ещё в 96 году продал(это маки такие были)?

linux-headers и linux-sources
немного разные вещи и у них немного разные версии
Quote:
mysql писал что вообще без баз данных и просил создать хоть какую-нить

как вариант -- научиться читать как устанавливать и настраивать mysql (hint: создание системных таблиц, без которых НИКТО и НИКОГДА не сможет подключиться к серверу, так как он просто не запуститься)
phpmyadmin -- МОРДА для работы с mysql, не более
Back to top
View user's profile Send private message
Angel
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2005
Posts: 118
Location: Moscow

PostPosted: Tue Feb 21, 2006 2:12 pm    Post subject: Reply with quote

В генту всё устанавливается командой emerge.

>phpmyadmin -- МОРДА для работы с mysql, не более
Кто спотит, но и для этой морды нужна база в mysql, httpd и php.
Если я всё это сэмерджил где база и почему не пашет php?
Back to top
View user's profile Send private message
IFL
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jun 2005
Posts: 117

PostPosted: Tue Feb 21, 2006 5:53 pm    Post subject: Reply with quote

Angel wrote:

Если я всё это сэмерджил где база и почему не пашет php?

База не запущена
PHP не подключен к apache
Логично?
Back to top
View user's profile Send private message
Angel
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2005
Posts: 118
Location: Moscow

PostPosted: Tue Feb 21, 2006 6:07 pm    Post subject: Reply with quote

to IFL

Ты говоришь истину.
phpmyadmin это программа написаная на php для работы с базами мускул.
Мало ли прог написаных на других языках, и почему они не должны работать после emerge.
Нафига нужна emerge, если прога после неё не работает?
Back to top
View user's profile Send private message
Laitr Keiows
Moderator
Moderator


Joined: 04 Jul 2005
Posts: 891
Location: Kobe, Japan

PostPosted: Tue Feb 21, 2006 9:10 pm    Post subject: Reply with quote

Angel wrote:
Нафига нужна emerge, если прога после неё не работает?

А настраивать кто её будет? А пароль рута в MySQL задавать кто будет? Дядя?
Back to top
View user's profile Send private message
IFL
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jun 2005
Posts: 117

PostPosted: Wed Feb 22, 2006 12:53 pm    Post subject: Reply with quote

Angel wrote:
Нафига нужна emerge, если прога после неё не работает?

а слабо читать, что пишут сразу после установки?
конкретнее --
Quote:
* You might want to run:
* "emerge --config =dev-db/mysql-5.0.17"
* if this is a new install.

версию mysql подставить нужную
Back to top
View user's profile Send private message
Angel
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2005
Posts: 118
Location: Moscow

PostPosted: Thu Feb 23, 2006 12:16 am    Post subject: Reply with quote

Надо было выкинуть эти строчки:

Code:
<IfDefine PHP4>
</IfDefine>


Кстати видюха nvidia не заработала от команды emerge. Но когда я с сайта качнул дрова всё заработало. В 2005.1 от emerge работало.
Ранее команда emerge phpmyadmin качала php5, а теперь php4.

На счёт r1 "машина едет, но задом".[/code]
Back to top
View user's profile Send private message
IFL
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jun 2005
Posts: 117

PostPosted: Thu Feb 23, 2006 9:47 am    Post subject: Reply with quote

Angel wrote:
Надо было выкинуть эти строчки:

Code:
<IfDefine PHP4>
</IfDefine>


мдааааааааааааааааа........
мы не будем делать нормально, мы сделаем через жопу!
Back to top
View user's profile Send private message
viy
Veteran
Veteran


Joined: 03 Jul 2004
Posts: 1580
Location: Riga, Latvia

PostPosted: Thu Feb 23, 2006 10:12 am    Post subject: Reply with quote

Angel wrote:
Надо было выкинуть эти строчки:

Code:
<IfDefine PHP4>
</IfDefine>

[/code]

Надо в /etc/conf.d/apache2 подправить APACHE2_OPTS.

У меня: APACHE2_OPTS="-D DEFAULT_VHOST -D PHP4 -D PYTHON"

Вообще-то все пакеты после установки дают много подсказок. Большинство настраивается через /etc/conf.d и /etc/env.d
Наверно стоит иногда напрягаться и читать что-то, маны скажем...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum