Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ipw3945 wireless drivers
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 5, 6, 7 ... 30, 31, 32  Next  
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
HomerJ
n00b
n00b


Joined: 12 Sep 2003
Posts: 34

PostPosted: Fri Apr 21, 2006 11:32 pm    Post subject: Reply with quote

Somebody kick me, and kick me hard. I mean HARD.

My system was so freshly installed, I didn't take the time to "emerge -u --deep world".

My reasoning was that I didn't need to spend time to install anything unless I could get the network to work. After all, I wouldn't be wasting my time with gentoo unless I could get the network up and running.

Well DUH!!! :oops: :oops: :oops: :roll: This means I was running with the stage3 version of all the packages. Whatever that is, my system just compiled updated for 2 hours to bring it up to date... and guess what.

Everything works now. Kick me, and kick me hard! I can't believe I spent the week on this. Sorry for wasting your time. That's what I get for installing gentoo while babysitting a 10 month old and a 4 year old.
_________________
* Inspiron 6400/e1505
* Intel Core Duo CPU 2.00 GHz
* ATI X1400
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4857
Location: Dark side of the mood

PostPosted: Sat Apr 22, 2006 9:33 am    Post subject: Reply with quote

echalon wrote:
For all those who did a world upgrade... I have found that I can use version 0.0.74, but only with iee80211 version 1.1.12. using version 1.1.13 gives me the problem with iwconfig reporting "unassociated" for everything. 1.1.12 works fine, but now I can't do any further upgrades because 1.1.13 is a dependancy.

It may be on your system only for I have successfully installed ieee80211-1.1.13 and it works. Now I have identified what makes the WiFi led blink: the led starts blinking (scanning, I think) when XDM starts. If I don't start X the led remains still.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4857
Location: Dark side of the mood

PostPosted: Sat Apr 22, 2006 9:36 am    Post subject: Reply with quote

HomerJ wrote:
My system was so freshly installed, I didn't take the time to "emerge -u --deep world".
...
Everything works now. Kick me, and kick me hard! I can't believe I spent the week on this. Sorry for wasting your time. That's what I get for installing gentoo while babysitting a 10 month old and a 4 year old.

Don't blame it on these little creatures ;-) . Now you know Gentoo emerge -u is there for a reason...
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
Back to top
View user's profile Send private message
widi
n00b
n00b


Joined: 19 Apr 2006
Posts: 4

PostPosted: Sat Apr 22, 2006 11:37 am    Post subject: Reply with quote

solved my problem.

the problem was, that the initscript of hotplug didn't told the kernel where to find the hotplug binary (/proc/sys/kernel/hotplug was empty).

so i made the following:

Code:
zeitdieb ~ # which hotplug
/sbin/hotplug
zeitdieb ~ #  echo -n "/sbin/hotplug" >  /proc/sys/kernel/hotplug
zeitdieb ~ # modprobe ipw3945


and dmesg shows:
Code:
eee80211_crypt: unregistered algorithm 'NULL'
ieee80211_crypt: registered algorithm 'NULL'
ieee80211: 802.11 data/management/control stack, 1.1.13
ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>
ipw3945: Intel(R) PRO/Wireless 3945 Network Connection driver for Linux, 0.0.74
ipw3945: Copyright(c) 2003-2006 Intel Corporation
ACPI: PCI Interrupt 0000:05:00.0[A] -> GSI 19 (level, low) -> IRQ 193
PCI: Setting latency timer of device 0000:05:00.0 to 64
ipw3945: Detected Intel PRO/Wireless 3945ABG Network Connection
ipw3945: Detected geography ABG (13 802.11bg channels, 23 802.11a channels)



iwconfig:
Code:
eth1      IEEE 802.11g  ESSID:"SomeNet"  Nickname:"SomeNick"
          Mode:Managed  Frequency:2.437 GHz  Access Point: DE:AD:BE:EF:00:00
          Bit Rate:36 Mb/s   Tx-Power:15 dBm   
          Retry limit:15   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=65/100  Signal level=-66 dBm  Noise level=-67 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:1   Missed beacon:0



So finally, it works :lol:

The only thing left is to make a script and add it to my rc :wink:
_________________
the digital age is full of new ways,
but allways remember what's behind.
Back to top
View user's profile Send private message
gr0g
n00b
n00b


Joined: 21 Apr 2006
Posts: 3

PostPosted: Sat Apr 22, 2006 1:22 pm    Post subject: Reply with quote

widi wrote:
So finally, it works :lol:

The only thing left is to make a script and add it to my rc :wink:


I had the same problem and discovered all I needed to do was an etc-update. Rebooted and it seems to be fine again...
Back to top
View user's profile Send private message
asiobob
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1375
Location: Bamboo Creek

PostPosted: Sat Apr 22, 2006 3:15 pm    Post subject: Reply with quote

Greetings,
I just saw this thread after I got the wifi working. For those who have problems you have hope because of the following

1. I have a Dell insprion 6400, "dual core centrino" wth IPW3945
2. I connect to an access point AGES away from my location with a weak signal
3. I need WPA Enterprise to authenticate, i,e EAP-TTLS

I installed ipw3945, I ran the script that removed the old ieee80211 from the kernel as I was told to do. Then the newer ieee80211 was installed along with everything else I needed.

For WPA you need CRC32 support in the kernel, as well as AES cipher. as mentioned in http://ipw3945.sourceforge.net/README.ipw3945

I have a ~x86 version of baselayout (1.12.0_pre17-r3). I installed the last ~arch version of wpa_supplicant and my config for that is pretty much

Code:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1
network={
        ssid="YOURSSID"
        key_mgmt=WPA-EAP
        eap=TTLS
        anonymous_identity="anonymous"
        identity="USERNAME"
        password="YOURSECRET"
        priority=2
        phase2="auth=PAP"
}


Thats right! I authenticate with a username/password not a shared key.

I configured /etc/init.d/net to suit, just follow the comments! *BUT* here is the thing that got me. the same readme file I refer to says for newer kernels use the -Dext option (driver option) for wpa supplicant and for older ones use -Dipw

The latter spewed errors on teh screen, the former was "driver not supported". After some googling I discover it's meant to me -Dwext (note the w) and then when I start eth1 BINGO! it works! Authenticated and have been given and IP etc...
Back to top
View user's profile Send private message
HomerJ
n00b
n00b


Joined: 12 Sep 2003
Posts: 34

PostPosted: Sat Apr 22, 2006 3:34 pm    Post subject: Reply with quote

Is this in 11a or 11g mode? I still can't get the 11a mode to work. 11g works fine. I'm starting to wonder if the problem is not the AP itself.
_________________
* Inspiron 6400/e1505
* Intel Core Duo CPU 2.00 GHz
* ATI X1400
Back to top
View user's profile Send private message
mjelkins
n00b
n00b


Joined: 09 Nov 2005
Posts: 16
Location: South Africa

PostPosted: Sat Apr 22, 2006 9:12 pm    Post subject: Reply with quote

I've been following the postings with great interest - trying and failing.. and now have success.
I have an Acer TravelMate 8204WLMi with Built-in 3945 wireless (A/B/G)

In order to install - I did the following..


    emerge mm-sources (new Kernel) ** Don't use **
    sh /usr/portage/net-wireless/ieee80211/files/remove-old
    emerge ieee80211 (a few times!!)
    emerge ipw3945 (also copied the ebuild a few days earlier)
    rc-update add ipw3945d boot (this installs modules and runs a daemon)


I then got stuck.
iwconfig showed the module installed and looking healthy.
Code:

# iwconfig
eth1      unassociated  ESSID:"posix"
          Mode:Managed  Frequency=2.427 GHz  Access Point: 00:02:6F:21:E2:42
          Bit Rate:0 kb/s   Tx-Power:16 dBm
          Retry limit:15   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:8   Missed beacon:0


Question was: How do I get my Wireless to become "associated" ??

Seems that something in 2.6.17 is broken. Moved back to 2.6.15 and everything is OK :?


Last edited by mjelkins on Tue Apr 25, 2006 4:03 pm; edited 2 times in total
Back to top
View user's profile Send private message
asiobob
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1375
Location: Bamboo Creek

PostPosted: Sun Apr 23, 2006 3:11 am    Post subject: Reply with quote

HomerJ wrote:
Is this in 11a or 11g mode? I still can't get the 11a mode to work. 11g works fine. I'm starting to wonder if the problem is not the AP itself.


if you were referring to my post, its 11g
Back to top
View user's profile Send private message
zidour
Tux's lil' helper
Tux's lil' helper


Joined: 29 Apr 2004
Posts: 103

PostPosted: Sun Apr 23, 2006 7:00 pm    Post subject: Reply with quote

Hi everyone,
first thanks for your great work.

Now to my problem:
I have installed ipw3945 and everything worked instantly. The only problem is, that I can't manage to start the ipw3945d daemon at boot. If i boot normally, then modprobe ipw3945, everything works fine.
Then if i put "ipw3945" into /etc/modules.autoload.d/kernel-2.6, the module is loaded at boot, but the daemon is not started (if I modprobe the module by hand, the daemon IS started automatically and if I modporbe -r the module by hand, the daemon IS stopped automatically).

I think I am just missing somthing obvious...

This is my /etc/modules.d/ipw3945d (the lines were added by the ebuild I guess):
Code:

install ipw3945 /sbin/modprobe --ignore-install ipw3945; sleep 0.5; /sbin/ipw3945d --quiet
remove ipw3945 /sbin/ipw3945d --kill; /sbin/modprobe -r --ignore-remove ipw3945


Versions I am using:
Code:

[ebuild   R   ] net-wireless/ipw3945-1.0.1  USE="-debug" 0 kB
[ebuild   R   ] net-wireless/ipw3945d-1.7.18  0 kB
[ebuild   R   ] net-wireless/ipw3945-ucode-1.13  0 kB




This is the tail of my /etc/modules.conf:
Code:

### modules-update: start processing /etc/modules.d/ipw3945
# modules.d configuration file for IPW3945
# For more information please read:
#    README.ipw3945


# Configurable module parameters
# ------------------------------
# antenna:      select antenna (1=Main, 2=Aux, default 0 [both])
# disable:      manually disable the radio (default 0 [radio on])
# associate:    auto associate when scanning (default 0 off)
# auto_create:  auto create adhoc network (default 1 on)
# led:  enable led control (default 1 on)
# channel:      channel to limit associate to (default 0 [ANY])
# rtap_iface:   create the rtap interface (1 - create, default 0)
# mode: network mode (0=BSS,1=IBSS,2=Monitor)

### modules-update: end processing /etc/modules.d/ipw3945

### modules-update: start processing /etc/modules.d/ipw3945d
install ipw3945 /sbin/modprobe --ignore-install ipw3945; sleep 0.5; /sbin/ipw3945d --quiet
remove ipw3945 /sbin/ipw3945d --kill; /sbin/modprobe -r --ignore-remove ipw3945

### modules-update: end processing /etc/modules.d/ipw3945d


I am using standard configuration, no custom init scripts...
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4857
Location: Dark side of the mood

PostPosted: Mon Apr 24, 2006 6:41 am    Post subject: Reply with quote

Zidour, what's your version of baselayout, coldplug and hotplug?
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
Back to top
View user's profile Send private message
zidour
Tux's lil' helper
Tux's lil' helper


Joined: 29 Apr 2004
Posts: 103

PostPosted: Mon Apr 24, 2006 10:12 am    Post subject: Reply with quote

Here it is:

Code:

~ # esearch -c coldplug hotplug baselayout
[ N] sys-apps/coldplug (20040920):  coldplug init.d program to load modules at bootime
[ I] sys-apps/hotplug (20040923-r2):  USB and PCI hotplug scripts
[ I] sys-apps/baselayout (1.12.0_pre18):  Filesystem baselayout and init scripts


i.e. coldplug is not installed. As far as I know it is deprecated anyway...

Thanks, VinzC!
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4857
Location: Dark side of the mood

PostPosted: Mon Apr 24, 2006 12:17 pm    Post subject: Reply with quote

zidour wrote:
Here it is:

Code:

~ # esearch -c coldplug hotplug baselayout
[ N] sys-apps/coldplug (20040920):  coldplug init.d program to load modules at bootime
[ I] sys-apps/hotplug (20040923-r2):  USB and PCI hotplug scripts
[ I] sys-apps/baselayout (1.12.0_pre18):  Filesystem baselayout and init scripts


i.e. coldplug is not installed. As far as I know it is deprecated anyway...

Thanks, VinzC!

The packages I have are less recent though :roll: ... Have you run etc-update, modules-update, all that stuff?

EDIT: how about your udev version?
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4857
Location: Dark side of the mood

PostPosted: Mon Apr 24, 2006 12:29 pm    Post subject: Reply with quote

zidour wrote:
Then if i put "ipw3945" into /etc/modules.autoload.d/kernel-2.6, the module is loaded at boot, but the daemon is not started (if I modprobe the module by hand, the daemon IS started automatically and if I modporbe -r the module by hand, the daemon IS stopped automatically).

My /etc/modules.autoload.d/kernel-2.6 file only contains evdev, which fixes a problem with the touchpad. Try removing ipw3945 and putting evdev there. The latter must be compiled as a module, of course (you'd have bet ;) ).
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
Back to top
View user's profile Send private message
zidour
Tux's lil' helper
Tux's lil' helper


Joined: 29 Apr 2004
Posts: 103

PostPosted: Mon Apr 24, 2006 4:35 pm    Post subject: Reply with quote

Thanks for your suggestions....

I am running ~x86 architecture, so I have a quite recent udev...

Code:

radegast2 martin # esearch -c udev
[ I] sys-fs/udev (090):  Linux dynamic and persistent device naming support (aka userspace devfs)


I am quite sure that etc-update and modules-update is not the problem here.

I also tried removing ipw3945 from modules.autoload - did not work.

What I forgot is that I edited /etc/conf.d/rc file:
Code:

# Dynamic /dev managers can trigger coldplug events which cause services to
# start before we are ready for them. If this happens, we can defer these
# services to start in the boot runlevel. If you don't want this then set
# RC_COLDPLUG to no.
# For more fine grained control you can list full service names to allow
# them to coldplug and prefix them with ! so they don't coldplug.
# Example - RC_COLDPLUG="net.wlan !net.*"
# This allows net.wlan and any service not matching net.* to coldplug.

RC_COLDPLUG="no"


The problem is that if RC_COLDPLUG is set to "yes" (default), init scripts try to bring eth0 up even if net.eth0 is not in any runlevel.
I solved this problem by setting it to "no".

I must admit that I don't understand the consequences of this setting completely, so I thought resetting RC_COLDPLUG back to "yes" might help.
But it did not...

Still, ipw3945 gets loaded (supposedly by udev), but the daemon is not run.
If I rmmod and modprobe ipw3945 again, everything starts working again...
Back to top
View user's profile Send private message
zidour
Tux's lil' helper
Tux's lil' helper


Joined: 29 Apr 2004
Posts: 103

PostPosted: Mon Apr 24, 2006 5:46 pm    Post subject: Reply with quote

Well, I was looking around a bit and this is what I have found:

1) ipw3945 is inserted when udev is started. This is done at boot by "/lib/rcscripts/addons/udev-start.sh". Unfortunately I don't know what mechanism udev uses for inserting modules (is it possible that it is just insmoding instead of modprobing?). Anyway, when the module is inserted by udev, the daemon is not started.

2) An obvious resolution to my problem is to prevent udev from inserting ipw3945 module and modprobe it later (I think that just writing ipw3945 into /etc/modules.autoload.d/kernel-2.6 should work). However, I have no idea how to tell udev not to load ipw3945.
Blacklisting ipw3945 in /etc/hotplug/blacklist does not work.
May be it has something to do with this bug: https://bugs.gentoo.org/show_bug.cgi?id=130766.

It seems to me that udev is to blame...
Back to top
View user's profile Send private message
HomerJ
n00b
n00b


Joined: 12 Sep 2003
Posts: 34

PostPosted: Mon Apr 24, 2006 6:32 pm    Post subject: Reply with quote

What prevents you from letting the module load by itself, and start the daemon in local.start or with a custom init.d script?

I had the same problem, but it automagically fixed itself on my 6th attempt to intall gentoo!
_________________
* Inspiron 6400/e1505
* Intel Core Duo CPU 2.00 GHz
* ATI X1400
Back to top
View user's profile Send private message
zidour
Tux's lil' helper
Tux's lil' helper


Joined: 29 Apr 2004
Posts: 103

PostPosted: Mon Apr 24, 2006 7:01 pm    Post subject: Reply with quote

You are right, nothing...

But it would be nicer and cleaner if it worked as it is supposed to work... anyway, I think starting the daemon somewhere in local.start will do it for now...

Quote:

I had the same problem, but it automagically fixed itself on my 6th attempt to intall gentoo!


Unfortunately I am not that patient :)
Back to top
View user's profile Send private message
LD
Guru
Guru


Joined: 23 Dec 2003
Posts: 336
Location: Middle of No-Where Granbury, Tx

PostPosted: Wed Apr 26, 2006 2:32 am    Post subject: Reply with quote

I'm having issues with range. I was able to get to my couch before with Windows on this thing. I can't get past my work desk now with wireless connectivity. Any one else having issues with this? Is there a setting I missed?
_________________
[Owner/Operator: Dhampir Dreams]
Last.fm profile
Netflix Profile
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4857
Location: Dark side of the mood

PostPosted: Wed Apr 26, 2006 11:31 am    Post subject: Reply with quote

LD wrote:
I'm having issues with range. I was able to get to my couch before with Windows on this thing. I can't get past my work desk now with wireless connectivity. Any one else having issues with this? Is there a setting I missed?

Maybe the big refrigerator in the middle of the path? ;-)
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
Back to top
View user's profile Send private message
Trev
n00b
n00b


Joined: 01 Feb 2005
Posts: 9

PostPosted: Wed Apr 26, 2006 12:14 pm    Post subject: Update baselayout worked for me Reply with quote

Hello,

I have been banging my head against this wall for sometime now. The problem I was getting was all modules would load but I couldn't associate to the AP using WPA.

Updating baselayout to the latest stable solved the problem. Here is the list of relevant packages:

[I--] [ ] net-wireless/ipw3945-1.0.1 (0)
[I--] [ ] net-wireless/ipw3945-ucode-1.13 (0)
[I--] [ ] net-wireless/ipw3945d-1.7.18 (0)
[I--] [ ] net-wireless/ieee80211-1.1.13-r1 (0)
[I--] [ ] sys-kernel/gentoo-sources-2.6.16-r3 (2.6.16-r3)
[I--] [ ] sys-apps/baselayout-1.11.14-r8 (0)

A few notes:
-You must run the remove-old script to remove the in-kernel 80211 stack
-You must have (as a module or compiled in) support for michael_mic and arc4 crypto types (you may need aes as well)

For me the last piece was to upgrade baselayout from 1.11.14-r4 to 1.11.14-r8. I hope this helps. The other posts here have been helpful. Thanks a lot
Back to top
View user's profile Send private message
sashak
n00b
n00b


Joined: 29 Apr 2006
Posts: 1

PostPosted: Sat Apr 29, 2006 6:38 pm    Post subject: Reply with quote

zidour wrote:
Well, I was looking around a bit and this is what I have found:

1) ipw3945 is inserted when udev is started. This is done at boot by "/lib/rcscripts/addons/udev-start.sh". Unfortunately I don't know what mechanism udev uses for inserting modules (is it possible that it is just insmoding instead of modprobing?). Anyway, when the module is inserted by udev, the daemon is not started.


In my case the daemon is started, but fails - /var fs is readonly at this moment and ipw3945d cannot write /var/run/ipw3945d.pid file. (actually you may see this when replacing 'ipw3945d --quiet' by ipw3945d > /dev/ipwd.log 2>&1 in /etc/modprobe.conf ). Unfortunatly ipw3945d is binary-only and after looking at 'strings ipw3945d' I cannot see obviuos way to reconfig the daemon itself. However such ugly workaround should help:
Code:

mv /var/run/ipw3945d.pid /dev
ln -s /dev/ipw3945d.pid /var/run/

Good luck.
Back to top
View user's profile Send private message
zidour
Tux's lil' helper
Tux's lil' helper


Joined: 29 Apr 2004
Posts: 103

PostPosted: Mon May 01, 2006 5:58 pm    Post subject: Reply with quote

To sashak:

OK, this sounds logical...
I will give it a try when I get home.
Back to top
View user's profile Send private message
TrevorCampbell
n00b
n00b


Joined: 16 Apr 2006
Posts: 15

PostPosted: Mon May 15, 2006 9:37 am    Post subject: Reply with quote

zidour wrote:
To sashak:

OK, this sounds logical...
I will give it a try when I get home.


I have the same problem, but the driver says it loads OK.. I get no errors in the ipwd.log using the above hack. Also the driver loads after the root file system is remonted as readwrite.

I usually
Code:
# rmmod ipw3945
# modprobe ipw3945

and then all works, but it is a PITA to do each time.
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4857
Location: Dark side of the mood

PostPosted: Mon May 15, 2006 9:44 am    Post subject: Reply with quote

@TrevorCampbell

First you should use modprobe -r instead of rmmod. I had also such troubles with ipw3945 but the latest version from portage (1.0.2) seemed to fix these (you'll probably have to unmask them using ~ARCH).
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Goto page Previous  1, 2, 3 ... 5, 6, 7 ... 30, 31, 32  Next
Page 6 of 32

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum