Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200602-08 ] libtasn1, GNU TLS: Security flaw in DER decoding
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Thu Feb 16, 2006 9:20 pm    Post subject: [ GLSA 200602-08 ] libtasn1, GNU TLS: Security flaw in DER d Reply with quote

Gentoo Linux Security Advisory

Title: libtasn1, GNU TLS: Security flaw in DER decoding (GLSA 200602-08)
Severity: high
Exploitable: remote
Date: February 16, 2006
Bug(s): #122307
ID: 200602-08

Synopsis

A flaw in the parsing of Distinguished Encoding Rules (DER) has been discovered in libtasn1, potentially resulting in the execution of arbitrary code.

Background

Libtasn1 is a library used to parse ASN.1 (Abstract Syntax Notation One) objects, and perform DER (Distinguished Encoding Rules) decoding. Libtasn1 is included with the GNU TLS library, which is used by applications to provide a cryptographically secure communications channel.

Affected Packages

Package: dev-libs/libtasn1
Vulnerable: < 0.2.18
Unaffected: >= 0.2.18
Architectures: All supported architectures

Package: net-libs/gnutls
Vulnerable: < 1.2.10
Unaffected: >= 1.2.10
Architectures: All supported architectures


Description

Evgeny Legerov has reported a flaw in the DER decoding routines provided by libtasn1, which could cause an out of bounds access to occur.

Impact

A remote attacker could cause an application using libtasn1 to crash and potentially execute arbitrary code by sending specially crafted input.

Workaround

There is no known workaround at this time.

Resolution

All libtasn1 users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/libtasn1-0.2.18"
All GNU TLS users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-libs/gnutls-1.2.10"


References

CVE-2006-0645


Last edited by GLSA on Sat Feb 16, 2008 4:17 am; edited 3 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum