Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[EMERGE] Problemas al compilar graphviz (Solucionado)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Popolous
Apprentice
Apprentice


Joined: 04 Aug 2003
Posts: 239

PostPosted: Fri May 29, 2009 8:16 am    Post subject: [EMERGE] Problemas al compilar graphviz (Solucionado) Reply with quote

¡Buenas!

He estado un tiempo fuera de casa por razones de trabajo y ayer me decidí a actualizar Gentoo. Después del emerge --sync de rigor, vino el emerge -uavDN world. Todo fue bien, algún error de compilación que subsané tras revisar las USE flags y seguí actualizando (eran la friolera de más de 590 paquetes...).

Al llegar al paquete graphviz me da el siguiente error de compilación:

Quote:

media-gfx/graphviz-2.22.2-r1 failed to compile: libgvplugin_gd.so: undefined reference to `gd_psfontResolve'


Hace un mes me volvió a pasar lo mismo e hice un reporte de fallos. Pero hasta la fecha no he podido encontrar nada que me permita arreglar este error y continuar. En google no he visto nada más que el bug que os he citado más arriba. ¿Tiene que ver con alguna USE flag? ¿Algún paquete que entre en conflicto?

La verdad es que ya no sé qué hacer para que compile. A ver si me podéis echar una mano.

¡Saludos!


Last edited by Popolous on Sat May 30, 2009 6:38 pm; edited 3 times in total
Back to top
View user's profile Send private message
chakenio
n00b
n00b


Joined: 30 Sep 2008
Posts: 53

PostPosted: Fri May 29, 2009 10:28 am    Post subject: Re: [EMERGE] Problemas al compilar graphviz Reply with quote

Buenas que tal, mira la verdad el error ni idea. Googleando un poco, comprendo que es un error de linkeo, el compilador no esta encontrando la libreria `gd_psfontResolve'. Podes poner un emerge --info, hiciste luego revdep-rebuild.

Saludos!
Back to top
View user's profile Send private message
Popolous
Apprentice
Apprentice


Joined: 04 Aug 2003
Posts: 239

PostPosted: Fri May 29, 2009 10:42 am    Post subject: Reply with quote

¡Hola!

La verdad es que ahora os pongo emerge --info, está con un revdep-rebuild y probaré de nuevo a hacer el emerge -uavDN world. No he visto la librería 'gd_psfontResolve' en la lista de dependencias rotas, pero bueno...a ver si se resuelve así.

Os mantengo informados, gracias de nuevo por la ayuda.

¡Saludos!
Back to top
View user's profile Send private message
Popolous
Apprentice
Apprentice


Joined: 04 Aug 2003
Posts: 239

PostPosted: Fri May 29, 2009 11:05 am    Post subject: Reply with quote

Pues terminó de hacer el revdep-rebuild y nada...sigue fallando. Ahora estoy actualizando python, con el python-updater. También he probado con

Code:

fix_libtoolfiles 4.3.2


Pero no ha encontrado nada que arreglar.

Sigo viendo a ver, cualquier ayuda es bien recibida.

¡Saludos!
Back to top
View user's profile Send private message
Inodoro_Pereyra
Advocate
Advocate


Joined: 03 Nov 2006
Posts: 2631
Location: En la otra punta del cable

PostPosted: Fri May 29, 2009 6:28 pm    Post subject: Reply with quote

Y si bajas graphviz a la rama estable compila?

Por lo que veo es dependencia de imagemagick, supongo -no tiengo tiempo de comprobarlo ya mismo- que el use flag de imagemagick que dispara la instalación de graphviz es svg. Si no usas un webserver o alguna aplicación que genere gráficos SVG en un archivo html podrías simplemente quitarle la use a imagemagick y ya con eso no necesitarías del paquete conflictivo.

Por las dudas asegurate corriendo:
Code:
equery depends graphviz


Salud!
_________________
Mi Blog.

Si no fuera por C, estaríamos escribiendo programas en BASI, PASAL y OBOL.
Back to top
View user's profile Send private message
Popolous
Apprentice
Apprentice


Joined: 04 Aug 2003
Posts: 239

PostPosted: Fri May 29, 2009 9:20 pm    Post subject: Reply with quote

Inodoro_Pereyra wrote:
Y si bajas graphviz a la rama estable compila?



He rebajado hasta la versión 2.22 y el fallo sigue siendo el mismo. Debe ser algo de base, pero lo que haré será mirar el imagemagick y desactivar la USE flag que me dices a ver si es eso.

¡Saludos!
Back to top
View user's profile Send private message
Popolous
Apprentice
Apprentice


Joined: 04 Aug 2003
Posts: 239

PostPosted: Sat May 30, 2009 11:29 am    Post subject: Reply with quote

Pues nada, sigo estancado :cry:. He probado a poner en /etc/portage/package.mask el paquete, pero hay varios más que dependen de él:

Quote:

media-gfx/exiv2
kde-base/gwenview
kde-base/kdegraphics-meta
kde-base/kde-meta
word


Después, lo he quitado del archivo (he comentado la línea) para no bloquearlo y he probado a emerger exiv2 con los parámetros del emerge -av para ver qué USE tiene activadas, pero no he visto la flag svb para deshabilitarla...

En fin, no sé qué más puedo hacer. He rebajado 3 versiones el graphviz y me da el mismo error. Alguna librería debo tener mal instalada (o no instalada o corrupta) pero no sé cuál es.

Por cierto, el comando:

Code:

equery depends graphviz


No arroja ningún resultado :?

¡Saludos!
Back to top
View user's profile Send private message
Popolous
Apprentice
Apprentice


Joined: 04 Aug 2003
Posts: 239

PostPosted: Sat May 30, 2009 11:39 am    Post subject: Reply with quote

¡Hola!

También posteo la salida del comando emerge --info:

Quote:

Portage 2.1.6.11 (default/linux/x86/2008.0, gcc-4.3.3, glibc-2.9_p20081201-r2,
2.6.29-gentoo-r1 i686)
=================================================================
System uname:
Linux-2.6.29-gentoo-r1-i686-Intel-R-_Core-TM-2_CPU_T7200_@_2.00GHz-with-gentoo-2.0.0
Timestamp of tree: Fri, 24 Apr 2009 17:30:01 +0000
distcc 3.1 i686-pc-linux-gnu [disabled]
ccache version 2.4 [disabled]
app-shells/bash: 4.0_p17-r1
dev-java/java-config: 2.1.7
dev-lang/python: 2.4.4-r15, 2.5.4-r2, 2.6.2
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache: 2.4-r8
dev-util/cmake: 2.6.3-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc: 0.4.3-r2
sys-apps/sandbox: 1.9
sys-devel/autoconf: 2.13, 2.63-r1
sys-devel/automake: 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils: 2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool: 2.2.6a
virtual/os-headers: 2.6.28-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config
/usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/
/etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release
/etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/
/etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash
/etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d
/etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sfperms strict
unmerge-orphans userfetch userpriv"
GENTOO_MIRRORS=" http://ftp.udc.es/gentoo/ http://trumpetti.atm.tut.fi/gentoo/
http://cesium.di.uminho.pt/pub/gentoo"
LDFLAGS="-Wl,-O1"
LINGUAS="es es_ES es_ES.UTF-8"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--timeout=180"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress
--force --whole-file --delete--stats --timeout=180 --exclude=/distfiles
--exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp/"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl berkdb bzip2 cli cracklib crypt cups doc dri examples fortran gdbm
gnome gpm iconv ipv6 isdnlog java kde midi mudflap ncurses nls nptl nptlonly
openmp pam pcre perl pppd python qt3 qt4 readline reflection session spl ssl
sysfs tcpd unicode x86 xorg zlib" ALSA_CARDS="hda-intel"
ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file
hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi nullplug
rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic
auth_digest authn_anon authn_dbdauthn_dbm authn_default authn_file authz_dbm
authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache
dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter
file_cache filter headers ident imagemap include info log_config logio
mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer
proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir
usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="mouse keyboard evdev
synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780
lb216 lcdm001 mtxorb ncurses text" LINGUAS="es es_ES es_ES.UTF-8"
LIRC_DEVICES="alsa_usb hauppauge" USERLAND="GNU" VIDEO_CARDS="fglrx vesa"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG,
LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS


¡Saludos!
Back to top
View user's profile Send private message
Txema
l33t
l33t


Joined: 20 May 2008
Posts: 767
Location: Granada

PostPosted: Sat May 30, 2009 12:14 pm    Post subject: Reply with quote

Manda huevos, la USE doc de exiv2 no apunta a documentación sino a otros 5 paquetes que nada tienen que ver con documentación...
Code:
    doc? (
        dev-lang/python
        app-doc/doxygen
        dev-libs/libxslt
        dev-util/pkgconfig
        media-gfx/graphviz
    )


Tiene fácil solución, desactiva la USE doc (yo la tengo quitada en todo el sistema y nunca la he necesitado)

Saludos.
Back to top
View user's profile Send private message
Popolous
Apprentice
Apprentice


Joined: 04 Aug 2003
Posts: 239

PostPosted: Sat May 30, 2009 12:17 pm    Post subject: Reply with quote

¡Madre mía!

Pues mira que he estado pensando en desactivarla porque era la única USE flag común en todos los paquetes que he pegado anteriormente. Voy a probar y como sea esto me tendré que dar mil latigazos por mi torpeza supina...

¡Saludos!
Back to top
View user's profile Send private message
Popolous
Apprentice
Apprentice


Joined: 04 Aug 2003
Posts: 239

PostPosted: Sat May 30, 2009 12:25 pm    Post subject: Reply with quote

Bueno, parece que ahora está compilando sin que aparezca en el listado (creo) el dichoso graphviz. Son 319 paquetes y antes eran 320 así que imagino que no aparecerá, no me ha dado tiempo a verlos cuando avanzaban la pantalla, pero tengo el graphviz en package.mask así que supongo que estará ya desactivado.

Espero que no haya ya más errores y pueda volver a iniciar las X sin problemas, ya que antes de actualizar se me quedaba la pantalla negra. Voy a esperar que terminen las actualizaciones y a ver qué pasa.

Muchísimas gracias por la ayuda

¡Saludos!
Back to top
View user's profile Send private message
Popolous
Apprentice
Apprentice


Joined: 04 Aug 2003
Posts: 239

PostPosted: Sat May 30, 2009 1:00 pm    Post subject: Reply with quote

Pues he cantado victoria demasiado pronto...Estaba entre los paquetes, y sigue dando errores de compilación, aún desactivando globalmente la variable USE = doc.

El paquete conflictivo ahora es doxygen que no me deja enmascararlo porque depende de graphviz y si enmascaro doxygen hay otros que dependen de él...vamos que esto puede convertirse en la pescadilla que se muerde la cola.

Voy a seguir indagando, alguna solución distinta de reinstalar todo debe haber.

¡Saludos!
Back to top
View user's profile Send private message
Txema
l33t
l33t


Joined: 20 May 2008
Posts: 767
Location: Granada

PostPosted: Sat May 30, 2009 1:05 pm    Post subject: Reply with quote

A ver... descripción del paquete doxygen: (paquete que yo no tengo instalado por cierto)
Quote:
documentation system for C++, C, Java, Objective-C, Python, IDL, and other languages

¿Seguro que has desactivado la USE doc? y ¿seguro que has añadido la opción -N al emerge para que lo tenga en cuenta?

Pega la salida de emerge -pvuND world, si no tienes X solo tienes que redirigirlo a un archivo:
Code:
emerge -pvuND world > LOG

O usar less o more, lo que más te guste ;)

Saludos.
Back to top
View user's profile Send private message
Popolous
Apprentice
Apprentice


Joined: 04 Aug 2003
Posts: 239

PostPosted: Sat May 30, 2009 6:38 pm    Post subject: Reply with quote

¡Hola!

Sí Txema ha sido más torpeza mía que otra cosa. Después de darme el mismo error, desinstalé doxygen y ya todo va como la seda...Hasta que ha llegado a otro paquete ftlk.

Voy a buscar por el foro si este error se ha dado antes porque simplemente no me compila y el error que me da no es muy descriptivo.

Lo cambio a solucionado. Ahora sí.

¡Saludos!
Back to top
View user's profile Send private message
Txema
l33t
l33t


Joined: 20 May 2008
Posts: 767
Location: Granada

PostPosted: Sat May 30, 2009 7:32 pm    Post subject: Reply with quote

Mmm, no son exactamente las mismas versiones, pero échale un vistazo a esto: https://bugs.gentoo.org/show_bug.cgi?id=270487

Saludos.
Back to top
View user's profile Send private message
Popolous
Apprentice
Apprentice


Joined: 04 Aug 2003
Posts: 239

PostPosted: Sat May 30, 2009 7:51 pm    Post subject: Reply with quote

Mmmm pues parece ser que sí, que son la misma versión (al menos de fltk es la 1.1.9).

Voy a ver si me bajo el parche y se lo aplico a ver si va. Tendré que leerme cómo se aplican :oops: :oops:.

¡Saludos!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum