Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Teclado us_intl no xorg 7.0
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
gmichels
Guru
Guru


Joined: 20 Jun 2003
Posts: 480
Location: Brazil

PostPosted: Wed Feb 08, 2006 4:45 pm    Post subject: Teclado us_intl no xorg 7.0 Reply with quote

Pessoal

Alguém aqui já tentou realizar a migração pro xorg 7.0? Eu fiz aqui, mas estou tendo problemas pra configurar meu teclado, que é americano, pro padrão necessário pra português.

No xorg 6.8, eu sempre usei a seguinte configuração para meu teclado, e tudo funciona as mil maravilhas:
Code:
Section "InputDevice"
    Identifier  "Keyboard1"
    Driver      "kbd"
    Option "XkbModel"   "pc105"
    Option "XkbLayout" "us_intl"
    Option "AutoRepeat" "500 30"
EndSection

Porém, após a atualização pro xorg 7.0, eu perdi a função de algumas teclas importantes, tais como a tecla "windows" (que uso em combinações de atalhos) ou até mesmo a possibilidade de se fazer CTRL+ALT+F<N>.

Na documentação de migração, bem no final, existe uma nota sobre problemas com layout de teclado, inclusive citando a perda do CTRL+ALT+F<N>, mas mesmo com as configurações indicadas, eu não consigo fazer voltar a funcionar.

Alguém com problema semelhante que tenha encontrado uma solução?

Obrigado!
Back to top
View user's profile Send private message
baldeante
Guru
Guru


Joined: 17 Jan 2004
Posts: 498
Location: Caldas da Rainha, Portugal

PostPosted: Wed Feb 08, 2006 6:42 pm    Post subject: Reply with quote

Já experimentaste :

Code:

Option "XkbLayout" "us"

ou
Code:

Option "XkbLayout" "en"




... li num topico há uns dias que havia uma versão do xorg que não gostava muito de us_* ou en_* não me lembro bem qual mas acho que era numa versão mais antiga talvez tenha voltado a ter o mesmo problema ......
_________________
Never Quit, Never Get Mad, Get Even
Back to top
View user's profile Send private message
gmichels
Guru
Guru


Joined: 20 Jun 2003
Posts: 480
Location: Brazil

PostPosted: Wed Feb 08, 2006 7:10 pm    Post subject: Reply with quote

Tentei o descrito neste bug, que não fez diferença nenhuma no resultado.

Se eu colocar SOMENTE
Code:
Option "XkbLayout" "us"

sem nenhuma opção a mais, daí a tecla windows funciona, o CTRL+ALT+F<N> funciona, porém eu perco os deadkeys, não consigo mais acentuar nenhuma letra, etc.
Back to top
View user's profile Send private message
baldeante
Guru
Guru


Joined: 17 Jan 2004
Posts: 498
Location: Caldas da Rainha, Portugal

PostPosted: Thu Feb 09, 2006 9:39 am    Post subject: Reply with quote

Boas,

Estou baralhado o teclado é americano ou Português ???
_________________
Never Quit, Never Get Mad, Get Even
Back to top
View user's profile Send private message
gmichels
Guru
Guru


Joined: 20 Jun 2003
Posts: 480
Location: Brazil

PostPosted: Thu Feb 09, 2006 12:18 pm    Post subject: Reply with quote

É um notebook comprado nos EUA, então ele tem teclado americano :)

Até o momento não consegui solução, voltei pro xorg 6.8.2 onde tudo funciona normalmente.
Back to top
View user's profile Send private message
joaoemanuel1981
n00b
n00b


Joined: 24 Jan 2006
Posts: 19

PostPosted: Fri Feb 10, 2006 7:48 pm    Post subject: Reply with quote

Tenta usar a ferramenta de configuração do Xorg, ao invés da configuração manual. Pode ser que o módulo tenha trocado de nome. Além disso o módulo do teclado tem todos os teclados suportados ou ainda não?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum